Create bootable LMDE USB stick

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

Create bootable LMDE USB stick

Postby NTMan on Mon May 23, 2011 3:54 pm

Hi

First way I try create stick such as debian USB stick with dd command:
a) sudo dd if=/home/mikhail/Downloads/linuxmint-debian-201101-gnome-dvd-i386.iso of=/dev/sdd
b) Try boot
I get message: "Operating System not found"

Second way I try create stick with unetbootin-linux-549.
a) Format to fat32 from gparted
b) launch unetbootin-linux-549 and select linuxmint-debian-201101-gnome-dvd-i386.iso
c) Try boot
I get message: "BOOT FAILED!" details can be seen on the screenshot.
Image

I have no more ideas how to make a bootable USB stick with LMDE
NTMan
Level 1
Level 1
 
Posts: 8
Joined: Wed Jan 20, 2010 5:23 am

Linux Mint is funded by ads and donations.
 

Re: Create bootable LMDE USB stick

Postby linuxuser159 on Mon May 23, 2011 4:11 pm

what was the content of syslinux.cfg

the first method, you don't have a bootloader on the usb stick to boot the image

the second method, most likely, problem with syslinux.cfg file
linuxuser159
Level 2
Level 2
 
Posts: 97
Joined: Thu May 12, 2011 2:02 am

Re: Create bootable LMDE USB stick

Postby NTMan on Mon May 23, 2011 4:59 pm

linuxuser159 wrote:what was the content of syslinux.cfg

Code: Select all
default menu.c32
prompt 0
menu title UNetbootin
timeout 100

label unetbootindefault
menu label Default
kernel /ubnkern
append initrd=/ubninit boot=live live-media-path=/casper quiet splash -- persistent

label ubnentry0
menu label Start Linux Mint
kernel /casper/vmlinuz
append initrd=/casper/initrd.lz boot=live  live-media-path=/casper quiet splash -- persistent

label ubnentry1
menu label Start Linux Mint (compatibility mode)
kernel /casper/vmlinuz
append initrd=/casper/initrd.lz boot=live xforcevesa  live-media-path=/casper ramdisk_size=1048576 root=/dev/ram rw noapic noapci nosplash irqpoll -- persistent

label ubnentry2
menu label Check the integrity of the DVD
kernel /casper/vmlinuz
append initrd=/casper/initrd.lz boot=live integrity-check  live-media-path=/casper persistent

label ubnentry3
menu label Memory Test
kernel /isolinux/memtest
append initrd=/ubninit  persistent

label ubnentry4
menu label Boot from local drive
kernel /ubnkern
append initrd=/ubninit  persistent


linuxuser159 wrote:the first method, you don't have a bootloader on the usb stick to boot the image

Ok, how create bootloader on the usb stick in this case?

linuxuser159 wrote:the second method, most likely, problem with syslinux.cfg file

Thanks for quick response, I will be hope listen description this problem.
NTMan
Level 1
Level 1
 
Posts: 8
Joined: Wed Jan 20, 2010 5:23 am

Re: Create bootable LMDE USB stick

Postby linuxuser159 on Mon May 23, 2011 6:00 pm

i cannot really judge the cfg file because i dont have a USB stick to try and see how unetbootin places the files on the stick

instead of unetbootin, try to manually do everything which is easy and straightforward

to make it easier to test your usb, install qemu first

and

Code: Select all
qemu /dev/sdd


which will emulate the boot up process and see what would happen without actually booting your computer. however, i found that sometimes qemu does not behave like the real thing.

you can manually create the bootloader:

GRUB2 Bootloader Example
Grub2 USB Flash Drive Install using the Ubuntu Live CD:

1. Boot from your Live Ubuntu Linux CD
2. Once booted, insert your USB Flash Drive
3. Open a terminal and type sudo su
4. Type fdisk -l (and note which device is your USB)
5. Type mkdir /mnt/USB && mount /dev/sdx1 /mnt/USB (replacing x with your actual usb device)
6. Type grub-install --force --no-floppy --root-directory=/mnt/USB /dev/sdx (replacing x with your actual USB device)
7. Type cd /mnt/USB/boot/grub
8. Type wget pendrivelinux.com/downloads/grub.cfg
9. Type df (and locate where cdrom is mounted I.E./dev/sr0)
10. Type dd if=/dev/sr0 of=/mnt/USB/ubuntu.iso (replacing sr0 with the device found in step 9)
11. Remove your Live CD and reboot your PC, setting your BIOS or Boot Menu to boot from the USB device.


source: http://www.pendrivelinux.com/install-gr ... ntu-linux/

You do not have to use the
Code: Select all
dd if=/... of=/...
if you downloaded the iso image of the live CD directly from the net. You just copy it to the usb stick

The first 5 steps are not necessary since you have already formatted your usb stick and mounted it. My computer auto-mounts my usb stick and I use gparted to format it.
Last edited by linuxuser159 on Wed May 25, 2011 5:22 pm, edited 6 times in total.
linuxuser159
Level 2
Level 2
 
Posts: 97
Joined: Thu May 12, 2011 2:02 am

Re: Create bootable LMDE USB stick

Postby casey972oo on Mon May 23, 2011 6:08 pm

Hi there ! ... I don't know ! ...

but I didn't have no problem at all ! ...
first i did download the ' .iso-image ' from ' linuxmint ! ...
then I burned it on a CD ... ' live-environment ' ! ...
and it did install by himself ! ... Lol ! ... (like I say) ...

but this will work as well with ' unetbootin ' ! ...
to burn the ' .iso-image ' on a USB-Stick ! ...

just clean this stick first ! ...

casey972oo

.
casey972oo
Level 4
Level 4
 
Posts: 347
Joined: Tue Mar 22, 2011 6:26 pm

Re: Create bootable LMDE USB stick

Postby NTMan on Tue May 24, 2011 12:11 pm

I use follow instruction:
Grub2 USB Flash Drive Install using the Ubuntu Live CD:

1. Boot from your Live Ubuntu Linux CD
2. Once booted, insert your USB Flash Drive
3. Open a terminal and type sudo su
4. Type fdisk -l (and note which device is your USB)
5. Type mkdir /mnt/USB && mount /dev/sdx1 /mnt/USB (replacing x with your actual usb device)
6. Type grub-install --force --no-floppy --root-directory=/mnt/USB /dev/sdx (replacing x with your actual USB device)
7. Type cd /mnt/USB/boot/grub
8. Type wget pendrivelinux.com/downloads/grub.cfg
9. Type df (and locate where cdrom is mounted I.E./dev/sr0)
10. Type dd if=/dev/sr0 of=/mnt/USB/ubuntu.iso (replacing sr0 with the device found in step 9)
11. Remove your Live CD and reboot your PC, setting your BIOS or Boot Menu to boot from the USB device.

But my USB stick still not properly bootable.
Image

Are you sure that this instruction suitable also for Linux Mint Debian?
NTMan
Level 1
Level 1
 
Posts: 8
Joined: Wed Jan 20, 2010 5:23 am

Re: Create bootable LMDE USB stick

Postby linuxuser159 on Tue May 24, 2011 7:18 pm

the instructions should be suitable. the LMDE ISO is similar to ubuntu. Both have a CASPER folder which contains the vmlinuz and initrd.lz. and CASPER folder should be directly under ubuntu.iso if you followed instructions. And ubuntu.iso should be directly placed on USB with the boot folder. Then the grub.cfg file you wget from pendrive should work. what is important is grub.cfg file pointing to the right location of vmlinuz and initrd.lz.

if you set it up correctly, try to do an actually booting with the USB. i had similar problem when I tried to qemu a USB partition with ubuntu. qemu did not work but i booted with this USB anyways on netbook and it worked.

===============
edit
===============

i've just noticed that LMDE has a problem with boot splash

http://www.linuxmint.com/rel_debian.php

So, i checked the isolinux.cfg file which should be similar to what you put in the grub.cfg file

the isolinux.cfg file uses the

Code: Select all
quiet splash --


so, try to put a "quiet" before "splash --" in the grub.cfg file. the quiet command does not disable splash. it is just placed before splash

content of isolinux.cfg
Code: Select all
label live
  menu label Start Linux Mint
  kernel /casper/vmlinuz
  append boot=live initrd=/casper/initrd.lz live-media-path=/casper quiet splash --


this way you are booting exactly as the CD would boot for LMDE
linuxuser159
Level 2
Level 2
 
Posts: 97
Joined: Thu May 12, 2011 2:02 am

Re: Create bootable LMDE USB stick

Postby linuxuser159 on Tue May 24, 2011 8:37 pm

check out following links

https://bugs.launchpad.net/linuxmint/+bug/636798

viewtopic.php?f=46&t=55543


it is not a bug. just have to tweak the cfg file correctly.
linuxuser159
Level 2
Level 2
 
Posts: 97
Joined: Thu May 12, 2011 2:02 am

Re: Create bootable LMDE USB stick

Postby NTMan on Tue May 24, 2011 10:31 pm

very very strange....
my grub.cfg
menuentry "LMDE" {
loopback loop /LMDE.iso
linux (loop)/casper/vmlinuz boot=live initrd=/casper/initrd.lz live-media-path=casper quiet splash --
initrd (loop)/casper/initrd.lz
}

And I have follow error:
Image
Strange because (initramfs) cat /live/image/casper/filesystem.squashfs show me content of filesystem.squashfs
NTMan
Level 1
Level 1
 
Posts: 8
Joined: Wed Jan 20, 2010 5:23 am

Re: Create bootable LMDE USB stick

Postby linuxuser159 on Wed May 25, 2011 4:16 am

you got

Code: Select all
loop /LMDE.iso


did you name the iso file LMDE instead of ubuntu ? the loop argument must match the name of the iso folder you place next to boot folder on the USB stick. this is how grub will know where vmlinuz and initrd.lz are located.
linuxuser159
Level 2
Level 2
 
Posts: 97
Joined: Thu May 12, 2011 2:02 am

Re: Create bootable LMDE USB stick

Postby NTMan on Wed May 25, 2011 2:22 pm

linuxuser159 wrote:you got

Code: Select all
loop /LMDE.iso


did you name the iso file LMDE instead of ubuntu ? the loop argument must match the name of the iso folder you place next to boot folder on the USB stick. this is how grub will know where vmlinuz and initrd.lz are located.


Yes, of cource
Image

I also try direct method without iso
Code: Select all
menuentry "LMDE" {
   linux /casper/vmlinuz boot=live live-media-path=/casper quiet splash --
   initrd /casper/initrd.lz
}

but always has get error described here
NTMan
Level 1
Level 1
 
Posts: 8
Joined: Wed Jan 20, 2010 5:23 am

Re: Create bootable LMDE USB stick

Postby linuxuser159 on Wed May 25, 2011 5:23 pm

i see ... you are supposed to keep all files inside the iso image and place the image next to /boot folder. this is because you are using loop command to tell grub to mount the iso image.


lets start over with a new method

1) Format USB as FAT32 and make bootable

2) Extract the content of the iso image and place on USB

3) Rename the isolinux folder to syslinux

4) Go inside the newly renamed syslinux folder and rename the isolinux.bin and isolinux.cfg files to syslinux.bin and syslinux.cfg

5)
Code: Select all
sudo apt-get install syslinux


6)
Code: Select all
sudo syslinux /dev/sdb
or whatever the USB device is

7)
Code: Select all
qemu /dev/sdb


i've just tried it with ubuntu 11.04 and it worked
linuxuser159
Level 2
Level 2
 
Posts: 97
Joined: Thu May 12, 2011 2:02 am

Re: Create bootable LMDE USB stick

Postby NTMan on Wed May 25, 2011 6:51 pm

lets start over with a new method

1) Format USB as FAT32 and make bootable
2) Extract the content of the iso image and place on USB
3) Rename the isolinux folder to syslinux
4) Go inside the newly renamed syslinux folder and rename the isolinux.bin and isolinux.cfg files to syslinux.bin and syslinux.cfg
5)
Code: Select all
sudo apt-get install syslinux

6)
Code: Select all
sudo syslinux /dev/sdb
or whatever the USB device is
7)
Code: Select all
qemu /dev/sdb



Unfortunately this method not worked too :(
SYSLINUX print message that vesamenu.c32 not a COM32R image.

Image

When I in syslinux.cfg change "default vesamenu.c32" to "default /casper/vmlinuz" I have another error:

Image

i've just tried it with ubuntu 11.04 and it worked


ubuntu 11.04 and Debian squeeze i can simple write to stick with dd command, and it will be work.
But I want launch LMDE on my netbook.

P.S. The image of LMDE 100% working I'm playing it in VirtualBox.
NTMan
Level 1
Level 1
 
Posts: 8
Joined: Wed Jan 20, 2010 5:23 am

Re: Create bootable LMDE USB stick

Postby linuxuser159 on Wed May 25, 2011 7:03 pm

you are right. i tried it with LMDE x64 and got same message

i google the problem. someone says after you get the message "not com32 image ....", type

boot: live


it will keep booting. i tried this and it worked.

another person suggested to type

Code: Select all
boot: help
linuxuser159
Level 2
Level 2
 
Posts: 97
Joined: Thu May 12, 2011 2:02 am

Re: Create bootable LMDE USB stick

Postby NTMan on Wed May 25, 2011 10:13 pm

Correct answer is "live". About "help" variant I knew before it, but "help" realy not helped me :)

Ok, qemu seems now can loading, but on real hardware instead SYSLINUX prompt, I see black screen and blink cursor on left top corner :(
NTMan
Level 1
Level 1
 
Posts: 8
Joined: Wed Jan 20, 2010 5:23 am

Re: Create bootable LMDE USB stick

Postby linuxuser159 on Thu May 26, 2011 10:30 am

this is all i know about this subject. you must be overlooking something like BIOS settings for booting a USB stick. when i installed ubuntu on my netbook, my USB hard disk was recognized as a second hard disk, not as a USB flash drive. so, i booted it as a hard disk.

how about try to format the usb stick as a ext4 and use grub-install again.

syslinux is designed for fat32. there is also extlinux for the ext format.
linuxuser159
Level 2
Level 2
 
Posts: 97
Joined: Thu May 12, 2011 2:02 am

Re: Create bootable LMDE USB stick

Postby casper911ca on Tue Dec 20, 2011 1:51 pm

I am using linuxmint-201109-xfce-dvd-64bit.iso
Extracted it into a bootable FAT32 usb stick
changed the file names and the folder names
ran syslinux
everything worked up to running qemu. I do not get the com32 error but get this instead in the terminal that pops up.
Code: Select all
sudo qemu /dev/sdb1
open /dev/kvm: No such file or directory
Could not initialize KVM, will disable KVM support
pci_add_option_rom: failed to find romfile "pxe-rtl8139.bin"

Code: Select all
SYSLINUX 4.01 debian-20100714 EDD Copyright (C) 1994-2010 H. Peter Alvin et al
ERROR: No configuration file found
No DEFAULT of UI configuration directive found
boot:

Image
casper911ca
Level 1
Level 1
 
Posts: 1
Joined: Tue Dec 20, 2011 1:31 pm

Re: Create bootable LMDE USB stick

Postby Oscar799 on Tue Dec 20, 2011 2:25 pm

Moved here by moderator
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8698
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Create bootable LMDE USB stick

Postby spandey on Fri Dec 23, 2011 6:32 am

Here are simple steps I follow which work for LMDE
1. Download ISO
2. Using Gparted delete all partitions in USB
3. Create a new FAT32 partition in USB large enough(say 2 GB) and mark sure to mark the bootable flag
4. Use Unetbootin and select diskimage option to write the ISO to USB
5. Boot the pc using USB

No manual writing of any files. It has worked for me for several installations without error.
Linux Mint 13 - Mate 64 Bit
spandey
Level 4
Level 4
 
Posts: 436
Joined: Sat Feb 20, 2010 1:23 pm

Re: Create bootable LMDE USB stick

Postby mrsfixit on Fri Dec 23, 2011 2:42 pm

I spent the day yesterday playing with LMDE.
My intent was to create a live usb *persistent* install so I could save my changes.
I started with a LMDE live usb stick I made about a month ago. I created it by this method:

1. Downloaded ISO.
2. Formatted the thumb drive as FAT32.
3. Used Unetbootin, selected disk image and wrote it to the thumb drive.

I did this on my desktop, which runs Ubuntu 10.04.

It worked, I've used it a few times, but it didn't save the changes, which was annoying. And the wifi didn't work.

I had a day to myself yesterday, and was hankering to experiment. Just for fun, I booted up my Acer ultraportable from the LMDE thumb drive.

I then formatted an 8 GB SD card, and plugged that into the laptop as well.

Using the install applet on the desktop, I did a full install from the 2 GB thumb drive to the 8 GB flash card.

The installer gave me a tiny bit of grief about having to designate a partition as root, and I probably did the wrong thing, but I just designated the whole card as root.

Bear in mind I'm kinda clueless about the real nuts and bolts of Linux, I was just tinkering, and was not sure if one could set up separate partitions on a flash card anyway....

Anyway, the install went flawlessly. I installed grub and the OS to the SD card as a full install, which saved my changes. I used the card to boot up and there was everything, just the way I saved it. I used it all day yesterday and it worked fine.

Oh, and I got the wifi working too, but that's for another post. :D
mrsfixit
Level 1
Level 1
 
Posts: 30
Joined: Thu Jul 07, 2011 6:27 pm
Location: Tannersville, PA

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: austin.texas and 4 guests