Plymouth at start

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

Plymouth at start

Postby shunesburg69 on Fri Jun 24, 2011 6:41 pm

I have installed plymouth and chosen a theme but when I boot I have a black screen
whereas the shut-down, it runs. Sorry for my in English I don't practice currently.
LinuxMint Debian Edition / Firefox 5.0 / Compiz
shunesburg69
Level 1
Level 1
 
Posts: 11
Joined: Fri Jun 24, 2011 6:10 pm

Linux Mint is funded by ads and donations.
 

Re: Plymouth at start

Postby LifeInTheGrey on Fri Jun 24, 2011 8:14 pm

Have you modified GRUB appropriately? GRUB defaults to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

However, to have a splash screen appear, you need to change it to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

So, the steps necessary:

1) In terminal type "gksudo gedit /etc/default/grub" (without quotation marks)
2) Make the changes described above; save, and close out
3) In terminal type "sudo update-grub" (without quotation marks)
4) Reboot; for some reason, it always takes my computer two reboots two activate, so if you don't see it the first time, try it again

You should be golden then!
the beauty of linux is that the rabbit hole goes as deep as you want it to go.
LifeInTheGrey
Level 3
Level 3
 
Posts: 145
Joined: Thu Apr 28, 2011 4:38 pm
Location: Seattle

Re: Plymouth at start

Postby shunesburg69 on Fri Jun 24, 2011 9:16 pm

I have that↓ and I rebooted more that 5 times already
Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vga=789"

and at the shut-down it work (I see the animation) it's just for the start which don't run.
LinuxMint Debian Edition / Firefox 5.0 / Compiz
shunesburg69
Level 1
Level 1
 
Posts: 11
Joined: Fri Jun 24, 2011 6:10 pm

Re: Plymouth at start

Postby LifeInTheGrey on Fri Jun 24, 2011 10:07 pm

Hmm ... do you see anything at all? Like perhaps a bar at the bottom that is dark blue / light blue / white, like a progress bar? I had a similar problem on my nVidia machine, because the drivers for the card did not load until after the boot splash would have normally run. What kind of graphics card are you using? And how did you set it up?
the beauty of linux is that the rabbit hole goes as deep as you want it to go.
LifeInTheGrey
Level 3
Level 3
 
Posts: 145
Joined: Thu Apr 28, 2011 4:38 pm
Location: Seattle

Re: Plymouth at start

Postby shunesburg69 on Sat Jun 25, 2011 6:03 am

Before, I chose my theme and add "vga=789" I had that you said.
But now I have a black screen except at the shut-down, here it work.
LinuxMint Debian Edition / Firefox 5.0 / Compiz
shunesburg69
Level 1
Level 1
 
Posts: 11
Joined: Fri Jun 24, 2011 6:10 pm

Re: Plymouth at start

Postby LifeInTheGrey on Sat Jun 25, 2011 9:11 am

shunesburg69 wrote:Before, I chose my theme and add "vga=789" I had that you said.
But now I have a black screen except at the shut-down, here it work.


So you have nothing but a black screen on boot, but splash screen at shutdown. Perhaps it is the "vga=789" that is the culprit, because that is setting the splash screen to be 800x600 with 24-bit color, and I'm not sure if the basic plymouth splash screens can produce that low of resolution or that high of color bit. A couple of options that you can try:

1) Change it to vga=791
- 1024x768 with 16-bit color is a more standard low resolution setting for boot screen splashes
2) Change it to vga=ask
- This will set it to whichever resolution/bitrate is best for the graphics card and drivers
3) Delete "vga=____" entirely and just make it GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
- I have never needed to specify resolution or bitrate, it should autodetect those settings
- I personally would try this first, however I must believe you chose to add the vga=789 information for a reason

If those guys don't work ... sorry, I gave it my best shot. Good luck!
the beauty of linux is that the rabbit hole goes as deep as you want it to go.
LifeInTheGrey
Level 3
Level 3
 
Posts: 145
Joined: Thu Apr 28, 2011 4:38 pm
Location: Seattle

Re: Plymouth at start

Postby twa on Sat Jun 25, 2011 12:20 pm

shunenburg69,
in order to have the splash at boot-in U must choose and apply it, so to recap:
from terminal
Code: Select all
sudo apt-get install plymouth-themes-all

then
Code: Select all
sudo gedit /etc/default/grub

modify the line to read:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
now, only if U have installed the proprietary drivers NVidia and ATI, in order not to have resolution problems, add this additional line (under GRUB_CMDLINE_LINUX_DEFAULT)
"vga=792"
save and close the file, and give a
Code: Select all
sudo update-grub

now U must choose a theme so
Code: Select all
sudo plymouth-set-default-theme --list

U will be given a list of the available themes; choose one and apply it
if, as an example, U choose the solar theme,
Code: Select all
sudo plymouth-set-default-theme solar

and apply it
Code: Select all
sudo update-initramfs -u


NOTE: details and text R not themes,

hope this will help U

:P
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread.
User avatar
twa
Level 4
Level 4
 
Posts: 231
Joined: Fri Sep 17, 2010 8:11 am
Location: Somewhere in the sky

Re: Plymouth at start

Postby shunesburg69 on Sun Jun 26, 2011 9:54 am

Whithout vga=789 I have like LifeInTheGrey had said:
LifeInTheGrey wrote:Hmm ... do you see anything at all? Like perhaps a bar at the bottom that is dark blue / light blue / white, like a progress bar? I had a similar problem on my nVidia machine, because the drivers for the card did not load until after the boot splash would have normally run. What kind of graphics card are you using? And how did you set it up?

I have a Nvidia card too (GT220) but it run perfectly with my installed drivers (3d acceleration work).
When I put vga=792 I have no splash at boot and all USB & PS2 peripherals (keyboard, mouse & WiFi-key) are unusable (it's strange).

Edit: twa, I have chosen already a theme like you said, it's not that the problem
because at the shut-down the right splash appear.
LinuxMint Debian Edition / Firefox 5.0 / Compiz
shunesburg69
Level 1
Level 1
 
Posts: 11
Joined: Fri Jun 24, 2011 6:10 pm

Re: Plymouth at start

Postby shunesburg69 on Wed Jun 29, 2011 10:05 am

Someone know what to do?
LinuxMint Debian Edition / Firefox 5.0 / Compiz
shunesburg69
Level 1
Level 1
 
Posts: 11
Joined: Fri Jun 24, 2011 6:10 pm

Re: Plymouth at start

Postby karashata on Wed Jun 29, 2011 5:54 pm

Go here: http://wiki.debian.org/plymouth

You might find that helpful.
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image
User avatar
karashata
Level 4
Level 4
 
Posts: 441
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada

Re: Plymouth at start

Postby shunesburg69 on Thu Jun 30, 2011 11:42 am

karashata wrote:Go here: http://wiki.debian.org/plymouth

Funny I'm not stupid, it's the first think that I do.
Someone else?
LinuxMint Debian Edition / Firefox 5.0 / Compiz
shunesburg69
Level 1
Level 1
 
Posts: 11
Joined: Fri Jun 24, 2011 6:10 pm

Re: Plymouth at start

Postby karashata on Thu Jun 30, 2011 2:17 pm

shunesburg69 wrote:
karashata wrote:Go here: http://wiki.debian.org/plymouth

Funny I'm not stupid, it's the first think that I do.
Someone else?


Sorry, I wasn't aware you'd already checked there. I used that and I has no issues getting Plymouth working for me, so...

In any case, if Plymouth is working fine for you at shut down but isn't working at boot, it sounds like you may not have properly updated the initial ram filesystem image (hereby referred to as initramfs) to add your Plymouth theme to it for it to run at boot. If that's the case, you need to make sure you run 'sudo update-initramfs -u -k all' in a terminal to make absolutely sure you update initramfs for all of your installed kernels.

If that doesn't help, I would recommend very carefully going through the page I linked you to earlier and making sure you read *everything*, because as far as I can tell, everything you need to know and do in order to install Plymouth and get it working in Debian is on that page. If it's *still* not working for you after carefully following that page's instructions... Well, in that case I'd be unable to help you further.
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image
User avatar
karashata
Level 4
Level 4
 
Posts: 441
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada

Re: Plymouth at start

Postby shunesburg69 on Thu Jun 30, 2011 5:53 pm

No change with "sudo update-initramfs -u -k all"
the strange thing is why I have a black screen at boot but have the animation at shut-down.

Well, in that case I'd be unable to help you further.

It's nice, by this way you don't make me false hope.
LinuxMint Debian Edition / Firefox 5.0 / Compiz
shunesburg69
Level 1
Level 1
 
Posts: 11
Joined: Fri Jun 24, 2011 6:10 pm

Re: Plymouth at start

Postby karashata on Thu Jun 30, 2011 6:19 pm

Hmm... Well... Lemme see...

I suppose the only way I can figure out what exactly might be wrong is with a checklist...

From the top, then.

Plymouth installed... Check

DRM libraries for your card (libdrm-intel1 for Intel cards, libdrm1-nouveau1 for nVidia cards, libdrm-radeon1 for AMD/ATI cards)... Unsure, need confirmation

/etc/initramfs-tools/modules edited appropriately... Unsure, need confirmation
(In order for Plymouth to run, the following will need to be added to the above named file:
For Intel Cards:
Code: Select all
# KMS
intel_agp
drm
i915 modeset=1

For nVidia cards:
Code: Select all
# KMS
drm
nouveau modeset=1

Make sure the appropriate code block is added to your /etc/initramfs-tools/modules, then report back.)

etc/default/grub updated appropriately... Unsure, need confirmation
(GRUB_GFXMODE ideally needs to be set to the highest possible resolution, depending on your monitor's resolution, widescreen resolutions don't seem to be widely supported yet except for lower resolution netbooks... Resolutions available to GRUB 2 can be displayed by typing 'vbeinfo' in the GRUB 2 command line. The command line is accessed by typing "c" when the main GRUB 2 menu screen is displayed. Make sure you remember to uncomment the line in /etc/default/grub otherwise it won't be used.
GRUB_CMDLINE_LINUX_DEFAULT needs to be set to "quiet splash", which you state you've already done.)

Plymouth theme selected... Check

Initial RAM filesystem updated... Check

After making sure everything is done, run 'sudo update-grub' and 'sudo update-initramfs -u -k all' in a terminal window to make sure any changes made take effect, then reboot to test things out. Hopefully after all this your plymouth splash screen will be working. If not, then I really can't help you anymore.
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image
User avatar
karashata
Level 4
Level 4
 
Posts: 441
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada

Re: Plymouth at start

Postby Dr.m0x on Fri Jul 01, 2011 4:08 am

I used to have working plymouth on my nvidia card but the upgrade to 2.6.39 has caused the same problem you are describing.

I can no longer boot unless I remove the splash command from grub.

I don't really care because it doesn't affect my ability to use my system in any way at all.

I think you will most likely have to live without plymouth until there is an update to resolve the apparent incompatibility which exists with the current version of plymouth and the new kernel.

---
Sent by an Htc Desire HD with Leedroid love.
Image
User avatar
Dr.m0x
Level 3
Level 3
 
Posts: 117
Joined: Thu Nov 25, 2010 4:12 am

Re: Plymouth at start

Postby shunesburg69 on Fri Jul 01, 2011 5:11 pm

karashata wrote:Plymouth installed... Check

OK

karashata wrote:DRM libraries for your card (libdrm-intel1 for Intel cards, libdrm1-nouveau1 for nVidia cards, libdrm-radeon1 for AMD/ATI cards)... Unsure, need confirmation

OK

karashata wrote:/etc/initramfs-tools/modules edited appropriately... Unsure, need confirmation
(In order for Plymouth to run, the following will need to be added to the above named file:

For nVidia cards:

Code: Select all
# KMS
drm
nouveau modeset=1

OK


GRUB_GFXMODE=1280x720
OK

karashata wrote:Plymouth theme selected... Check

OK

karashata wrote:Initial RAM filesystem updated... Check

Where I can see that?

karashata wrote:run 'sudo update-grub' and 'sudo update-initramfs -u -k all'

OK
LinuxMint Debian Edition / Firefox 5.0 / Compiz
shunesburg69
Level 1
Level 1
 
Posts: 11
Joined: Fri Jun 24, 2011 6:10 pm

Re: Plymouth at start

Postby karashata on Sat Jul 02, 2011 5:59 pm

shunesburg69 wrote:
karashata wrote:Initial RAM filesystem updated... Check

Where I can see that?

Honestly, I don't think there's really anywhere you can look that up, I just filled that in based on your previous replies in the thread to the effect that you had previously ran the update-initramfs command, probably several times now during this whole process...

In any case, I can't do much more for you now if it's still not working.
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image
User avatar
karashata
Level 4
Level 4
 
Posts: 441
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada

Re: Plymouth at start

Postby NeoMint on Mon Jul 11, 2011 2:23 pm

Note: Flat panel screens, will likely use different values, than these.

CRT users only:

I'm running Debian sid; so, it should track LMDE.

After adding the vga=792 to GRUB(2), this worked with my (debian way) installed Nvidia drivers, and after following the Plymouth wiki.

This is because of my particular GPU (nvidia), and CRT (Dell), monitor capabilities.

Please note: CRT users will have internal, CRT size, adjustment "memories", for each of theses 3 resolutions, and they may need to be adjusted; optimally, on/in your monitor, and it's controls. Each has it's own "boarder", setting limits; so to speak. This is not the case, on LCD flat-panels. While there may be a suggested resolution for your monitor, only LCD's have native resolutions. Other resolutions are "emulated", on flat-panel LCD's, and may be muddy looking; if not at the native res.

Also, I find the grub menu (and console) works best, for me, at 800x600 (before Plymouth; at 1024x768x24, AKA "792"). Then, when X starts, I use 1280x960 at 85hz, via nvidia-settings (<---and saved with), as my desktop-environment, preference (for photography).

You might find this download link interesting. It's a Plymouth, GUI switcher; converted for Debian, and a Plymouth, converted for debian, sunrise theme. I just installed them, with part one(theme), and two(switcher), using gdebi.

https://sites.google.com/site/stevosfilehideaway/Home/Earth-sunrise-Debian_and_EZSwitch.zip?attredirects=0

with...
Code: Select all
sudo gedit /etc/default/grub

Though not using nouveau, I'm set to...
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset nouveau.modeset=1"
GRUB_CMDLINE_LINUX="vga=792"
and...
GRUB_GFXMODE=800x600

Then don't forget...
Code: Select all
sudo update-grub
Also, ...
Code: Select all
sudo update-initramfs -u
...or use the switcher GUI.

Note: Some people use a hack/workaround, after your Plymouth start, is working, and set a different (see url below) Plymouth theme, for shutdown. Then, by not doing the proper, "sudo update-initramfs -u" following it, and/or not using the "EZSwitch"(for this), just...
Code: Select all
/usr/sbin/plymouth-set-default-theme Earth-sunset
...it displays a sunset, only on shutdown/restart. I installed the MEPEIS sunset deb package (for "Debian", or Debian based) and just (as root) copied over the disto label, "debian" (from the debian sunrise); right over the mepis file, in that sunset Plymouth theme (as root; in /usr/share/plymouth/...). One could make a LMDE, matching graphic, too. It's tiny.

MEPIS sunset theme: https://docs.google.com/leaf?id=0B1UMhse3gjfPZjU4ODg3YTUtOWVmYi00ZDk3LTg2ZWUtOWMzOThkYzk1ZmVk&hl=en

Also, the 800x600 for the non-X console, is much nicer for smxi, and other operations. It has much smoother text, less scrolling, and less warp-around issues.
NeoMint
Level 2
Level 2
 
Posts: 57
Joined: Fri Jan 14, 2011 8:18 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 3 guests