Starting LMDE...

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

Starting LMDE...

Postby HTD on Sun Aug 21, 2011 10:57 am

My LMDE takes 64 seconds to boot. I mean after 64s from hiting enter on GRUB and pausing for logging on - CPU meters drops to 0% showing I'm free to work.

Ubuntu is a disabled turtle compared to this, as well as Windows 7. But can LMDE be even faster?

Here is some research I've made for fun:

When system starts it uses sysvinit to load services. But there are alternatives like upstart and systemd. I've tried both. The same 64s - but both upstart and systemd seems not configurable. Systemd tried to load apache2 all the time and I couldn't disable it with systemctl. Lame. I had no idea how to configure upstart. Typing sudo restart gdm3 returned there's no such job. Lame again. I think LMDE is configured to use sysvinit and changing it to something different requires lots of manual configuration. Or maybe I'm wrong?

OK, there is services panel in LMDE configuration. There are some services there which can be easily enabled and disabled. All enabled look like they have to stay, but...
anacron
atd
cron
are they all needed? will removing some of them speed anything up?

The next thing is GDM3 - it's slow! I've changed it to lightdm, but lightdm is ultra-lame - when you enter your username wrong, there's no way to type it again, and you have to restart it from console. XDM - I don't know, it looks so 90-s. KDM - no, I'm not for KDE (and I know there are issues if you start GNOME with KDM).

So - is there anything to be done? Maybe a part of GNOME could be preloaded while starting GDM3? Maybe something else could speed things up?
HTD
Level 1
Level 1
 
Posts: 46
Joined: Sun May 22, 2011 7:31 pm

Linux Mint is funded by ads and donations.
 

Re: Starting LMDE...

Postby xenopeek on Sun Aug 21, 2011 11:49 am

Hi, don't disable anacron, atd or cron--your system needs those services.

64s is quite long, but it depends on your hardware. Please share output of:
Code: Select all
inxi -F

And please install bootchart to analyze the boot:
Code: Select all
sudo apt-get install bootchart pybootchartgui

Then reboot and browse to /var/log/bootchart, there should be a png image there with an analysis of your boot. Please post that here also.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14815
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Starting LMDE...

Postby HTD on Sun Aug 21, 2011 2:23 pm

Code: Select all
$ inxi -F
System:    Host fallout Kernel 3.0.0-1-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition
CPU:       Dual core Intel Core2 Duo E6750 (-MCP-) cache 4096 KB flags (lm nx sse sse2 sse3 ssse3 vmx) bmips 10687.9
           Clock Speeds: (1) 2003.00 MHz (2) 2003.00 MHz
Graphics:  Card ATI RV770 [Radeon HD 4870] X.Org 1.10.3 Res: 1680x1050@60.0hz
           GLX Renderer ATI Radeon HD 4800 Series          GLX Version 3.3.10907 Compatibility Profile Context Direct Rendering Yes
Audio:     Card-1 ATI HD48x0 audio driver HDA Intel BusID: 01:00.1
           Card-2 Intel 82801I (ICH9 Family) HD Audio Controller driver HDA Intel BusID: 00:1b.0
           Card-3 Creative Labs SB X-Fi driver SB-XFi at port ec00 BusID: 05:01.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
Network:   Card Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver r8169 v: 2.3LK-NAPI at port d800 BusID: 04:00.0
Disks:     HDD Total Size: 2140.4GB (49.1% used) 1: /dev/sdb SAMSUNG_HD642JJ 640.1GB 21C
           2: /dev/sda SAMSUNG_HD154UI 1500.3GB 21C
Partition: ID:/ size: 40G used: 19G (50%) fs: ext4 ID:swap-1 size: 10.75GB used: 0.00GB (0%) fs: swap
Sensors:   System Temperatures: cpu: 25.0C mobo: 23.0C gpu: 45.50C
           Fan Speeds (in rpm): cpu: 1642 fan-1: 0 fan-3: 0 fan-4: 0
Info:      Processes 237 Uptime 5:01 Memory 1215.8/3966.1MB Runlevel 2 Client Shell inxi 1.4.23
HTD
Level 1
Level 1
 
Posts: 46
Joined: Sun May 22, 2011 7:31 pm

Re: Starting LMDE...

Postby xenopeek on Sun Aug 21, 2011 2:31 pm

Hi, your processor is fast enough and you have enough memory that your boot should not be slowed down such by either. Your primary harddisk is slower than your secondary harddisk, but it is not clear without seeing the bootchart if in fact this is slowing your boot.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14815
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Starting LMDE...

Postby HTD on Sun Aug 21, 2011 2:41 pm

Image

Oh, you forgot to tell me I need to start bootchart with GRUB :) So I rebooted twice before I checked on bootchart's site :)

OK, it takes exactly 32 seconds to load GDM3. And next 32 seconds to load GNOME with some startup programs, like Pidgin, CompizFusionIcon, gnome panel applets... And of course Compiz, Emerald and themes.

The disk - I indeed do use slower disk for startup, but it's not THAT slow, is it? I do in on purpose - it's quieter and "green" - less noise and heat for most of the time. I use the faster one as media storage, and it can be put to sleep when I'm not using it (even more silence). Puting to sleep system disk causes quite big lags sometimes, so it's better to disable it.

From that chart it looks like there's a lot of "disk utilization" without throughput - is it badly fragmented so it's most seek time? Is there a way to defragment it? (It's ext4 partition).
I think moving all files to another partition and then moving them back again could help - but it could take time. I think I have enough space for it on my unused Ubuntu partition...
HTD
Level 1
Level 1
 
Posts: 46
Joined: Sun May 22, 2011 7:31 pm

Re: Starting LMDE...

Postby xenopeek on Sun Aug 21, 2011 3:21 pm

Sorry about bootchart not automatically starting. This must be different on LMDE, as on Linux Mint 11 it automatically starts after each boot after installation.

Your boot is showing a healthy 21 seconds, which is good but means the programs loaded after boot are causing the delay. The bootchart is showing a very high wait I/O. Both CPU and disk throughput are way lower than wait I/O, which means that everything is constantly waiting for your harddisk (they should overlap, meaning nothing is waiting for harddisk). Yeah, sorry, your first harddisk is officially slow :wink: Fragmentation is not an issue on ext4 as it is on Windows, this is not causing delays.

There are two things you can do:
1. Reduce the amount of automatically started programs. So go to Startup Applications and disable what you don't need.
2. Get a SSD as first drive instead of the current harddisk. I boot in 6 seconds with a SSD. You can get good reviews on SSDs here: http://www.storagereview.com/

You can also benchmark the read speed of your harddisk, to get some idea of what improvements are possible.
- Go to Menu and find Disk Utility, start it
- Select your first harddisk
- Click "Benchmark"
- Choose "Start Read-Only Benchmark"
- Wait till done, and check the minimum and average read rates. A good SATA-300 SSD will do average of 250 MB/s and a minimum of 200 MB/s. I would be surprised if you get above 100 MB/s with a 5400 RPM harddisk.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14815
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands


Return to Installation & Boot

Who is online

Users browsing this forum: Bing [Bot] and 4 guests