[SOLVED] Disable fsck on btrfs

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

[SOLVED] Disable fsck on btrfs

Postby lucman on Mon Nov 21, 2011 3:36 pm

I get this error when my LMDE (201109 GNOMEx64 Freshinstall) boots.
"fsck.btrfs file not found" Because btrfs doesn't have an fsck tool.
When i updated to Update Pack 3 (Testing) System doesn't boot, it shows this error and only let me use a root terminal
or "press Ctrl+D to Continue" (computer reboots if i press that key)
Maybe, there's an option for "disable" fsck on my btrfs partitions.
    /boot - ext4
    / - btrfs
    /home - btrfs

Greetings. :)
PS: I don't know if this post goes here or in "Update/Upgrade Issues"
Last edited by lucman on Tue Nov 22, 2011 11:04 am, edited 1 time in total.
Linux Mint Debian Edition GNOME x64 User
User avatar
lucman
Level 1
Level 1
 
Posts: 2
Joined: Sun Jun 12, 2011 2:35 pm

Linux Mint is funded by ads and donations.
 

Re: Disable fsck on btrfs

Postby amina on Tue Nov 22, 2011 5:31 am

You could try to edit fstab (carefully !!!) from the root terminal (for example with nano):

Code: Select all
nano /etc/fstab


The last number at the end of each btrfs line should be 0 (which indicates that fsck should not check those filesystems).

In nano, you can save with Ctrl + O followed by <Enter> and quit with Ctrl + x.
amina
Level 3
Level 3
 
Posts: 140
Joined: Wed Mar 02, 2011 4:45 am

[SOLVED] Disable fsck on btrfs

Postby lucman on Tue Nov 22, 2011 11:03 am

Thanks it worked! :D

Code: Select all
sudo nano /etc/fstab

Change the last 0 to 1 on btrfs partitions.
Save: Ctrl+O; Enter
Linux Mint Debian Edition GNOME x64 User
User avatar
lucman
Level 1
Level 1
 
Posts: 2
Joined: Sun Jun 12, 2011 2:35 pm


Return to Installation & Boot

Who is online

Users browsing this forum: darethehair and 3 guests