new install mint debian

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

new install mint debian

Postby rosswmcgee on Mon Nov 28, 2011 10:29 pm

E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


I keep getting this error. I would like fix it. Please help or it is back to MInt 12
rosswmcgee
Level 3
Level 3
 
Posts: 149
Joined: Wed Jan 13, 2010 2:29 pm

Linux Mint is funded by ads and donations.
 

Re: new install mint debian

Postby rosswmcgee on Tue Nov 29, 2011 12:20 pm

32 bit

Linux rosswmcgee 2.6.32-5-686 #1 SMP Thu Nov 25 18:43:34 UTC 2010 i686 GNU/Linux

This install is from the dvd 201101

Hope you can figure it out because I like the idea of a rolling mint debian, although Lisa is very nice.
rosswmcgee
Level 3
Level 3
 
Posts: 149
Joined: Wed Jan 13, 2010 2:29 pm

Re: mint debian updater error

Postby rosswmcgee on Tue Nov 29, 2011 12:29 pm

________________________________________
/ FORTUNE PROVIDES QUESTIONS FOR THE \
| GREAT ANSWERS: #4 A: Go west, young |
| man, go west! Q: What do wabbits do |
\ when they get tiwed of wunning awound? /
----------------------------------------
\
\
___
{~._.~}
( Y )
()~*~()
(_)-(_)
ross@rosswmcgee ~ $ sudo apt-get update && sudo apt-get dist-upgrade
[sudo] password for ross:
Get:1 http://packages.linuxmint.com debian Release.gpg [198 B]
Ign http://packages.linuxmint.com/ debian/import Translation-en
Ign http://packages.linuxmint.com/ debian/import Translation-en_US
Ign http://packages.linuxmint.com/ debian/main Translation-en
Hit http://security.debian.org testing/updates Release.gpg
Ign http://security.debian.org/ testing/updates/contrib Translation-en
Ign http://security.debian.org/ testing/updates/contrib Translation-en_US
Ign http://packages.linuxmint.com/ debian/main Translation-en_US
Ign http://packages.linuxmint.com/ debian/upstream Translation-en
Ign http://packages.linuxmint.com/ debian/upstream Translation-en_US
Get:2 http://packages.linuxmint.com debian Release [12.1 kB]
Get:3 http://www.debian-multimedia.org testing Release.gpg [198 B]
Ign http://www.debian-multimedia.org/ testing/main Translation-en
Ign http://www.debian-multimedia.org/ testing/main Translation-en_US
Ign http://www.debian-multimedia.org/ testing/non-free Translation-en
Ign http://www.debian-multimedia.org/ testing/non-free Translation-en_US
Hit http://ftp.debian.org testing Release.gpg
Ign http://ftp.debian.org/debian/ testing/contrib Translation-en
Ign http://ftp.debian.org/debian/ testing/contrib Translation-en_US
Ign http://security.debian.org/ testing/updates/main Translation-en
Ign http://security.debian.org/ testing/updates/main Translation-en_US
Ign http://security.debian.org/ testing/updates/non-free Translation-en
Ign http://security.debian.org/ testing/updates/non-free Translation-en_US
Hit http://security.debian.org testing/updates Release
Get:4 http://www.debian-multimedia.org testing Release [29.4 kB]
Ign http://packages.linuxmint.com debian/main i386 Packages
Ign http://ftp.debian.org/debian/ testing/main Translation-en
Ign http://ftp.debian.org/debian/ testing/main Translation-en_US
Ign http://ftp.debian.org/debian/ testing/non-free Translation-en
Ign http://ftp.debian.org/debian/ testing/non-free Translation-en_US
Hit http://ftp.debian.org testing Release
Hit http://security.debian.org testing/updates/main i386 Packages
Ign http://packages.linuxmint.com debian/upstream i386 Packages
Ign http://packages.linuxmint.com debian/import i386 Packages
Hit http://security.debian.org testing/updates/contrib i386 Packages
Hit http://security.debian.org testing/updates/non-free i386 Packages
Ign http://packages.linuxmint.com debian/main i386 Packages
Hit http://ftp.debian.org testing/main i386 Packages/DiffIndex
Ign http://packages.linuxmint.com debian/upstream i386 Packages
Ign http://packages.linuxmint.com debian/import i386 Packages
Get:5 http://packages.linuxmint.com debian/main i386 Packages [9,896 B]
Get:6 http://packages.linuxmint.com debian/upstream i386 Packages [5,208 B]
Get:7 http://www.debian-multimedia.org testing/main i386 Packages/DiffIndex [2,023 B]
Hit http://ftp.debian.org testing/contrib i386 Packages/DiffIndex
Hit http://ftp.debian.org testing/non-free i386 Packages/DiffIndex
Get:8 http://packages.linuxmint.com debian/import i386 Packages [19.4 kB]
Hit http://www.debian-multimedia.org testing/non-free i386 Packages/DiffIndex
Get:9 http://www.debian-multimedia.org testing/main i386 2011-11-29-1642.02.pdiff [326 B]
Get:10 http://www.debian-multimedia.org testing/main i386 2011-11-29-1642.02.pdiff [326 B]
Get:11 http://www.debian-multimedia.org testing/main i386 2011-11-29-1642.02.pdiff [326 B]
Fetched 78.8 kB in 7s (10.7 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Failed
The following packages have unmet dependencies:
libgl1-mesa-dri : Breaks: xserver-xorg-core (< 2:1.10.2-2) but 2:1.7.7-9 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
ross@rosswmcgee ~ $ sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
dpkg: error processing /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
/var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
ross@rosswmcgee ~ $
rosswmcgee
Level 3
Level 3
 
Posts: 149
Joined: Wed Jan 13, 2010 2:29 pm

Re: new install mint debian

Postby richyrich on Tue Nov 29, 2011 12:37 pm

Suggestions;
- check the Lmde section of the forum for update/upgrade posts and instructions.
- download and install the latest spin : linuxmint-201109-gnome-dvd (or xfce)
User avatar
richyrich
Level 13
Level 13
 
Posts: 4652
Joined: Mon May 04, 2009 8:31 pm
Location: Somewhere in northern Saskatchewan, Canada

Re: mint debian updater error

Postby zerozero on Tue Nov 29, 2011 12:53 pm

your error has nothing to do with gstreamer, the issue is here
The following packages have unmet dependencies:
libgl1-mesa-dri : Breaks: xserver-xorg-core (< 2:1.10.2-2) but 2:1.7.7-9 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

this leads to think, first that this is an old install, and second that you hadn't update it successfully in some time;
to help me debug this i need 2 outputs (they are most probably end up in error, but we may end up learning something from those errors)
Code: Select all
sudo apt-get install libgl1-mesa-dri

Code: Select all
sudo apt-get install xserver-xorg-core


edit:next time, please, don't hijack other topics and duplicate the same subject over several topics.
thank you
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: new install mint debian

Postby rosswmcgee on Tue Nov 29, 2011 1:58 pm

Sorry about that I got confused on the right post, here are my results:
__________________________________
( You are going to have a new love )
( affair. )
----------------------------------
o
o \_\_ _/_/
o \__/
(oo)\_______
(__)\ )\/\
||----w |
|| ||
rosswmcgee ross # sudo apt-get install libgl1-mesa-dri
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libc6-dev : Breaks: gcc-4.4 (< 4.4.6-4) but 4.4.5-8 is to be installed
E: Broken packages
rosswmcgee ross # sudo apt-get install xserver-xorg-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libc6-dev : Breaks: gcc-4.4 (< 4.4.6-4) but 4.4.5-8 is to be installed
xserver-xorg-core : Depends: libpixman-1-0 (>= 0.21.6) but 0.20.2-0ubuntu1 is to be installed
E: Broken packages
rosswmcgee ross #
rosswmcgee
Level 3
Level 3
 
Posts: 149
Joined: Wed Jan 13, 2010 2:29 pm

Re: new install mint debian

Postby zerozero on Tue Nov 29, 2011 2:09 pm

when i was answering you in the other topic, i didn't have all the info with me, when i moved those posts over here i saw the only info i need

This install is from the dvd 201101

this is never going to work, that iso is soo old, the changes are soo relevant in all the system that will be impossible to bring that install up-to-date;

the solution is in richyrich post above: d/l the new and updated iso and start from there
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: new install mint debian

Postby rosswmcgee on Tue Nov 29, 2011 2:12 pm

I had the same problem with 201109
rosswmcgee
Level 3
Level 3
 
Posts: 149
Joined: Wed Jan 13, 2010 2:29 pm

Re: new install mint debian

Postby zerozero on Tue Nov 29, 2011 2:18 pm

rosswmcgee wrote:I had the same problem with 201109

sorry, but that it's impossible.
you might had the gstreamer error in the 201109 iso, but that is an easy fix, with this (201101) there's no easy or hard fix.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: new install mint debian

Postby rosswmcgee on Tue Nov 29, 2011 2:32 pm

OK I will re-install using the latest dvd iso then will will go from there.
rosswmcgee
Level 3
Level 3
 
Posts: 149
Joined: Wed Jan 13, 2010 2:29 pm

Re: new install mint debian

Postby zerozero on Tue Nov 29, 2011 2:36 pm

cool and you can report any issue here, i will get notifications from this topic
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: new install mint debian

Postby rosswmcgee on Tue Nov 29, 2011 5:53 pm

OK install has occured/ some updates did not this is the msg..

E: /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb: trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1
rosswmcgee
Level 3
Level 3
 
Posts: 149
Joined: Wed Jan 13, 2010 2:29 pm

Re: new install mint debian

Postby zerozero on Tue Nov 29, 2011 6:13 pm

ok, no problem, we were expecting that :D
open a terminal and do
Code: Select all
sudo apt-get update && sudo apt-get dist-upgrade

you are going to get the same error, but now you are prepared to it, after the error, copy&past this
Code: Select all
sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb

and that nasty is gone :lol:
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: new install mint debian

Postby rosswmcgee on Tue Nov 29, 2011 10:22 pm

First of all thanks for sticking with me on this and again sorry I got the posts mixed up. I am up and running, with no updates remaining. My guess is that the first

dvd 201109 was not complete, so then I swithched to the 201101 which was too old.

I wished the install was a bit easier when it comes to the to the partioning, I always use the entire space, in Lisa it was easy with debian I am still not sure I

did it right, or the grub part in the update I am not sure either. Then there was a note to allow other sources if I wanted a more complete install. Well here I am

up and running all seems well. If you have any other suggestions they are welcomed. Just know that we run mint 9 on my wifes machine, I was running Julia on mine. On another machine I run Squeeze, and that is what attracted me to mint lmde. I did try Lisa and like it but will stay with this because supposedly I will never

need another new install. Thanks again. Ross
rosswmcgee
Level 3
Level 3
 
Posts: 149
Joined: Wed Jan 13, 2010 2:29 pm

Re: new install mint debian

Postby zerozero on Wed Nov 30, 2011 6:02 am

i'm very happy you got it running;
the only thing, maybe, if you haven't done it yet, is have a look here viewtopic.php?f=185&t=82346 and rearrange your repos.
apart from that, enjoy
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: new install mint debian

Postby NoGRoD on Wed Nov 30, 2011 8:21 am

I have done a fresh install of linuxmint-201109-gnome-dvd-64bit and get the same error doing the updates:
Code: Select all
E: /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb: intentando sobreescribir `/usr/lib/gstreamer-0.10/libgstxvid.so', que está también en el paquete gstreamer0.10-plugins-really-bad 0.10.22-0.1

I did the "sudo dpkg -i --force-overwrite" with my file and it worked.
Thanks!
NoGRoD
Level 1
Level 1
 
Posts: 1
Joined: Wed Dec 01, 2010 8:18 am

Re: new install mint debian

Postby VanR on Wed Nov 30, 2011 10:17 am

I got that message when I updated the other day. All I did was uncheck the gstreamer-really-bad update and let the rest update. Then I went back after they had updated and let the gstreamer-really-bad install by itself and it had no errors.
VanR
Level 1
Level 1
 
Posts: 35
Joined: Mon May 09, 2011 2:54 am
Location: AZ

Re: new install mint debian

Postby rosswmcgee on Wed Nov 30, 2011 11:02 am

Tried this gksu gedit /etc/apt/sources.list

got this.


gksu gedit /etc/apt/sources.list

(gedit:2420): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported


(gedit:2420): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.3FF35V': No such file or directory

(gedit:2420): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

Followed by this in another terminal window:

deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free


In other words I have the Kernel 3.0. -1-486 and Gnome 3.02.. To tell you the truth I am very excited about Mint LMDE. Lisa is remarkable but the rolling aspect of LMDE is just great! Thanks again all.
rosswmcgee
Level 3
Level 3
 
Posts: 149
Joined: Wed Jan 13, 2010 2:29 pm

Re: new install mint debian

Postby zerozero on Wed Nov 30, 2011 11:29 am

ok, we are getting there :D
- that warning you can forget, means nothing basically;
- the 2nd window that you got with the 4 repos is not a terminal window, is a gedit window (text editor) and you should here be very careful because you are in "root mode"
- you should now delete all those entries and copy&past the ones bellow (then save the file and just to be sure everything is fine post here back the output of inxi -r)

Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free


be very carefull with the copy&past, they have to be identical
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: new install mint debian

Postby rosswmcgee on Wed Nov 30, 2011 12:28 pm

OK did that and then ran gksu gedit /etc/apt/sources.list

No warnings came through so I assume all is well.


So when the next update pack arrives do you just run it like any other update?
rosswmcgee
Level 3
Level 3
 
Posts: 149
Joined: Wed Jan 13, 2010 2:29 pm

Linux Mint is funded by ads and donations.
 
Next

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 4 guests