Can't install latest LMDE on 2009 27" iMac

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read how to get help

Can't install latest LMDE on 2009 27" iMac

Postby iindigo on Fri Mar 09, 2012 8:51 pm

Hello all,

I've been attempting to install the latest version of Linux Mint Debian Edition x64 (Xfce variant) on my 2009 27" iMac with the following specs:

• 2.66Ghz quad Core i5 750
• Radeon 4850 512MB graphics
• 8GB memory
• 1TB internal HD (15GB partitioned off for LMDE)

As has been the case with all Linux distributions since the debut of this iMac revision, booting the LMDE live DVD works great until X11 fires up. At that point, the system redirects output to the mini displayport that has no monitor hooked up to it, leaving the internal display blank and thus preventing installation. I've tried several solutions presented by googling and searching the ubuntu forums, including booting with different combinations of the arguments "radeon.modeset=0", "nomodeset", and "xforcevesa". The only one that has any effect at all is "radeon.modeset=0", which delays monitor switching for a few extra settings but ultimately does not help.

I do not have a mini-displayport monitor to hook up and I would really like to have LMDE as part of a tri-boot setup of Lion, LMDE, and Win7. Are there any other options I could try to get this installed?

I'd like to add that while I'm reasonably comfortable with the command line (I use it regularly under OS X), I am not comfortable with vim or emacs if any text editing is necessary.


Thanks!
iindigo
Level 1
Level 1
 
Posts: 2
Joined: Fri Mar 09, 2012 8:26 pm

Linux Mint is funded by ads and donations.
 

Re: Can't install latest LMDE on 2009 27" iMac

Postby AlbertP on Fri Mar 30, 2012 6:20 am

The workaround from Ubuntu is to use an external monitor for live discs; they say the built-in one will work after installation. They have a bug report about it, IIRC it was mentioned in the release notes of some Ubuntu version (Natty?).
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 3 guests