Beware update 4

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

Beware update 4

Postby j1mw3b on Sun Apr 15, 2012 10:22 am

I run LinuxMint LMDE on my laptop, update 3, with what looks like Gnome2.
Saw this update 4 come along and almost installed it until I read that it will switch me to Gnome 3 shell.
UGH!!!! Tried it already and was the reason I switched from pure Debian to Mint.

So, I have a VirtualBox VM with LinuxMint LMDE, but with LXDE - which I would have to switch to if I installed this Update 4 on my base laptop.

So.... installed Update 4 on my Virtual LMDE/LXDE and am left with an unusable system. No desktop at all - am presented with a terminal only command line interface. Did startx, aborted! Did init 5, aborted!
I went thru the total install until it said "completed" and then did halt to shutdown the system. Restart this AM is no LXDE, no Gnome, no Cinnamon, no Mate, no GUI interface.

Yeah, sure I accepted all the requests to replace config files during the install - but this still shouldn't leave me with a junked system.

I am now very unhappy with Mint - who needs this aggravation. Might just go back to pure Debian.

Any Mint developers have a clue why this happened.

Jim
j1mw3b
Level 1
Level 1
 
Posts: 21
Joined: Fri Nov 11, 2011 7:42 pm

Linux Mint is funded by ads and donations.
 

Re: Beware update 4

Postby j1mw3b on Sun Apr 15, 2012 10:26 am

LXDE??? I meant XFCE. Don't use this VM much, just for things like this.

Jim
j1mw3b
Level 1
Level 1
 
Posts: 21
Joined: Fri Nov 11, 2011 7:42 pm

Re: Beware update 4

Postby j1mw3b on Sun Apr 15, 2012 10:33 am

And why, when I shutdown, does it say "stopping Gnome......"?

Jim
j1mw3b
Level 1
Level 1
 
Posts: 21
Joined: Fri Nov 11, 2011 7:42 pm

Re: Beware update 4

Postby Monsta on Sun Apr 15, 2012 10:48 am

Check out this thread, looks like a similar breakage.
Monsta
Level 8
Level 8
 
Posts: 2496
Joined: Fri Aug 19, 2011 3:46 am

Re: Beware update 4

Postby j1mw3b on Sun Apr 15, 2012 3:06 pm

Thanks, that fixed it. Don't think I would have figured that one out.
I had already did an install of Mate thinking maybe that would get it going, so Mate became my default desktop.
It just presented a blank desktop so scratch Mate from candidate list.
Then tried XFCE and it works fine.
Tried also Gnome classic and that one is pretty bad.

Gnome 3 fails and starts in fallback mode - says maybe my graphics hardware is not capable.....
Surprising, that. This is a fairly new Lenovo Thinkpad T520 - Intel HD 3000 graphics I think.

So, for now, it's XFCE for me.

Jim
j1mw3b
Level 1
Level 1
 
Posts: 21
Joined: Fri Nov 11, 2011 7:42 pm

Re: Beware update 4

Postby äxl on Sun Apr 15, 2012 3:25 pm

My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Beware update 4

Postby jjaythomas on Sun Apr 15, 2012 4:11 pm

Are you using the new 'UP4 LMDE-XFCE ISO' OR installing XFCE on a already LMDE (Gnome) System???

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: Beware update 4

Postby j1mw3b on Mon Apr 16, 2012 7:31 pm

2 system, both VirtualBox VMs -
First is LMDE with xfce. I applied the update via the update icon. The fix was the vboxvideo driver above which let me get a desktop running. Full Gnome didn't work. Mate and Cinnamon both look like the Gnome fallback. All unsatisfactory. I am back with XFCE

Second is also LMDE and was a fresh install from the linuxmint-201109-gnome-dvd-32bit.iso file (as was originally the first VM). I only did this one to see if full Gnome would work. I then did apt-get update && apt-get dist-upgrade. After a long time, it finished and I rebooted and tried to logon with Gnome. Again it fails - same error as first system.

My host system (running VirtualBox) is also LMDE, but without update 4 and good old Gnome 2 - I'll probly switch it over to XFCE eventually.

So, the Gnome folks are forcing me to leave Gnome - liked it for a long time - and move to XFCE.
As I understand Gnome 3 is 3D anyway and who needs that. This is a work computer for programming, not an Apple or Windows.


The GUI experts have gone whacko.

Funny thing, I had previously installed Ubuntu Mint on my old T42 laptop and it ran Gnome 3 and also the latest KDE just fine - hard to believe this T520 has less graphics - maybe some BIOS setting - but Gnome 3 and KDE (4?) was why I went to Linux Mint in the first place so don't care about them.


Jim
j1mw3b
Level 1
Level 1
 
Posts: 21
Joined: Fri Nov 11, 2011 7:42 pm

Re: Beware update 4

Postby Monsta on Tue Apr 17, 2012 3:31 am

Did you try this to get more info about Gnome's bad behavior?
Monsta
Level 8
Level 8
 
Posts: 2496
Joined: Fri Aug 19, 2011 3:46 am

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 6 guests