Conky won't start at login.....but it's in my startup script

Questions about applications and software
Forum rules
Before you post please read this

Conky won't start at login.....but it's in my startup script

Postby hogfan on Wed May 02, 2012 6:28 am

I am having problems getting conky to start at login. I have added it to my /etc/init.d/local.autostart file that I created, after the line that I added to set my laptops screen brightness. I have it set for a delay of 30 to allow the composite manager time to load. After updating I the script I did run:

Code: Select all
sudo update-rc.d local.autostart defaults


However, when I reboot and log back on, the screen brightness is adjusted properly, so I know the script runs, but conky never launches. Here is the content of my local.autostart file. Any help is extremely appreciated.

Code: Select all
#!/bin/sh
### BEGIN INIT INFO
# Provides:             Startup Scripts
# Required-Start:       $all
# Required-Stop:        $all
# Default-Start:        2 3 4 5
# Default-Stop:         0 1 6
# Short-Description:    Automatically starts processes at logon
# Description:          Startup Items
### END INIT INFO

pkexec /usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness  8
conky -p 30 -c '/home/jeremy/.conkyrc'


-hogfan
hogfan
Level 2
Level 2
 
Posts: 52
Joined: Fri Apr 20, 2012 10:08 pm

Linux Mint is funded by ads and donations.
 

Re: Conky won't start at login.....but it's in my startup sc

Postby Habitual on Wed May 02, 2012 7:46 am

Jeremy:

It would be helpful to know more about your environment.

How about terminal>
Code: Select all
lsb_release -dr

output please?

Thanks!
What's a landing but a take off in reverse?
My DorkBlog
User avatar
Habitual
Level 8
Level 8
 
Posts: 2029
Joined: Sun Nov 21, 2010 8:31 pm
Location: Undecided

Re: Conky won't start at login.....but it's in my startup sc

Postby hogfan on Thu May 03, 2012 12:58 am

Here is the requested output. Thanks.

Code: Select all

jeremy@mintbook ~ $ lsb_release -dr
Description:   Linux Mint Debian Edition
Release:   1
hogfan
Level 2
Level 2
 
Posts: 52
Joined: Fri Apr 20, 2012 10:08 pm

Re: Conky won't start at login.....but it's in my startup sc

Postby hogfan on Fri May 04, 2012 2:37 am

Ok, I am still fighting with this. I created a new script named .autostart_conky.sh in the folder: /home/jeremy

The contents of the script are:

Code: Select all
#!/bin/sh
sleep 45
conky -c '/home/jeremy/.conkyrc'


Then I made the script executable by doing: sudo chmod +x /home/jeremy/.autostart_conky.sh

I then ran: sudo gnome-session-properties

and Added a new entry pointing to the script .autostart_conky.sh, but when I reboot or logout and back in, conky doesn't start. So I have now tried this two ways and It won't autostart. However, I can open the terminal and paste in: sudo conky -c '/home/jeremy/.conkyrc' and it fires right off. Any ideas? I didn't think that autostarting an application at logon would be this hard.

-hogfan
hogfan
Level 2
Level 2
 
Posts: 52
Joined: Fri Apr 20, 2012 10:08 pm

Re: Conky won't start at login.....but it's in my startup sc

Postby hogfan on Fri May 04, 2012 11:29 am

Another update. It appears that my .autostart_conky.sh script is not even being executed at logon! However, I can open the terminal and type:

Code: Select all
sudo /home/jeremy/.autostart_conky.sh


And the script runs and launches Conky, so I have verified that the script is executable and works. Any ideas?

-hogfan
hogfan
Level 2
Level 2
 
Posts: 52
Joined: Fri Apr 20, 2012 10:08 pm

Re: Conky won't start at login.....but it's in my startup sc

Postby timgood on Tue May 08, 2012 5:30 am

I am having exactly the same problem. I can start conky from a direct command or terminal, but autostarting it does not work at all. Strange!
timgood
Level 1
Level 1
 
Posts: 11
Joined: Tue May 01, 2012 4:19 am

Re: Conky won't start at login.....but it's in my startup sc

Postby corn on Tue May 08, 2012 6:58 am

I had the same problem, but it solved itself quite "magically", and there are times (it's very rare though) where it won't start on its own. I'm not exactly sure how I got it to work, but I believe I withdrew Composition (xcompmgr) from Startup Applications... it didn't really make sense but it worked.
corn
Level 1
Level 1
 
Posts: 24
Joined: Sun Dec 25, 2011 7:59 pm

Re: Conky won't start at login.....but it's in my startup sc

Postby dwainehead on Tue May 08, 2012 10:59 am

I had that problem to fix it I added as startup applications
LMDE x64 20120409 UP5 AMD FX 4100 x4 3.6gHz Gigabyte GA-970A-UD3 16g Corsair Vengeance PC1600 Hitachi 750gig sata 3 EVGA Geforce 550Ti 1g kernel 3.2.0-3
User avatar
dwainehead
Level 2
Level 2
 
Posts: 56
Joined: Tue Jan 10, 2012 2:03 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 3 guests