[SOLVED] installing screen.insserv: vmwareUSBArbitrator erro

Questions about applications and software
Forum rules
Before you post please read this

[SOLVED] installing screen.insserv: vmwareUSBArbitrator erro

Postby fiver22 on Sun Jun 03, 2012 8:52 pm

I went to install 'screen' and ended up with errors having to do with (of all things)
"'insserv: Starting vmware-USBArbitrator depends on minissdpd and therefore on system facility `$all' which can not be true!"
Assuming VMware was the culprit I purged it, dpkg --configure -a, I even rebooted, but STILL when attempting to install screen I get http://pastebin.com/ZrRC2ge4 Any ideas where I should start?

Some background: when installing VMware player I couldn't get it to start which led me to http://weltall.heliohost.org/wordpress/ ... 2-and-3-3/ I installed that patch and vmware started fine. Again I have removed vmware with purge and tried both apt-get -f install and dpkg --configure -a. but Im still getting "insserv: Starting vmware-USBArbitrator (...)
http://pastebin.com/ZrRC2ge4
I've even restarted :)
Where do I even start to figure out how to fix this? googling leads me to http://lists.debian.org/debian-user/201 ... 01060.html but that doesn't seem to be my situation as I've supposedly removed vmware -and even if it IS the fix I'm, shamefully, not certain I understand the instructions.

SOLUTION:
a friend, 'phos', guided me through this:
sudo mv /etc/init.d/vmware-USBArbitrator /home/fiver22
sudo mv /etc/init.d/vmware /home/fiver22
I then was able to sudo apt-get install screen without issue.
I then rm'd the files I moved to /home/fiver22 as I don't trust vmware AT ALL anymore.
I feel like saying it again: I don't trust VMware :D
User avatar
fiver22
Level 1
Level 1
 
Posts: 46
Joined: Wed Feb 01, 2012 8:08 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 5 guests