Pidgin upgrade to debian testing

Questions about applications and software
Forum rules
Before you post please read this

Pidgin upgrade to debian testing

Postby den68 on Sun Jun 17, 2012 12:42 pm

Hello,

I currently use LMDE latest that includes Pidgin 2.10.2.
this version has an annoying bug that is corrected in 2.10.3, according to Pidgin website.
So I decided to switch the Debian testing reps and upgrade only Pidgin.
However, when doing this ("sudo apt-get install pidgin"), I get the following :

Code: Select all
The following extra packages will be installed:
  compiz-core compiz-plugins cups-client cups-common fontconfig-config
  gir1.2-gdesktopenums-3.0 git git-core git-man glib-networking
  glib-networking-common glib-networking-services gnome-themes-standard
  gsettings-desktop-schemas libacl1 libattr1 libcogl9 libexiv2-12
  libfarstream-0.1-0 libfontconfig1 libgail-3-0 libgdk-pixbuf2.0-0
  libgdk-pixbuf2.0-common libglib2.0-0 libglib2.0-bin libgnutls26 libgtk-3-0
  libgtk-3-bin libgtk-3-common libjavascriptcoregtk-3.0-0 libpango1.0-0
  libperl5.14 libpurple0 libqt4-dbus libqt4-network libqt4-opengl libqt4-xml
  libqtcore4 libqtgui4 libsoup-gnome2.4-1 libsoup2.4-1 libvte-2.90-9
  libvte-2.90-common libwbclient0 libwebkitgtk-3.0-0 libwebkitgtk-3.0-common
  libwine libwine-alsa libwine-bin libwine-cms libwine-gecko-unstable
  libwine-gl libwine-gphoto2 libwine-ldap libwine-openal libwine-print
  libwine-sane libx11-6 libx11-dev libxfce4ui-1-0 libxfce4util-bin
  libxfce4util-common libxfce4util4 libxfconf-0-2 lpr mutter-common perl
  perl-base perl-modules pidgin-data qdbus samba-common
  shiki-colors-xfwm-theme wine wine-bin xfce-keyboard-shortcuts xfconf xfwm4
  xfwm4-themes
Suggested packages:
  xpp git-daemon-run git-daemon-sysvinit git-doc git-el git-arch git-cvs
  git-svn git-email git-gui gitk gitweb ttf-baekmuk ttf-arphic-gbsn00lp
  ttf-arphic-bsmi00lp ttf-arphic-gkai00mp ttf-arphic-bkai00mp tk8.5
  qt4-qtconfig wine-doc magicfilter apsfilter perl-doc
  libterm-readline-gnu-perl libterm-readline-perl-perl libpod-plainer-perl
  gnome-colors shiki-colors winbind avscan klamav clamav xfce4
Recommended packages:
  smbclient libx11-doc
The following packages will be REMOVED:
  apt-file autopoint banshee banshee-extension-soundmenu build-essential bum
  cinnamon cli-common command-not-found compiz compiz-gtk cowsay cups-bsd
  cups-driver-gutenprint debhelper docbook-xml dpkg-dev foomatic-db-engine
  foomatic-filters-ppds fusion-icon gir1.2-muffin-3.0 gir1.2-mutter-3.0 gthumb
  gthumb-data icoutils intltool-debian libalgorithm-diff-perl
  libalgorithm-diff-xs-perl libalgorithm-merge-perl libart2.0-cil
  libboo2.0.9-cil libcairo-perl libconfig-file-perl libdbus-glib1.0-cil
  libdbus1.0-cil libdpkg-perl libencode-locale-perl
  libfile-copy-recursive-perl libfile-listing-perl libflickrnet2.2-cil
  libfont-afm-perl libgconf2.0-cil libgdata1.7-cil libgdata1.9-cil
  libgkeyfile1.0-cil libglade2.0-cil libglib-perl libglib2.0-cil
  libgmime2.4-cil libgnome-vfs2.0-cil libgnome2-canvas-perl libgnome2-perl
  libgnome2-vfs-perl libgnome2.24-cil libgnomepanel2.24-cil
  libgstfarsight0.10-0 libgtk-sharp-beans-cil libgtk2-perl libgtk2.0-cil
  libgudev1.0-cil libhtml-format-perl libhtml-parser-perl libhtml-tagset-perl
  libhtml-tree-perl libhttp-cookies-perl libhttp-date-perl
  libhttp-message-perl libhttp-negotiate-perl libio-socket-ssl-perl
  liblist-moreutils-perl liblwp-mediatypes-perl liblwp-protocol-https-perl
  libmail-sendmail-perl libmailtools-perl libmetacity-private0a
  libmono-addins-gui0.2-cil libmono-addins0.2-cil libmono-cairo2.0-cil
  libmono-cairo4.0-cil libmono-compilerservices-symbolwriter4.0-cil
  libmono-corlib2.0-cil libmono-corlib4.0-cil libmono-data-tds2.0-cil
  libmono-data-tds4.0-cil libmono-i18n-west2.0-cil libmono-i18n-west4.0-cil
  libmono-i18n4.0-cil libmono-messaging2.0-cil libmono-posix2.0-cil
  libmono-posix4.0-cil libmono-security2.0-cil libmono-security4.0-cil
  libmono-sharpzip2.84-cil libmono-sharpzip4.84-cil libmono-simd2.0-cil
  libmono-sqlite2.0-cil libmono-sqlite4.0-cil
  libmono-system-configuration4.0-cil libmono-system-core4.0-cil
  libmono-system-data-linq2.0-cil libmono-system-data2.0-cil
  libmono-system-data4.0-cil libmono-system-drawing4.0-cil
  libmono-system-enterpriseservices4.0-cil libmono-system-messaging2.0-cil
  libmono-system-security4.0-cil libmono-system-transactions4.0-cil
  libmono-system-web-applicationservices4.0-cil
  libmono-system-web-services4.0-cil libmono-system-web2.0-cil
  libmono-system-web4.0-cil libmono-system-xml4.0-cil libmono-system2.0-cil
  libmono-system4.0-cil libmono-wcf3.0-cil libmono-web4.0-cil
  libmono-zeroconf1.0-cil libmono2.0-cil libmuffin0 libmutter0
  libndesk-dbus-glib1.0-cil libndesk-dbus1.0-cil libnet-dbus-perl
  libnet-http-perl libnet-ssleay-perl libnotify0.4-cil liboobs-1-5
  libpango-perl libregexp-assemble-perl libsys-hostname-long-perl
  libtaglib2.0-cil libtie-ixhash-perl libtimedate-perl liburi-perl libwww-perl
  libwww-robotrules-perl libxml-parser-perl libxml-twig-perl lm-sensors
  mate-desktop-environment mate-system-tools metacity metacity-common
  mint-meta-common mintsystem module-assistant mono-2.0-gac mono-4.0-gac
  mono-gac mono-runtime muffin-common nvidia-kernel-source playonlinux
  po-debconf printer-driver-gutenprint quilt rarian-compat samba sane-utils
  sgml-base sgml-data shiki-colors-metacity-theme shiki-wise-theme
  system-tools-backends tasksel tasksel-data tomboy update-inetd xml-core
The following NEW packages will be installed:
  gir1.2-gdesktopenums-3.0 git-core libcogl9 libexiv2-12 libfarstream-0.1-0
  libwine-gecko-unstable libxfce4ui-1-0 libxfce4util-bin libxfce4util-common
  libxfce4util4 libxfconf-0-2 lpr shiki-colors-xfwm-theme
  xfce-keyboard-shortcuts xfconf xfwm4 xfwm4-themes
The following packages will be upgraded:
  compiz-core compiz-plugins cups-client cups-common fontconfig-config git
  git-man glib-networking glib-networking-common glib-networking-services
  gnome-themes-standard gsettings-desktop-schemas libacl1 libattr1
  libfontconfig1 libgail-3-0 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
  libglib2.0-0 libglib2.0-bin libgnutls26 libgtk-3-0 libgtk-3-bin
  libgtk-3-common libjavascriptcoregtk-3.0-0 libpango1.0-0 libperl5.14
  libpurple0 libqt4-dbus libqt4-network libqt4-opengl libqt4-xml libqtcore4
  libqtgui4 libsoup-gnome2.4-1 libsoup2.4-1 libvte-2.90-9 libvte-2.90-common
  libwbclient0 libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libwine libwine-alsa
  libwine-bin libwine-cms libwine-gl libwine-gphoto2 libwine-ldap
  libwine-openal libwine-print libwine-sane libx11-6 libx11-dev mutter-common
  perl perl-base perl-modules pidgin pidgin-data qdbus samba-common wine
  wine-bin
63 upgraded, 17 newly installed, 169 to remove and 870 not upgraded.
Need to get 106 MB of archives.
After this operation, 121 MB disk space will be freed.
Do you want to continue [Y/n]?


that seems a lot just to upgrade Pidgin, so my question is : is it safe ? am I doing it right ?

Thanks !
chris
den68
Level 1
Level 1
 
Posts: 45
Joined: Sun Jun 17, 2012 12:32 pm

Linux Mint is funded by ads and donations.
 

Re: Pidgin upgrade to debian testing

Postby zerozero on Sun Jun 17, 2012 12:56 pm

of course it doesn't look safe :shock:
please share with us
Code: Select all
inxi -Sr
also
Code: Select all
cat /etc/apt/preferences
and finally
Code: Select all
sudo apt-get -t testing install pidgin
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: Pidgin upgrade to debian testing

Postby den68 on Sun Jun 17, 2012 5:20 pm

here it is :

Code: Select all
home ~ $ inxi -Sr
System:    Host home Kernel 3.2.0-2-486 i686 (32 bit) Distro Linux Mint Debian Edition
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream
           deb http://ftp.fr.debian.org/debian/ testing main contrib non-free
           deb http://www.debian-multimedia.org testing main non-free
           deb http://security.debian.org/ testing/updates main contrib non-free
           deb http://repository.spotify.com stable non-free


home ~ $ cat /etc/apt/preferences
Package: *
Pin: release o=linuxmint
Pin-Priority: 500

Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 500

Package: *
Pin: release o=Debian
Pin-Priority: 500



home ~ $ sudo apt-get -t testing install pidgin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libwine-alsa libwine-openal libwine libwine-ldap wine-bin libwine-gphoto2
  wine libwine-print libkarma0 libwine-bin libwine-cms libwine-gl libmpg123-0
  libwine-sane libcogl9 libexiv2-12 gir1.2-gdesktopenums-3.0
  libwine-gecko-unstable
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  compiz-core compiz-plugins cups-client cups-common fontconfig-config
  gir1.2-gdesktopenums-3.0 git git-core git-man glib-networking
  glib-networking-common glib-networking-services gnome-themes-standard
  gsettings-desktop-schemas libacl1 libattr1 libcogl9 libexiv2-12
  libfarstream-0.1-0 libfontconfig1 libgail-3-0 libgdk-pixbuf2.0-0
  libgdk-pixbuf2.0-common libglib2.0-0 libglib2.0-bin libgnutls26 libgtk-3-0
  libgtk-3-bin libgtk-3-common libjavascriptcoregtk-3.0-0 libpango1.0-0
  libperl5.14 libpurple0 libqt4-dbus libqt4-network libqt4-opengl libqt4-xml
  libqtcore4 libqtgui4 libsoup-gnome2.4-1 libsoup2.4-1 libvte-2.90-9
  libvte-2.90-common libwbclient0 libwebkitgtk-3.0-0 libwebkitgtk-3.0-common
  libwine libwine-alsa libwine-bin libwine-cms libwine-gecko-unstable
  libwine-gl libwine-gphoto2 libwine-ldap libwine-openal libwine-print
  libwine-sane libx11-6 libx11-dev libxfce4ui-1-0 libxfce4util-bin
  libxfce4util-common libxfce4util4 libxfconf-0-2 lpr mutter-common perl
  perl-base perl-modules pidgin-data qdbus samba-common
  shiki-colors-xfwm-theme wine wine-bin xfce-keyboard-shortcuts xfconf xfwm4
  xfwm4-themes
Suggested packages:
  xpp git-daemon-run git-daemon-sysvinit git-doc git-el git-arch git-cvs
  git-svn git-email git-gui gitk gitweb ttf-baekmuk ttf-arphic-gbsn00lp
  ttf-arphic-bsmi00lp ttf-arphic-gkai00mp ttf-arphic-bkai00mp tk8.5
  qt4-qtconfig wine-doc magicfilter apsfilter perl-doc
  libterm-readline-gnu-perl libterm-readline-perl-perl libpod-plainer-perl
  gnome-colors shiki-colors winbind avscan klamav clamav xfce4
Recommended packages:
  smbclient libx11-doc
The following packages will be REMOVED:
  apt-file autopoint banshee banshee-extension-soundmenu build-essential bum
  cinnamon cli-common command-not-found compiz compiz-gtk cowsay cups-bsd
  cups-driver-gutenprint debhelper docbook-xml dpkg-dev foomatic-db-engine
  foomatic-filters-ppds fusion-icon gir1.2-muffin-3.0 gir1.2-mutter-3.0 gthumb
  gthumb-data icoutils intltool-debian libalgorithm-diff-perl
  libalgorithm-diff-xs-perl libalgorithm-merge-perl libart2.0-cil
  libboo2.0.9-cil libcairo-perl libconfig-file-perl libdbus-glib1.0-cil
  libdbus1.0-cil libdpkg-perl libencode-locale-perl
  libfile-copy-recursive-perl libfile-listing-perl libflickrnet2.2-cil
  libfont-afm-perl libgconf2.0-cil libgdata1.7-cil libgdata1.9-cil
  libgkeyfile1.0-cil libglade2.0-cil libglib-perl libglib2.0-cil
  libgmime2.4-cil libgnome-vfs2.0-cil libgnome2-canvas-perl libgnome2-perl
  libgnome2-vfs-perl libgnome2.24-cil libgnomepanel2.24-cil
  libgstfarsight0.10-0 libgtk-sharp-beans-cil libgtk2-perl libgtk2.0-cil
  libgudev1.0-cil libhtml-format-perl libhtml-parser-perl libhtml-tagset-perl
  libhtml-tree-perl libhttp-cookies-perl libhttp-date-perl
  libhttp-message-perl libhttp-negotiate-perl libio-socket-ssl-perl
  liblist-moreutils-perl liblwp-mediatypes-perl liblwp-protocol-https-perl
  libmail-sendmail-perl libmailtools-perl libmetacity-private0a
  libmono-addins-gui0.2-cil libmono-addins0.2-cil libmono-cairo2.0-cil
  libmono-cairo4.0-cil libmono-compilerservices-symbolwriter4.0-cil
  libmono-corlib2.0-cil libmono-corlib4.0-cil libmono-data-tds2.0-cil
  libmono-data-tds4.0-cil libmono-i18n-west2.0-cil libmono-i18n-west4.0-cil
  libmono-i18n4.0-cil libmono-messaging2.0-cil libmono-posix2.0-cil
  libmono-posix4.0-cil libmono-security2.0-cil libmono-security4.0-cil
  libmono-sharpzip2.84-cil libmono-sharpzip4.84-cil libmono-simd2.0-cil
  libmono-sqlite2.0-cil libmono-sqlite4.0-cil
  libmono-system-configuration4.0-cil libmono-system-core4.0-cil
  libmono-system-data-linq2.0-cil libmono-system-data2.0-cil
  libmono-system-data4.0-cil libmono-system-drawing4.0-cil
  libmono-system-enterpriseservices4.0-cil libmono-system-messaging2.0-cil
  libmono-system-security4.0-cil libmono-system-transactions4.0-cil
  libmono-system-web-applicationservices4.0-cil
  libmono-system-web-services4.0-cil libmono-system-web2.0-cil
  libmono-system-web4.0-cil libmono-system-xml4.0-cil libmono-system2.0-cil
  libmono-system4.0-cil libmono-wcf3.0-cil libmono-web4.0-cil
  libmono-zeroconf1.0-cil libmono2.0-cil libmuffin0 libmutter0
  libndesk-dbus-glib1.0-cil libndesk-dbus1.0-cil libnet-dbus-perl
  libnet-http-perl libnet-ssleay-perl libnotify0.4-cil liboobs-1-5
  libpango-perl libregexp-assemble-perl libsys-hostname-long-perl
  libtaglib2.0-cil libtie-ixhash-perl libtimedate-perl liburi-perl libwww-perl
  libwww-robotrules-perl libxml-parser-perl libxml-twig-perl lm-sensors
  mate-desktop-environment mate-system-tools metacity metacity-common
  mint-meta-common mintsystem module-assistant mono-2.0-gac mono-4.0-gac
  mono-gac mono-runtime muffin-common nvidia-kernel-source playonlinux
  po-debconf printer-driver-gutenprint quilt rarian-compat samba sane-utils
  sgml-base sgml-data shiki-colors-metacity-theme shiki-wise-theme
  system-tools-backends tasksel tasksel-data tomboy update-inetd xml-core
The following NEW packages will be installed:
  gir1.2-gdesktopenums-3.0 git-core libcogl9 libexiv2-12 libfarstream-0.1-0
  libwine-gecko-unstable libxfce4ui-1-0 libxfce4util-bin libxfce4util-common
  libxfce4util4 libxfconf-0-2 lpr shiki-colors-xfwm-theme
  xfce-keyboard-shortcuts xfconf xfwm4 xfwm4-themes
The following packages will be upgraded:
  compiz-core compiz-plugins cups-client cups-common fontconfig-config git
  git-man glib-networking glib-networking-common glib-networking-services
  gnome-themes-standard gsettings-desktop-schemas libacl1 libattr1
  libfontconfig1 libgail-3-0 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
  libglib2.0-0 libglib2.0-bin libgnutls26 libgtk-3-0 libgtk-3-bin
  libgtk-3-common libjavascriptcoregtk-3.0-0 libpango1.0-0 libperl5.14
  libpurple0 libqt4-dbus libqt4-network libqt4-opengl libqt4-xml libqtcore4
  libqtgui4 libsoup-gnome2.4-1 libsoup2.4-1 libvte-2.90-9 libvte-2.90-common
  libwbclient0 libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libwine libwine-alsa
  libwine-bin libwine-cms libwine-gl libwine-gphoto2 libwine-ldap
  libwine-openal libwine-print libwine-sane libx11-6 libx11-dev mutter-common
  perl perl-base perl-modules pidgin pidgin-data qdbus samba-common wine
  wine-bin
63 upgraded, 17 newly installed, 169 to remove and 870 not upgraded.
Need to get 106 MB of archives.
After this operation, 121 MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.
den68
Level 1
Level 1
 
Posts: 45
Joined: Sun Jun 17, 2012 12:32 pm

Re: Pidgin upgrade to debian testing

Postby zerozero on Sun Jun 17, 2012 5:34 pm

wait a minute :shock:
you want to pick pidgin from testing and keep the system within the UP or you want fully move to testing?

EDIT:
according to this:
So I decided to switch the Debian testing reps and upgrade only Pidgin
i assume your intention is to update only pidgin, if so that is not the way to go.
1- you have to keep the default latest repos and add the debian testing;
2- you shouldn't alter the preferences file;
3- after 1- and 2- do a system update and install pidgin from testing with the -t testing switch;

let us know.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: Pidgin upgrade to debian testing

Postby Lippy on Sun Jun 17, 2012 6:29 pm

The newer version of Pidgin depends on libfarstream, which replaces the older libfarsight. If you are just cherry-picking Pidgin from testing, then it will conflict with those packages that still depend on the older libfarsight. Empathy comes to mind. Unfortunately, upgrading Empathy isn't trivial as upgrading that will pull in all the Gnome 3.4 packages with it. This also breaks Cinnamon as there is no way for the new and old libclutter to co-exist on the system.

So I'm afraid you are left with only two choices. You can either hold off on the Pidgin upgrade until the next Update Pack, by which time the dependencies will be solved, or upgrade the whole OS to Debian Testing. There isn't much else you can do right now. :(
LMDE (tracking Testing) with Cinnamon; Intel Core 2 Duo E8400, Nvidia GeForce GTX 260 (using Nouveau)
Lippy
Level 2
Level 2
 
Posts: 68
Joined: Thu Oct 06, 2011 12:28 pm

Re: Pidgin upgrade to debian testing

Postby den68 on Mon Jun 18, 2012 2:37 am

thanks a lot for the help.

zerozero, I tried the way you said, it didn't make a difference, although I now realize I was not doing it the right way.

Lippy, I see what you mean, I'll stay with my bug for now in hope to see an UP in the coming weeks.
den68
Level 1
Level 1
 
Posts: 45
Joined: Sun Jun 17, 2012 12:32 pm

Re: Pidgin upgrade to debian testing

Postby zerozero on Mon Jun 18, 2012 10:48 am

i tried all the possible combinations but pidgin has a dep on libpurple0 that makes it uninstallable the way you want
Code: Select all
amadeu@zerozero:~$ sudo apt-get -t testing install pidgin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 pidgin : Depends: libpurple0 (>= 2.8.0) but it is not going to be installed
E: Broken packages

because if you try libpurple0
Code: Select all
amadeu@zerozero:~$ sudo apt-get -t testing install libpurple0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  mate-netspeed python-pyatspi2 libatspi2.0-0 at-spi2-core python-mate-menu
  mozo libv8-3.6.6.14 libglew1.6 caribou mate-sensors-applet gir1.2-atspi-2.0
  mate-calc pax mate-utils libmatesensorsappletplugin ncurses-term librpmio3
  libcogl9 libexiv2-12 gir1.2-gcr-3 gir1.2-gck-1 gir1.2-gdesktopenums-3.0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  compiz-core compiz-plugins cups-client cups-common emesene eog
  fontconfig-config gcr gir1.2-gck-1 gir1.2-gcr-3 gir1.2-gdesktopenums-3.0 git
  git-core git-man glib-networking glib-networking-common
  glib-networking-services gnome-desktop-data gnome-desktop3-data
  gnome-keyring gnome-settings-daemon gnome-shell-common gnome-themes-standard
  gnome-tweak-tool gsettings-desktop-schemas libacl1 libattr1 libcogl9
  libexiv2-12 libfarstream-0.1-0 libfontconfig1 libgail-3-0 libgck-1-0
  libgcr-3-1 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgirepository-1.0-1
  libgjs0b libglib2.0-0 libglib2.0-bin libgnome-desktop-3-2 libgnutls26
  libgtk-3-0 libgtk-3-bin libgtk-3-common libjavascriptcoregtk-3.0-0
  libpango1.0-0 libperl5.14 librpmio3 libsoup-gnome2.4-1 libsoup2.4-1
  libtelepathy-glib0 libvte-2.90-9 libvte-2.90-common libwacom-common
  libwacom2 libwbclient0 libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libx11-6
  libx11-dev libxfce4ui-1-0 libxfce4util-bin libxfce4util-common libxfce4util4
  libxfconf-0-2 lpr lsb-release mutter-common perl perl-base perl-modules
  pidgin pidgin-data python-farstream python-gi python-gi-cairo samba-common
  seahorse shiki-colors-xfwm-theme xfce-keyboard-shortcuts xfconf xfwm4
  xfwm4-themes
Suggested packages:
  xpp git-daemon-run git-daemon-sysvinit git-doc git-el git-arch git-cvs
  git-svn git-email git-gui gitk gitweb ttf-baekmuk ttf-arphic-gbsn00lp
  ttf-arphic-bsmi00lp ttf-arphic-gkai00mp ttf-arphic-bkai00mp tk8.5
  magicfilter apsfilter lsb perl-doc libterm-readline-gnu-perl
  libterm-readline-perl-perl libpod-plainer-perl gnome-colors shiki-colors
  xfce4
Recommended packages:
  smbclient
The following packages will be REMOVED:
  alien apt-file autoconf autoconf2.13 automake automake1.4 autopoint banshee
  broadcom-sta-source build-essential checkinstall cinnamon cli-common
  command-not-found compiz-gtk cowsay cups-bsd cups-driver-gutenprint
  debhelper docbook-xml dpkg-dev f-spot foomatic-db-engine
  foomatic-filters-ppds gir1.2-muffin-3.0 gir1.2-mutter-3.0 giver gnome-common
  gnome-session gnome-session-fallback gnome-shell gnome-system-tools
  googleearth gthumb gthumb-data intltool intltool-debian
  libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl
  libart2.0-cil libavahi1.0-cil libboo2.0.9-cil libcairo-perl
  libclass-accessor-perl libconfig-file-perl libdbus-glib1.0-cil
  libdbus1.0-cil libdpkg-perl libencode-locale-perl
  libfile-copy-recursive-perl libfile-listing-perl libflickrnet2.2-cil
  libfont-afm-perl libgconf2.0-cil libgdata1.7-cil libgdata1.8-cil
  libgdata1.9-cil libgkeyfile1.0-cil libglade2.0-cil libglib-perl
  libglib2.0-cil libgmime2.4-cil libgnome-keyring1.0-cil libgnome-vfs2.0-cil
  libgnome2-canvas-perl libgnome2-perl libgnome2-vfs-perl libgnome2.24-cil
  libgnomepanel2.24-cil libgstfarsight0.10-0 libgtk-sharp-beans-cil
  libgtk2-perl libgtk2.0-cil libgudev1.0-cil libhtml-format-perl
  libhtml-parser-perl libhtml-tagset-perl libhtml-template-perl
  libhtml-tree-perl libhttp-cookies-perl libhttp-date-perl
  libhttp-message-perl libhttp-negotiate-perl libio-socket-inet6-perl
  libio-socket-ssl-perl libio-string-perl liblist-moreutils-perl
  liblwp-mediatypes-perl liblwp-protocol-https-perl libmail-sendmail-perl
  libmailtools-perl libmetacity-private0a libmono-addins-gui0.2-cil
  libmono-addins0.2-cil libmono-cairo2.0-cil libmono-cairo4.0-cil
  libmono-compilerservices-symbolwriter4.0-cil libmono-corlib2.0-cil
  libmono-corlib4.0-cil libmono-data-tds2.0-cil libmono-data-tds4.0-cil
  libmono-i18n-west2.0-cil libmono-i18n-west4.0-cil libmono-i18n4.0-cil
  libmono-messaging2.0-cil libmono-posix2.0-cil libmono-posix4.0-cil
  libmono-security2.0-cil libmono-security4.0-cil libmono-sharpzip2.84-cil
  libmono-sharpzip4.84-cil libmono-simd2.0-cil libmono-simd4.0-cil
  libmono-sqlite2.0-cil libmono-sqlite4.0-cil
  libmono-system-configuration4.0-cil libmono-system-core4.0-cil
  libmono-system-data-linq2.0-cil libmono-system-data2.0-cil
  libmono-system-data4.0-cil libmono-system-drawing4.0-cil
  libmono-system-enterpriseservices4.0-cil libmono-system-messaging2.0-cil
  libmono-system-security4.0-cil libmono-system-transactions4.0-cil
  libmono-system-web-applicationservices4.0-cil
  libmono-system-web-services4.0-cil libmono-system-web2.0-cil
  libmono-system-web4.0-cil libmono-system-xml4.0-cil libmono-system2.0-cil
  libmono-system4.0-cil libmono-wcf3.0-cil libmono-web4.0-cil
  libmono-zeroconf1.0-cil libmono2.0-cil libmuffin0 libmutter0
  libndesk-dbus-glib1.0-cil libndesk-dbus1.0-cil libnet-dbus-perl
  libnet-http-perl libnet-ssleay-perl libnotify0.4-cil liboobs-1-4 liboobs-1-5
  libpango-perl libparse-debianchangelog-perl libregexp-assemble-perl
  libsocket6-perl libsub-name-perl libsys-hostname-long-perl libtaglib2.0-cil
  libtie-ixhash-perl libtimedate-perl liburi-perl libwww-perl
  libwww-robotrules-perl libx11-protocol-perl libxml-namespacesupport-perl
  libxml-parser-perl libxml-sax-base-perl libxml-sax-expat-perl
  libxml-sax-perl libxml-simple-perl libxml-twig-perl lm-sensors lsb-core
  mate-desktop-environment mate-system-tools metacity metacity-common
  mint-meta-common mintsystem module-assistant mono-2.0-gac mono-4.0-gac
  mono-gac mono-runtime muffin muffin-common pinta po-debconf
  printer-driver-gutenprint python-farsight python-papyon rarian-compat rpm
  samba sane-utils sgml-base sgml-data shiki-colors-metacity-theme
  shiki-wise-theme system-tools-backends tomboy update-inetd xml-core
The following NEW packages will be installed:
  gcr gir1.2-gck-1 gir1.2-gcr-3 gir1.2-gdesktopenums-3.0 git-core libcogl9
  libexiv2-12 libfarstream-0.1-0 librpmio3 libwacom-common libwacom2
  libxfce4ui-1-0 libxfce4util-bin libxfce4util-common libxfce4util4
  libxfconf-0-2 lpr python-farstream shiki-colors-xfwm-theme
  xfce-keyboard-shortcuts xfconf xfwm4 xfwm4-themes
The following packages will be upgraded:
  compiz-core compiz-plugins cups-client cups-common emesene eog
  fontconfig-config git git-man glib-networking glib-networking-common
  glib-networking-services gnome-desktop-data gnome-desktop3-data
  gnome-keyring gnome-settings-daemon gnome-shell-common gnome-themes-standard
  gnome-tweak-tool gsettings-desktop-schemas libacl1 libattr1 libfontconfig1
  libgail-3-0 libgck-1-0 libgcr-3-1 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
  libgirepository-1.0-1 libgjs0b libglib2.0-0 libglib2.0-bin
  libgnome-desktop-3-2 libgnutls26 libgtk-3-0 libgtk-3-bin libgtk-3-common
  libjavascriptcoregtk-3.0-0 libpango1.0-0 libperl5.14 libpurple0
  libsoup-gnome2.4-1 libsoup2.4-1 libtelepathy-glib0 libvte-2.90-9
  libvte-2.90-common libwbclient0 libwebkitgtk-3.0-0 libwebkitgtk-3.0-common
  libx11-6 libx11-dev lsb-release mutter-common perl perl-base perl-modules
  pidgin pidgin-data python-gi python-gi-cairo samba-common seahorse
62 upgraded, 23 newly installed, 199 to remove and 907 not upgraded.
Need to get 87.2 MB of archives.
After this operation, 270 MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.

too much for just a IM i think.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 2 guests