LMDE & Bumblebee

Questions about applications and software
Forum rules
Before you post please read how to get help

LMDE & Bumblebee

Postby kristof on Wed Jun 20, 2012 11:18 am

I'm running LMDE on a Dell Vostro 3750 with Bumblebee installed to support the Nvidia Optimus stuff. The only time I really want to use the Nvidia card is when dual booting into Windows. I'm a little confused though, as I thought Bumblebee's power management allowed you to do just that, i.e. use only the Intel card unless a program was specifically launched using optirun. However I find when randomly checking the status of the card here and there that often it's been turned on for reasons unclear to me:

Code: Select all
kristof@kristof ~ $ more /proc/acpi/bbswitch
0000:01:00.0 ON


I've been turning it off using

Code: Select all
kristof@kristof ~ $ sudo rmmod nvidia
[sudo] password for kristof:
kristof@kristof ~ $ sudo tee /proc/acpi/bbswitch <<<OFF
OFF


which appears to work fine. Does anyone know of a better 'permanent' solution to instruct Bumblebee never to turn on the card unless I explicitly ask for it?
kristof
Level 1
Level 1
 
Posts: 4
Joined: Thu Aug 19, 2010 12:37 pm

Linux Mint is funded by ads and donations.
 

Re: LMDE & Bumblebee

Postby reidiculous on Thu Jun 21, 2012 3:09 pm

Hola Kristof,

I experienced something similar, here are 2 things you should check:

1. make sure the bumblebeed daemon is running - if not, the card will be on. the bumblebee install gives you an init startup script
2. see the module options on bbswitch page and set both states to 0

Hope this helps
reidiculous
Level 1
Level 1
 
Posts: 1
Joined: Thu Jun 21, 2012 3:02 pm

Re: LMDE & Bumblebee

Postby mint-me on Tue Jun 26, 2012 10:48 am

Turn it off for good.
Disable NVIDIA in Optimus and run Integrated Intel graphics only:
http://main.solusos.com/showthread.php? ... Priority-1
Mint 17 Cinnamon 64bit
Dell Inspiron 15R(N5110) Intel i7-2670QM, 4GB DDR3 1333Mhz, Intel 6 Express HM67
GeForce GT525M, 500G SATA, 15.6" HD 1366x768 Optimus on Bumblebee
mint-me
Level 2
Level 2
 
Posts: 83
Joined: Sat May 26, 2012 2:25 am
Location: australia

Re: LMDE & Bumblebee

Postby mint-me on Thu Aug 16, 2012 9:23 am

See also http://main.solusos.com/showthread.php? ... us-Support
the links to install Bumblebee on Squeeze and Wheezy (in SolusOS 1 & 2) have a better fix if this problem persists:

The following is a fix (avoids libvdpau probe activating Nvidia GPU) that ensures the NVIDIA card stays OFF when not in use by optirun.

Enter your username where appears $USER:
Code: Select all
# echo 'DEVPATH=="/module/nvidia", ACTION=="remove", RUN+="/bin/rm  /dev/nvidia0 /dev/nvidiactl"' >>  /etc/udev/rules.d/99-nvidiactl.rules
# usermod -a -G video $USER
# update-initramfs -u
Mint 17 Cinnamon 64bit
Dell Inspiron 15R(N5110) Intel i7-2670QM, 4GB DDR3 1333Mhz, Intel 6 Express HM67
GeForce GT525M, 500G SATA, 15.6" HD 1366x768 Optimus on Bumblebee
mint-me
Level 2
Level 2
 
Posts: 83
Joined: Sat May 26, 2012 2:25 am
Location: australia


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 5 guests