Java upgrade problem

Questions about applications and software
Forum rules
Before you post please read this

Java upgrade problem

Postby zkab on Thu Jul 05, 2012 12:07 pm

I have Mint LMDE 64bits and followed the guide http://www.wikihow.com/Install-Oracle-Java-on-Ubuntu-Linux to upgrade Java to Version 7 Update 5.
It went without problem but when checking Java version with http://www.java.com/en/download/testjava.jsp I get message 'Java(TM) was blocked because it is out of date'
When I click 'Run this time' it tells me: Java SE 6 Update 26 ... hmm ...

dpkg -l sun-java6* gives that version 6 is still installed:

ii sun-java6-bin 6.26-1 Sun Java(TM) Runtime Environment (JRE) 6 (architecture dependent files)
un sun-java6-fonts <none> (no description available)
un sun-java6-jdk <none> (no description available)
ii sun-java6-jre 6.26-1 Sun Java(TM) Runtime Environment (JRE) 6 (architecture independent files)
ii sun-java6-plugin 6.26-1 Java(TM) Plug-in, Java SE 6

and when I try to remove sudo apt-get remove sun-java6* --purge it suggests new packages to be install (that I removed before started to install Java 7 Update 5)

sudo apt-get remove sun-java6* --purge
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'sun-java5-jre' for regex 'sun-java6*'
Note, selecting 'sun-java6-jre' for regex 'sun-java6*'
Note, selecting 'sun-java6-jdk' for regex 'sun-java6*'
Note, selecting 'sun-java6-fonts' for regex 'sun-java6*'
Note, selecting 'sun-java6-bin' for regex 'sun-java6*'
Note, selecting 'ia32-sun-java6-bin' for regex 'sun-java6*'
Note, selecting 'sun-java6-plugin' for regex 'sun-java6*'
Note, selecting 'ia32-sun-java6-plugin' for regex 'sun-java6*'
The following extra packages will be installed:
default-jre default-jre-headless icedtea-6-jre-cacao icedtea-6-jre-jamvm icedtea-netx icedtea-netx-common openjdk-6-jre openjdk-6-jre-headless openjdk-6-jre-lib
Suggested packages:
icedtea-plugin sun-java6-fonts fonts-ipafont-gothic fonts-ipafont-mincho ttf-indic-fonts
The following packages will be REMOVED:
sun-java6-bin* sun-java6-jre* sun-java6-plugin*
The following NEW packages will be installed:
default-jre default-jre-headless icedtea-6-jre-cacao icedtea-6-jre-jamvm icedtea-netx icedtea-netx-common openjdk-6-jre openjdk-6-jre-headless openjdk-6-jre-lib
0 upgraded, 9 newly installed, 3 to remove and 0 not upgraded.
Need to get 0 B/33,2 MB of archives.
After this operation, 11,9 MB disk space will be freed.

How can I get my system to understand that I run Java 7 and get rid of all prior versions ?
zkab
Level 2
Level 2
 
Posts: 79
Joined: Wed Jun 22, 2011 7:46 pm

Linux Mint is funded by ads and donations.
 

Re: Java upgrade problem

Postby zerozero on Thu Jul 05, 2012 7:27 pm

[moved here]
check this viewtopic.php?f=197&t=98650
zerozero
Level 16
Level 16
 
Posts: 6474
Joined: Tue Jul 07, 2009 2:29 pm


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 1 guest