Can't go fullscreen in chrome

Questions about applications and software
Forum rules
Before you post please read this

Can't go fullscreen in chrome

Postby aptitude on Sat Jul 07, 2012 2:46 pm

I'm using LMDE and I have the latest version of google chrome. I cannot view my videos in fullscreen whether it's youtube or any other site. When I click the fullscreen button, the video just blinks but stays the same. I've tried disabling flash and enabling it again, bit that didnt help. Any ideas on how to fix this? Firefox works well by the way, but i rarely use it, so it'd be great if i have everything working in chrome.
aptitude
Level 1
Level 1
 
Posts: 10
Joined: Wed Jun 20, 2012 11:07 am

Linux Mint is funded by ads and donations.
 

Re: Can't go fullscreen in chrome

Postby Sonsum on Sat Jul 07, 2012 5:40 pm

Hmmm. what Desktop Environment are you running?
Sonsum
Level 3
Level 3
 
Posts: 111
Joined: Fri Jun 24, 2011 9:03 pm

Re: Can't go fullscreen in chrome

Postby aptitude on Sat Jul 07, 2012 7:54 pm

I have mate, cinnamon, gnome and kde. The problem occurs in all desktop environments
aptitude
Level 1
Level 1
 
Posts: 10
Joined: Wed Jun 20, 2012 11:07 am

Re: Can't go fullscreen in chrome

Postby Sonsum on Sun Jul 08, 2012 2:19 am

Is this 32 bit or 64 bit Chrome? I believe 32 bit comes with its own version of flash, while the 64 bit does not.

EDIT: Also, have you tried Chromium? I don't think it's much different than Chrome.
Sonsum
Level 3
Level 3
 
Posts: 111
Joined: Fri Jun 24, 2011 9:03 pm

Re: Can't go fullscreen in chrome

Postby xircon on Sun Jul 08, 2012 12:36 pm

Confirmed LMDE 64bit Cinnamon - videos will not go full screen. Version 21.0.1180.15 dev.
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Can't go fullscreen in chrome

Postby craigevil on Sun Jul 08, 2012 1:37 pm

Look in about:plugins and post the version of Flash being used. Disable the system version and make sure it is using the built in version.

You can also try deleting the Chrome cache in ~/.cache/google-chrome/
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: Can't go fullscreen in chrome

Postby xircon on Sun Jul 08, 2012 1:44 pm

Thought I had done that, but an update must of overwritten it. PepperFlash will go full screen.

Cheers Craig.

Steve
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Can't go fullscreen in chrome

Postby xircon on Sun Jul 08, 2012 2:23 pm

Spoke too soon, first video worked, next didn't. This is what is happening:
http://www.youtube.com/watch?v=cOIXDfAj ... e=youtu.be

Deleted cache and disabled everything but pepper.
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Can't go fullscreen in chrome

Postby setcho on Fri Jul 13, 2012 3:59 am

I have exactly the same problem as xircon and I'm running Mint 13 Cinnamon (should I create a new thread in the correct section ?). I was hoping an update to Chrome would fix the issue but I installed one yesterday and nothing has changed. Note Chromium works fine but I prefer to use Chrome so any help would be appreciated.

@craigevil My Chrome Flash is Version: 11.3.31.115. How do I disable the system version? I uninstalled mint-flashplugin (along with mint meta codecs) from synaptic and tried Chrome again but it still doesn't work. Is there a way to disable Chrome flash and make it use flash the way Firefox does?

@xircon Did you find a fix for this?

I tried the answer given here http://askubuntu.com/questions/157437/videos-wont-go-into-full-screen i.e. turn off 11.3 flash and use 11.2 but after I did this websites like BBC iPlayer tell me flash is out of date and refuse to play.

Thanks in advance
setcho
Level 1
Level 1
 
Posts: 20
Joined: Thu Jun 23, 2011 3:38 am

Re: Can't go fullscreen in chrome

Postby xircon on Fri Jul 13, 2012 4:48 am

Nope, I really like chrome, but it's constant memory leaks are killing me and kept overheating my laptop, I am currently using (and getting used to) Opera. Going well so far.
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Can't go fullscreen in chrome

Postby setcho on Wed Jul 18, 2012 3:32 am

Thank for the the reply xircon. I might give Opera a go I haven't tried it for about 5 years.
setcho
Level 1
Level 1
 
Posts: 20
Joined: Thu Jun 23, 2011 3:38 am

Re: Can't go fullscreen in chrome

Postby xircon on Wed Jul 18, 2012 3:41 am

Try opera-next rather than opera, it works better if you use a theme that removes the titlebar.
http://www.opera.com/browser/next/
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Can't go fullscreen in chrome

Postby setcho on Wed Jul 18, 2012 4:08 am

I spoke too soon, I have fixed it! A closer reading of the askubuntu answer (link above) was what I needed.

We need to switch Chrome to flash 11.2. However because we are using Linux Mint, flash version 11.2 isn't installed only 11.0.1 is. What you need to do is remove mint-flashplugin-11 from synaptic and install flashplugin-installer (i.e. 11.2) and then do the following

1. In the URL bar enter chrome://plugins/
2. Locate the Flash plug-in, you should see multiple versions listed
3. Click Disable for the plug-in with the location /opt/google/chrome/PepperFlash/libpepflashplayer.so (11.3)
4. You should still have one enabled in another location, like /usr/lib/adobe-flashplugin/libflashplayer.so (11.2)
5. Restart Chrome (quit and open again)

Hope this helps. I'll still give opera-next a go as well.
setcho
Level 1
Level 1
 
Posts: 20
Joined: Thu Jun 23, 2011 3:38 am

Re: Can't go fullscreen in chrome

Postby xircon on Wed Jul 18, 2012 4:21 am

Not working for me:
Code: Select all
Flash (3 files) - Version: 11.2 r202
Shockwave Flash 11.2 r202
Name:   Shockwave Flash
Description:   Shockwave Flash 11.3 r31
Version:   11.3.31.208
Location:   /opt/google/chrome/PepperFlash/libpepflashplayer.so
Type:   PPAPI (out-of-process)
     Enable
MIME types:   
MIME type   Description   File extensions
application/x-shockwave-flash   Shockwave Flash   
.swf
application/futuresplash   FutureSplash Player   
.spl
Name:   Shockwave Flash
Version:   11.2 r202
Location:   /usr/lib/flashplugin-nonfree/libflashplayer.so
Type:   NPAPI
     Disable
MIME types:   
MIME type   Description   File extensions
application/x-shockwave-flash   Shockwave Flash   
.swf
application/futuresplash   FutureSplash Player   
.spl
Name:   Shockwave Flash
Version:   11.2 r202
Location:   /opt/mint-flashplugin-x64/libflashplayer.so
Type:   NPAPI
     Enable
MIME types:   
MIME type   Description   File extensions
application/x-shockwave-flash   Shockwave Flash   
.swf
application/futuresplash   FutureSplash Player   
.spl


Still unresponsive and useless :(
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Can't go fullscreen in chrome

Postby setcho on Wed Jul 18, 2012 4:39 am

here's mine
Code: Select all
Flash (2 files) - Version: 11.2 r202
Shockwave Flash 11.2 r202
Name:   Shockwave Flash
Description:   Shockwave Flash 11.3 r31
Version:   11.3.31.115
Location:   /opt/google/chrome/PepperFlash/libpepflashplayer.so
Type:   PPAPI (out-of-process)
     Enable
MIME types:   
MIME type   Description   File extensions
application/x-shockwave-flash   Shockwave Flash   
.swf
application/futuresplash   FutureSplash Player   
.spl
Name:   Shockwave Flash
Version:   11.2 r202
Location:   /usr/lib/flashplugin-installer/libflashplayer.so
Type:   NPAPI
     Disable
MIME types:   
MIME type   Description   File extensions
application/x-shockwave-flash   Shockwave Flash   
.swf
application/futuresplash   FutureSplash Player   
.spl


there are a couple of differences between the two. Try disabling 11.3 and removing mint-flashplugin-x64. Also I notice that your 11.2 shows as flashplugin-nonfree/libflashplayer.so whereas mine is flashplugin-installer/libflashplayer.so I'm not sure why this would be different, what flash package did you install in synaptic?
setcho
Level 1
Level 1
 
Posts: 20
Joined: Thu Jun 23, 2011 3:38 am

Re: Can't go fullscreen in chrome

Postby xircon on Wed Jul 18, 2012 4:52 am

11.3 (pepper) is disabled, I installed flashplugin-nonfree from synaptic, I can't see flashplugin-installer. But chrome videos do now go fullscreen, it is just the problems with memory leaks.
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Can't go fullscreen in chrome

Postby setcho on Wed Jul 18, 2012 5:07 am

Ok I'm glad it works, It's a shame about the memory leaks though :(
setcho
Level 1
Level 1
 
Posts: 20
Joined: Thu Jun 23, 2011 3:38 am

Re: Can't go fullscreen in chrome

Postby jamsoolee on Sat Jul 28, 2012 2:24 am

I don't know if this problem is just with me, but I did as setcho instructed, and I can go into fullscreen but the colors are all messed up. :( Like everything is in shades of blue...
[center]
Image
[/center]
User avatar
jamsoolee
Level 1
Level 1
 
Posts: 8
Joined: Thu Sep 09, 2010 1:06 am
Location: /home

Re: Can't go fullscreen in chrome

Postby pmendes on Sat Jul 28, 2012 4:28 pm

setcho solution worked like a charm for me!

setcho wrote:We need to switch Chrome to flash 11.2. However because we are using Linux Mint, flash version 11.2 isn't installed only 11.0.1 is. What you need to do is remove mint-flashplugin-11 from synaptic and install flashplugin-installer (i.e. 11.2) and then do the following

1. In the URL bar enter chrome://plugins/
2. Locate the Flash plug-in, you should see multiple versions listed
3. Click Disable for the plug-in with the location /opt/google/chrome/PepperFlash/libpepflashplayer.so (11.3)
4. You should still have one enabled in another location, like /usr/lib/adobe-flashplugin/libflashplayer.so (11.2)
5. Restart Chrome (quit and open again)
pmendes
Level 1
Level 1
 
Posts: 2
Joined: Sat Nov 19, 2011 8:22 am

Re: Can't go fullscreen in chrome

Postby raam86 on Sat Sep 08, 2012 8:42 am

Installing fAdobe Flash plugin
Adobe flash player plugin version 11

from the software manager worked like a charm.
raam86
Level 1
Level 1
 
Posts: 1
Joined: Sat Sep 08, 2012 8:41 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 8 guests