texstudio, libfontconfig1

Questions about applications and software
Forum rules
Before you post please read this

texstudio, libfontconfig1

Postby TomRoche on Sun Jul 08, 2012 5:13 pm

I'm running the usual GNOME-based LMDE UP4 (64-bit) with a few things installed from other repos (emacs-snapshot, iceweasel, R). I need to start learning TeX, and have had TeXstudio recommended for introductory purposes. Unfortunately package=texstudio is not in the current LMDE repos:

Code: Select all
me@it:~$ sudo aptitude -s install texstudio
Couldn't find any package whose name or description matched "texstudio"


So I added the wheezy repo to my sources.list, et voilà, I see package=texstudio. However

Code: Select all
The following packages have unmet dependencies:
  libqt4-network:   Depends: libqt4-dbus (= 4:4.7.4-2) but 4:4.8.2-1 is to be installed.
                    Depends: libqtcore4 (= 4:4.7.4-2) but 4:4.8.2-1 is to be installed.
  texlive-binaries: Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-2.1ubuntu3 is installed.
                    Depends: libptexenc1 but it is not going to be installed.
                    Depends: ed but it is not going to be installed.
  libqtgui4:        Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-2.1ubuntu3 is installed.
  libpoppler19:     Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-2.1ubuntu3 is installed.


QT4 and Poppler don't seem too problematic, but *lots* of things seem to depend on libfontconfig1

Code: Select all
me@it:~$ aptitude search ~Dlibfontconfig1 | grep -e '^i' | wc -l
224


so I'm hesitant to try updating that. Am I being unduly cautious? If so, what would be the safest way to update libfontconfig1 from 2.8.0-2.1ubuntu3 to >= 2.9.0 ?
TomRoche
Level 3
Level 3
 
Posts: 168
Joined: Thu Jan 13, 2011 2:52 pm

Linux Mint is funded by ads and donations.
 

Re: texstudio, libfontconfig1

Postby asdfasdf on Sun Jul 08, 2012 5:48 pm

TomRoche wrote:I'm running the usual GNOME-based LMDE UP4 (64-bit) with a few things installed from other repos (emacs-snapshot, iceweasel, R). I need to start learning TeX, and have had TeXstudio recommended for introductory purposes. Unfortunately package=texstudio is not in the current LMDE repos:

Code: Select all
me@it:~$ sudo aptitude -s install texstudio
Couldn't find any package whose name or description matched "texstudio"


So I added the wheezy repo to my sources.list, et voilà, I see package=texstudio. However

Code: Select all
The following packages have unmet dependencies:
  libqt4-network:   Depends: libqt4-dbus (= 4:4.7.4-2) but 4:4.8.2-1 is to be installed.
                    Depends: libqtcore4 (= 4:4.7.4-2) but 4:4.8.2-1 is to be installed.
  texlive-binaries: Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-2.1ubuntu3 is installed.
                    Depends: libptexenc1 but it is not going to be installed.
                    Depends: ed but it is not going to be installed.
  libqtgui4:        Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-2.1ubuntu3 is installed.
  libpoppler19:     Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-2.1ubuntu3 is installed.


QT4 and Poppler don't seem too problematic, but *lots* of things seem to depend on libfontconfig1

Code: Select all
me@it:~$ aptitude search ~Dlibfontconfig1 | grep -e '^i' | wc -l
224


so I'm hesitant to try updating that. Am I being unduly cautious? If so, what would be the safest way to update libfontconfig1 from 2.8.0-2.1ubuntu3 to >= 2.9.0 ?


I haven't used TeXstudio, but I had already installed TeX on this LMDE UP4 box. The version of texlive-binaries is 2009-12, and the version of libfontconfig1 is the same as yours, 2.8.0-2.1ubuntu3.

My experience with TeX itself is that it is pretty stable (Knuth stopped work on the base TeX package a long time ago); I wondered if TeXstudio "just work" with the current version of texlive-2009 and the current libfontconfig1, so I went to the TeXstudio website and downloaded the .deb file directly from http://download.opensuse.org/repositories/home:/BeniBela:/texstudio/Debian_6.0/amd64/. Then I did:

Code: Select all
# apt-get install libpoppler-qt4-3
# dpkg -i texstudio_2.3-1_amd64.deb


and it seemed to install pretty nicely, but of course, your mileage may vary.

Also, have you tried LyX? It's a very popular GUI/wrapper for LaTeX; it's available as:

Code: Select all
# apt-get install lyx
asdfasdf
Level 1
Level 1
 
Posts: 38
Joined: Sun May 06, 2012 1:33 am

Re: texstudio, libfontconfig1

Postby TomRoche on Sun Jul 08, 2012 7:17 pm

asdfasdf wrote:TeX itself [is] pretty stable (Knuth stopped work on the base TeX package a long time ago)


Right, but does that matter much? TeX the ecosystem seems to be continually evolving.

asdfasdf wrote:I went to the TeXstudio website and downloaded the .deb file directly from http://download.opensuse.org/repositories/home:/BeniBela:/texstudio/Debian_6.0/amd64/


Good to know that will work, but I try to work from stock repositories (i.e., rather than downloading .deb's) wherever possible. Hopefully this means that one of the repos has {libqtgui4, libpoppler*, texlive-*} that work with the LMDE version of libfontconfig1.

asdfasdf wrote:have you tried LyX? It's a very popular GUI/wrapper for LaTeX


No, but I was pleased to see that

  • lyx installed from the stock LMDE repos (
    Code: Select all
    sudo aptitude install lyx
    )
  • after
    Code: Select all
    lyx &
    and closing the help file, I was able to
    1. open a new file
    2. paste in some simple TeX math (
      Code: Select all
      \sum_{i=1}^{n} \frac{I_i U_i}{a_{U_i}}
      )
    3. select it
    4. render it with mainmenu>Insert>Math>Display Formula

So, thanks: I think lyx will get me started with TeX.
TomRoche
Level 3
Level 3
 
Posts: 168
Joined: Thu Jan 13, 2011 2:52 pm


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 3 guests