[SOLVED] Wine 1.5 requires KDE!?

Questions about applications and software
Forum rules
Before you post please read this

[SOLVED] Wine 1.5 requires KDE!?

Postby morgan71 on Thu Jul 19, 2012 9:29 am

I am tracking SID and I am using Gnome 3.4 as my desktop. Today, when I did an upgrade, I noticed there was a new version of Wine, 1.5.9. I tried to do a dist-upgrade, but then apt wanted to install kde-runtime, linux-image-3.2.0-3-rt-686-pae and a whole bunch of other packages! Together it would be more than 0.5 GB of new software installed. I have tried searching but I haven't found any information that Wine should now have a dependency to KDE. Does someone have more information about this? I really hope Wine isn't going to be as bloated as Windows, because then I'll throw it out.
Last edited by morgan71 on Thu Jul 19, 2012 3:07 pm, edited 1 time in total.
User avatar
morgan71
Level 1
Level 1
 
Posts: 7
Joined: Mon Jun 27, 2011 2:21 pm
Location: Gothenburg, Sweden

Linux Mint is funded by ads and donations.
 

Re: Wine 1.5 requires KDE!?

Postby zerozero on Thu Jul 19, 2012 11:17 am

it shouldn't depend on any kde package but then again i never installed 1.5.9
from where does it come from?
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: Wine 1.5 requires KDE!?

Postby Brian49 on Thu Jul 19, 2012 11:52 am

zerozero wrote:from where does it come from?

Good question. The only place where I've seen 1.5.9 is in the Ubuntu Wine PPA.
Brian49
Level 5
Level 5
 
Posts: 612
Joined: Thu Oct 29, 2009 2:27 pm

Re: Wine 1.5 requires KDE!?

Postby morgan71 on Thu Jul 19, 2012 3:06 pm

zerozero wrote:it shouldn't depend on any kde package but then again i never installed 1.5.9
from where does it come from?

Thanks, you were right. It wasn't from Debian but from liquorix.net. I am using their kernel so that's why it's in my sources.list. Apparently they have built a wine 1.5 with dependencies to KDE. After changing their pin priority, everything is back to normal .:D
User avatar
morgan71
Level 1
Level 1
 
Posts: 7
Joined: Mon Jun 27, 2011 2:21 pm
Location: Gothenburg, Sweden

Re: [SOLVED] Wine 1.5 requires KDE!?

Postby zerozero on Thu Jul 19, 2012 4:06 pm

yeahh i see :wink:
one problem (at least, didn't bother to look for others, honestly) is wine1.5 itself
Code: Select all
Package: wine1.5
Architecture: i386 amd64
Section: otherosfs
Multi-Arch: allowed
Pre-Depends: dpkg (>= 1.15.7.2~), ${misc:Pre-Depends}
Depends:    ${misc:Depends}, ${shlibs:Depends},
            binfmt-support (>= 1.1.2),
            procps,
            wine1.5-i386  (= ${binary:Version}) [i386 amd64],
            wine1.5-amd64 (= ${binary:Version}) [amd64],
Recommends: cups-bsd,
            gnome-exe-thumbnailer | kde-runtime,
            ttf-droid,
            ttf-liberation,
            ttf-mscorefonts-installer,
            ttf-umefont,
            ttf-unfonts-core,
            ttf-wqy-microhei,
            winbind,
            winetricks,
            xdg-utils
Suggests:   dosbox:any
Conflicts:  wine1.0, wine1.2, wine1.3, wine1.4
Replaces:   wine, wine1.0, wine1.2, wine1.3, wine1.4
Provides:   wine
Description: Microsoft Windows Compatibility Layer (Binary Emulator and Library)
 Wine is a compatibility layer for running Windows applications on Linux.
 Applications are run at full speed without the need of cpu emulation. Wine
 does not require Microsoft Windows, however it can use native system dll
 files in place of its own if they are available.
 .
 This package includes a program loader for running unmodified Windows
 executables as well as the Wine project's free version of the Windows API for
 running programs ported from Windows.
this is part of the control file inside liquorix.net/debian/pool/main/w/wine1.5/wine1.5_1.5.9-1.debian.tar.gz

actually the changelog is enough
Code: Select all
wine1.5 (1.5.9-1) unstable; urgency=low

  * Non-maintainer upload.
  * debianized

 -- Steven Barrett <damentz@gmail.com>  Wed, 18 Jul 2012 18:49:55 -0500

wine1.5 (1.5.9-0ubuntu2~pulse19+build1) precise; urgency=high

  * Fix near-infinite loop in dsound
    - Sorry!!! Special thanks to Loris Zinsou helping me diagnose
      and fix it, and "Church" for also reporting it.

 -- Maarten Lankhorst <maarten.lankhorst@canonical.com>  Wed, 18 Jul 2012 23:09:48 +0200

wine1.5 (1.5.9-0ubuntu1~pulse19) precise; urgency=medium

  * New upstream release
    - Support for GPOS font tables in Uniscribe.
    - Support for XRandr 1.2 and 1.3.
    - Parser improvements for the HLSL compiler.
    - More key exchange algorithms supported on Mac OS.
    - Relay tracing on ARM.
    - Various bug fixes.

if this is not clear yet :lol: this is nothing more than repackaging the ubuntu wine pkgs into a debian repo :evil:
not good
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: [SOLVED] Wine 1.5 requires KDE!?

Postby Monsta on Thu Jul 19, 2012 5:46 pm

Code: Select all
Recommends: cups-bsd,
            gnome-exe-thumbnailer | kde-runtime,

Ahh... these recommendations again, could they be the cause? :)
Look at this post (see the section named "Telling apt to not install recommended packages") and check these settings in your system.

Or you can try using --no-install-recommends option, it does the same but just for one run.
Monsta
Level 8
Level 8
 
Posts: 2494
Joined: Fri Aug 19, 2011 3:46 am

Re: [SOLVED] Wine 1.5 requires KDE!?

Postby zerozero on Thu Jul 19, 2012 5:56 pm

:D Monsta,
good one but doesn't solve the basic issue: this is a bad packaging and damentz knows better than that.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: [SOLVED] Wine 1.5 requires KDE!?

Postby Monsta on Thu Jul 19, 2012 6:40 pm

Did I argue about that? :)

I've just pointed out another issue that may cause some surprises for an unsuspecting user. It's not that this apt-get behavior is bad by itself; but it can turn out bad when people put whatever they want in the "recommends" section (like it's done in the mentioned wine package).
Monsta
Level 8
Level 8
 
Posts: 2494
Joined: Fri Aug 19, 2011 3:46 am

Re: [SOLVED] Wine 1.5 requires KDE!?

Postby morgan71 on Fri Jul 20, 2012 6:02 pm

Monsta wrote:
Code: Select all
Recommends: cups-bsd,
            gnome-exe-thumbnailer | kde-runtime,

Ahh... these recommendations again, could they be the cause? :)
Look at this post (see the section named "Telling apt to not install recommended packages") and check these settings in your system.

Or you can try using --no-install-recommends option, it does the same but just for one run.

You are right, I had install-recommends turned on. Thanks for pointing that out.
User avatar
morgan71
Level 1
Level 1
 
Posts: 7
Joined: Mon Jun 27, 2011 2:21 pm
Location: Gothenburg, Sweden

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 5 guests