Can't install firefox-trunk on latest LMDE

Questions about applications and software
Forum rules
Before you post please read this

Can't install firefox-trunk on latest LMDE

Postby HackerAC88 on Thu Jul 26, 2012 6:14 pm

Hi guys. In all this latests months, I could not install Firefox Trunk. I don't know whats the problem with packets or any dependences. Here I paste the error message, If somebody can help me, I would greatly appreciate.

Failed to install some packages. This may mean that
You requested an impossible situation or if you are using the unstable
distribution that some required packages have not been created or
been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
firefox-trunk: Depends: libc6 (> = 2.15) but is to be installed 2.13-27
Recommended: xul-ext-ubufox but it will not install
Recommends: firefox-trunk-globalmenu but it will not install
HackerAC88
Level 1
Level 1
 
Posts: 4
Joined: Sun Apr 04, 2010 1:22 pm

Linux Mint is funded by ads and donations.
 

Re: Can't install firefox-trunk on latest LMDE

Postby zerozero on Thu Jul 26, 2012 9:03 pm

[moved here]
i would be surprised if it worked, that is an ubuntu pkg, is not supposed to work in debian as you can see from the error message apt gives you:
- that pkg is build expecting some other pkg (xul-ext-ubufox and firefox-**-globalmenu) that only are available in ubuntu.

it's the latest firefox you want?
add this to your sources.list
Code: Select all
deb http://mozilla.debian.net/ experimental iceweasel-aurora

update the system and add the keyring
Code: Select all
apt install pkg-mozilla-archive-keyring

install iceweasel (the unbranded firefox)
Code: Select all
apt policy iceweasel
iceweasel:
  Installed: (none)
  Candidate: 16.0~a2+20120720042008-1
  Version table:
     16.0~a2+20120720042008-1 0
        500 http://mozilla.debian.net/ experimental/iceweasel-aurora amd64 Packages
     10.0.6esr-1 0
        500 http://ftp.debian.org/debian/ testing/main amd64 Packages

atm is *only* 16 (but the build is already from 20th july (FF-trunk 17 was build 7 hours ago >> we are not too late)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6484
Joined: Tue Jul 07, 2009 2:29 pm


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 6 guests