libzip1 for LMDE?

Questions about applications and software
Forum rules
Before you post please read how to get help

Important information

libzip1 for LMDE?

Postby Quasimodo on Sun Sep 30, 2012 5:32 pm

I recently decided to move from Linux Mint 12 to LMDE on my Aspire One netbook. I'm now setting up the various apps which I had running on Mint 12, including the Linux version of the Kobo desktop. Unfortunately when I tried to run kobo-desktop.deb to install the Kobo desktop, it complained that the dependency for libzip1 couldn't be satisfied. I see that according to Synaptic, libzip1 isn't available - presumably it's been replaced by libzip2. Can anyone suggest the way round this please? At a guess, it may be possible to keep dpkg happy by providing a symlink to point to libzip2 but pretend it's libzip1, but I'm afraid I don't know which of the several instances of libzip2 the link would need to point to...

Thanks in advance for any help

Ian
Quasimodo
Level 1
Level 1
 
Posts: 46
Joined: Mon Oct 31, 2011 9:18 am
Location: Newbury, Berkshire, UK

Linux Mint is funded by ads and donations.
 

Re: libzip1 for LMDE?

Postby zerozero on Sun Sep 30, 2012 6:06 pm

[moved here]
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6520
Joined: Tue Jul 07, 2009 2:29 pm

Re: libzip1 for LMDE?

Postby Quasimodo on Sun Sep 30, 2012 6:15 pm

Oops, sorry, should have looked further down the main index :(

Ian
Quasimodo
Level 1
Level 1
 
Posts: 46
Joined: Mon Oct 31, 2011 9:18 am
Location: Newbury, Berkshire, UK

Re: libzip1 for LMDE?

Postby zerozero on Sun Sep 30, 2012 6:21 pm

no problem :D
i'm afraid i can't help you with this issue: libzip1 was deprecated in debian and also ubuntu to libzip2 and you can find several hits on google about this same problem;

probably the best option would be to contact the dev. so they can update the dependencies of the app.
https://bugs.launchpad.net/ubuntu/+sour ... bug/990314
http://ubuntuforums.org/archive/index.p ... 67138.html
http://packages.debian.org/search?suite ... ds=libzip1
(see that libzip1 is only available in stable and in less well known archs)
http://packages.debian.org/search?suite ... ds=libzip2
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6520
Joined: Tue Jul 07, 2009 2:29 pm

Re: libzip1 for LMDE? [SOLVED]

Postby Quasimodo on Mon Oct 01, 2012 5:37 am

Thanks for your tolerance :)

I found a copy of libzip1 here:
Code: Select all
https://launchpad.net/ubuntu/+archive/primary/+files/libzip1_0.9.3-1_i386.deb

installed it, and the Linux version of Kobo desktop is now running happily on my netbook.

Ian
Quasimodo
Level 1
Level 1
 
Posts: 46
Joined: Mon Oct 31, 2011 9:18 am
Location: Newbury, Berkshire, UK

Re: libzip1 for LMDE?

Postby zerozero on Mon Oct 01, 2012 11:44 am

ohh well, i wouldn't consider it a fix, not so much for resort to an ubuntu package but mainly because imo in the next dist-upgrade that package will be replaced by libzip2.
try a simulation
Code: Select all
sudo apt-get update && sudo apt-get -s dist-upgrade
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6520
Joined: Tue Jul 07, 2009 2:29 pm


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 7 guests