FYI: Google Chrome on LMDE

Questions about applications and software
Forum rules
Before you post please read this

FYI: Google Chrome on LMDE

Postby phlux on Thu Feb 28, 2013 10:11 am

Hey folks. I just wanted to check in with you and give you my latest experience with Google Chrome on my LMDE install. I had to change a few things around to get everything running smoothly, but once I did, all was well.

I'll start off by saying that I'm doing this on an amd64 install, so YMMV based on your platform. Heck, as far as I know, the problems I encountered were specific to my machine only, and I'm giving a heads up for no reason!

Instead of installing the .deb package from http://www.google.com/chrome, I added the repositories myself and added

Code: Select all
http://dl.google.com/linux/chrome/deb/ stable main


After adding and updating the repos, I decided to charge directly into the install of the 'unstable' version of google-chrome. Rather than using apt-get from CLI, I decided I'd play around in the Software Manager just for kicks.

After installing, I noticed that "Google Chrome" with its colorful icon sat squarely in my "Internet" submenu in Cinnamon. I was able to set it as my default browser, and I got to work. The trouble began when I decided to fire up the ol' Software Manager again and install a few games.

After installing my games, I noticed that Chrome was no longer in my "Internet," submenu. I took a look in settings, and I could no longer set it as my default browser, either. I reinstalled Chrome, and it fixed itself.

I tried running the software manager again, and it broke Chrome again. I was pretty stumped. I was seriously starting to consider just dumping Chrome, running Chromium, and extracting pepper-flash from Chrome. My problem was solved, however, by realizing that Google Chrome did not have a .desktop file in /usr/share/applications or ~/.local/applications/. I decided to copy the chromium.desktop file, open it up in vi, and :%s/Chromium/Chrome, and changing the executable from /usr/bin/chromium to /usr/bin/google-chrome.

I fired up the software manager again, installed a few packages, and viola! Problem solved!

So in short: If you wish to use Google Chrome, but can't set it as a default browser, and it keeps disappearing from your "Internet," submenu, simply create a Google Chrome .desktop file (google-chrome.desktop). I hope that this is able to help someone now or in the future. It was certainly a pain for me until I was able to narrow it down (admittedly with the help of another) to something so simple. I always look in the most difficult places first!
Image
User avatar
phlux
Level 1
Level 1
 
Posts: 24
Joined: Wed Feb 27, 2013 9:49 am
Location: Houston, TX

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 2 guests