Virtual keyboard at login, how to get one?

Questions about applications and software
Forum rules
Before you post please read this

Virtual keyboard at login, how to get one?

Postby Lew_Rockwell_Fan on Tue Aug 20, 2013 1:30 am

I'm trying to get a virtual keyboard running at login under LMDE with Mate.

I found this http://florence.sourceforge.net/english/tips.html#gdm about getting Florence to run in Gnome that seemed like it might be adaptable to Mate and I found the corresponding files but it didn't work.

I also found this http://forums.linuxmint.com/viewtopic.php?f=199&t=80062&p=486079&hilit=florence+login#p486079 and it does put a vkb on the login screen but it is dysfunctional.

The same approach with xvkbd produced a brief appearance of xvkbd before the login screen but it never appeared again. After booting I looked at the ttys and something was going on on tty2 which might perhaps have been an invisible xvkbd.

I also tried to get OnBoard running but haven't had any luck so far. It worked beautifully at login under Ubuntu Oneiric. So this ought to be possible.

Any suggestions would be appreciated.
Lew_Rockwell_Fan
Level 1
Level 1
 
Posts: 24
Joined: Sat Apr 27, 2013 3:59 pm

Linux Mint is funded by ads and donations.
 

Re: Virtual keyboard at login, how to get one?

Postby Lew_Rockwell_Fan on Tue Aug 27, 2013 5:14 pm

I found something that ALMOST works. Adapted from http://forums.linuxmint.com/viewtopic.php?f=18&t=120341#p747175 I installed lightdm and set it to be the dm. I created the file /etc/lightdm/virtual-keyboard.sh and gave it appropriate perms.
It contains:
Code: Select all
#! /bin/bash

/usr/bin/xvkbd -secure -geometry 1850x300+20+640 -display $DISPLAY&
I edited /etc/lightdm/lightdm.conf to add the line
Code: Select all
greeter-setup-script=/etc/lightdm/virtual-keyboard.sh
under the heading
Code: Select all
 [SeatDefaults]
(What an odd line. Seems like it ought have something like
Code: Select all
=desk_chair,floor
after it.
This works BUT the vkb seems to have something like dwellclick going on. When my pointer hovers over a key for any period longer than a very brief moment that letter is entered without clicking. And as long as my pointer is there it will be entered again and again. This makes it very tricky to use. If anyone can suggest how to fix this, or at least lengthen the time I have to hover to something more easily controlled, I would appreciate it.
-------------
Added by edit later same day:
The problem with the click-on-hover behavior is simply a setting, settable through the menu key on the xvkb keyboard at the lower left. The time before auto-clicking can be set or the feature can be turned off altogether.

So, this isn't exactly what I was looking for, because I was hoping not to have to scrap the mdm theme I had spent altogether too much time on tweaking, but it does work, and now I can see if I can manage to tweak an ldm theme into what I want. If anybody knows how to make mdm behave with some vk I'm still interested. But in the meantime I think I'll focus on trying to turn a ldm theme into what I want. If that proves too difficult I may try posting this question in the Mate forum. Anyway, hopefully this may be some help to somebody looking for something similar.
Lew_Rockwell_Fan
Level 1
Level 1
 
Posts: 24
Joined: Sat Apr 27, 2013 3:59 pm


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 3 guests