Failed to open a session for the virtual machine Linux Mint

Questions about applications and software
Forum rules
Before you post please read this

Failed to open a session for the virtual machine Linux Mint

Postby Mr. Green on Tue Sep 10, 2013 1:34 pm

Hello Mint Comunity. :)

I hope this is posted in the 'right' place. I am a complete newcomer to LMDE, and to Linux based Operating Systems in general, but have many years of working with that 'other' OS under my belt, so not a stranger to computing.

I have some recent experience in running a live TAILS usb (which is based on Debian for anyone not aware of tails). It was this enjoyable first encounter with Debian that led to my developing a greater interest in Linux, and having spent some weeks investigating further, I settled on LMDE as the 'right' distro for me.

After spending some days deciding on my next moves, I set up an LMDE guest in VirtualBox to see how things would go. I was attracted to the ability to save the state of the machine and take snapshots incase my inexperience led to any undesireable results.

After much trial and error, and many hours over many evenings of searching engines and forums for help (and scrapping a couple of VM's for failed installations and inability to get the Guest Additions working correctly, I finally achieved success on my third attempt, and sat back to revell in the fruits of my labours: a lovely working LMDE VBox guest.

I successfully installed all my updates and upgrades through the CLI, and even got the Guest Additions working. I set up all my required Firefox add-ons (NoScript/AdBlock Plus, HTTPS Everywhere etc.) and then spent some time compiling an array of visually attractive backgrounds/themes etc, and very pleased with the look and feel of my new LMDE guest - I saved the state of the machine successfully, and called it a night.

My delight was cut short today however, as when I went to start up my new machine, I encountered the following error:

Failed to open a session for the virtual machine Linux Mint Debian Edition.

ahci#0: The target VM is missing a device on port 0. Please make sure the source and target VMs have compatible storage configurations [ver=6 pass=final] (VERR_SSM_LOAD_CONFIG_MISMATCH).

Result Code: E_FAIL (0x80004005)
Component: Console
Interface: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}


which is the equivalent of a foreign language to me, and needless to say, all that work is seemingly now 'lost'. :(

It is installed in VirtualBox 4.2.18 on a Windows 7 64bit host.

I uploaded the log as an attachment but got the message "The extension log is not allowed." If anyone is able to help me get my new system back running, I would greatly appreciate it. I was so happy and excited to finally have my new Mint machine up, looking great and running really smoothly, and I hope my journey does not end in disappointment, as windoze was all set to take a back seat.

Please let me know how I can get the log uploaded, and any other info you need to help me.

Many thanks for your time.
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Linux Mint is funded by ads and donations.
 

Re: Failed to open a session for the virtual machine Linux M

Postby trapperjohn on Tue Sep 10, 2013 1:57 pm

Did you do your install using an attached iso file or a disk drive?
If you did, did you detach the install cd before restart?
When you close the session, are you saving the machine state, or shutting it down? If you are saving it, are you certain you have not saved the state of the live CD install session?
How big is your vdi?
trapperjohn
Level 5
Level 5
 
Posts: 686
Joined: Wed Jul 11, 2012 4:10 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Tue Sep 10, 2013 2:17 pm

Thanks for your quick reply John. :)

trapperjohn wrote:Did you do your install using an attached iso file or a disk drive?


I mounted the iso image in the drive, rather than burning to disk.


trapperjohn wrote:If you did, did you detach the install cd before restart?


I dismounted/ejected the iso after install, and then "pressed enter" to complete the installation as promted by the wizard before reboot.


trapperjohn wrote:When you close the session, are you saving the machine state, or shutting it down? If you are saving it, are you certain you have not saved the state of the live CD install session?


I saved the machine state from the "close" drop down menu in VBox. And no, it was definitely a full install into the VM, not just running from the live CD.


trapperjohn wrote:How big is your vdi?


The installation has 12.80Gb of virtual hard disk space allocated, 703mb of virtual memory and 128Mb of video memory available. I hope this is what you wanted to know, and this info allows for further assistance. :)

Thanks for your time.
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby trapperjohn on Tue Sep 10, 2013 4:48 pm

OK

I dismounted/ejected the iso after install, and then "pressed enter" to complete the installation as promted by the wizard before reboot


There's one more step after this. We have to go to the machine settings>storage and remove the attachment for the iso.

I saved the machine state from the "close" drop down menu in VBox. And no, it was definitely a full install into the VM, not just running from the live CD.

Actually, you don't want to do this just after the install completes. The state you are saving in this case is the state of the install session. In your list of VBox machines you will see "saved" just below your machine. Right-click it and "discard saved state"
trapperjohn
Level 5
Level 5
 
Posts: 686
Joined: Wed Jul 11, 2012 4:10 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Tue Sep 10, 2013 5:10 pm

trapperjohn wrote:OK

I dismounted/ejected the iso after install, and then "pressed enter" to complete the installation as promted by the wizard before reboot


There's one more step after this. We have to go to the machine settings>storage and remove the attachment for the iso.


I think I recall that I did so, but not 100% sure. The mounted iso in the drive 'disappeared' from the desktop at any rate, hopefully that will tell you whether or not I completed that step or not?


trapperjohn wrote:
I saved the machine state from the "close" drop down menu in VBox. And no, it was definitely a full install into the VM, not just running from the live CD.

Actually, you don't want to do this just after the install completes. The state you are saving in this case is the state of the install session.


I see, thanks for the helpful re-education. ;)



trapperjohn wrote:In your list of VBox machines you will see "saved" just below your machine. Right-click it and "discard saved state"


I was considering trying this, but did not want to risk losing the things I'd saved so far - if there might still have been a way of restoring the save. As it seems 'dead' now anyway, I shall go ahead and do so.

In my naivety, what should I expect from taking this action? Just want to be aware of the outcome first. Obviously the saved state would be lost, but what state will that leave the newly built box in please?

As an aside, having investigated more into the error report and log, it seems that Port 0 referred to in the report as missing a device - represents the virtual hard drive I created, which if I check the machine details, is no longer present. Would this be as a result of the conditions you have indicated, in that I have inadvertently saved the state of the install session?

Last 'green' question for now - I'm clearly still learning more about virtualisation and linux 'on the fly' as I go, so I elected to "save the state" of the machine in a measure of ignorance as to how the shutdown process works inside virtualisation. Can you confirm that if I instead shut down the LMDE guest from within the OS itself (rather than using VBox close) that all my data and changes will remain intact just as if I were shutting down a "real" machine?

Thanks again for taking the time to help me John. :)
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby trapperjohn on Tue Sep 10, 2013 5:48 pm

Hi,

In short, delete the saved state.

When you close a VBox guest machine using the guest's normal shutdown process, the state of the OS is retained in the vdi. Using the virtual machine's Machine>Close dialog has three choices:
    The Send Shutdown Signal sends [cntl][alt][delete] to the guest, so it's the same as closing the guest as above.
    The Power Off the Machine, imitates a power outage (just like holding the power button for a few moments on a native machine).
    Finally, Save the Machine State creates a restartable instance of the existing session (I very rarely do this).

Don't get snapshots confused with "saved states." When your guest is off, you can take a snapshot. Within the snapshot will be an image of the guest at the moment it was taken.
trapperjohn
Level 5
Level 5
 
Posts: 686
Joined: Wed Jul 11, 2012 4:10 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Tue Sep 10, 2013 6:00 pm

Thanks for the info.

I just discarded the saved state, started the box - and got the dreaded "FATAL" error message.

Ok, so onto snaphots: I did take one when the install was first completed, but it was taken from within the running guest.

I'll see if that gives me something to work with - otherwise, is it time for "attempt number four", or anything else I can try?

Still, if so, at least I'll be armed with more experience and your inherited knowledge -so hopefully make the next 'try' the last one necessary. :)


If the snapshot works and takes me back my initial "ready to go" point, what are your suggested next steps from here, to ensure I have no further complications?
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Tue Sep 10, 2013 6:07 pm

Mr. Green wrote:If the snapshot works and takes me back my initial "ready to go" point, what are your suggested next steps from here, to ensure I have no further complications?



Ok, so the snap shot worked and I'm back in, but the guest has already has it's state saved within it.

If I power it down normally from here, will all be well when I restart?
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby trapperjohn on Tue Sep 10, 2013 6:30 pm

So, you are back in. The question is, have you removed the .iso from the machine settings > storage? I just want to make sure your not running a live session. If the "Install Linux Mint" icon is on the desktop, then you are not running your installed version.

If you are in fact running your installed LMDE, then your guest is running from the vdi image that you created. Just as an excercise, create a document named someName and save it. Now, restart the guest from the Mint menu. When it restarts, your document will be there.

Now, from the Mint menu again, shut down. Take a snap shot. Start again and create/save another document called someName2. Shut down from the Mint menu. If you start it again, someName2 will be there. If you shut down again and then restore your snapshot, it will return to the exact moment when you took the snapshot... with only someName present.
trapperjohn
Level 5
Level 5
 
Posts: 686
Joined: Wed Jul 11, 2012 4:10 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Tue Sep 10, 2013 7:48 pm

trapperjohn wrote:So, you are back in. The question is, have you removed the .iso from the machine settings > storage? I just want to make sure your not running a live session. If the "Install Linux Mint" icon is on the desktop, then you are not running your installed version.


Yes, nothing is mounted in the virtual drive, and the "install mint" icon dissappeared after the install to be replaced by the guest additions icon when I mounted that. Since I dismounted that, there has been nothing on the drive/showing on the desktop.


trapperjohn wrote:If you are in fact running your installed LMDE, then your guest is running from the vdi image that you created. Just as an excercise, create a document named someName and save it. Now, restart the guest from the Mint menu. When it restarts, your document will be there.


Unfortunately there was a fatal crash. "Oops! Something went wrong, and the system cannot recover".

I could not get the error details.

It did say though, that a programme was trying to do something like "something-desktop.console-something - multi-user logout" (my incorrect random recall) and was unable to perform the task, then requested administrative permission from my password. I tried both accepting and denying it - yet both times it crashes.

I restarted the snapshot, and get back in fine, but whenever I try to "restart" from within the guest, it fails to start after I login, and the "Oops! Something went wrong" error returns. So as it stands, I'm unsure how to progress from here.

I'm going to try logging out first, and then restarting/shutting down.

Won't be able to stay up much longer as work early am - but will be sure to check back in with you tomorrow.

Thanks for your patience in working with me on this.
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Tue Sep 10, 2013 9:24 pm

Last contribution of the night:

Managegd to get what is causing the shutdown issue:

I am asked to authenticate the shutdown, and the messagebox states that something is trying to run a process, and in the 'details' drop-down is this:


org.freedesktop.consolekit.system.restart-multiple-users


I power down the machine then, as it is the only way I can exit. When I start it up again, I log in, and the desktop appears briefly at first, before the "oops!" message pops up to claim the screen, and inform me that the system cannot recover.

This happens every time. Though I do still have the working snapshot ('working' in the sense that I can at least get in); for whatever use that seems at present.

I found a few interesting links when searching that term, but it is late, so will look further into this tomorrow.

Do you think this can be overcome, or will I need to start all over again?
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby trapperjohn on Wed Sep 11, 2013 8:58 am

Hi,

It can be overcome. The question is; will it be easier than a complete re-try? Let's see.

It's behaving like another user is active or logged-in and you don't have permission to shut them down. One possible other user is root. (Have you used a root terminal in your session?) Open a terminal and run the command:
who

Also, let's make you an administrator. From the Menu>Administration>Users and Groups Window, click Account Type, enter password, and pick Administrator.

BTW:
Most likely, you are through the VBox part of the problem now and are on to a set-up/configuration challenge. But let's look at the VBox machine's settings once more. At the system page, motherboard tab; how much memory have you allocated? Is your install a 32 bit version of LMDE? In general, the best place to start with memory is towards the high end of the green in the slider, but less <= 2048 with a 32 bit OS. On the processor tab, is your box for PAE/NX checked? (Mine's not.) At the display page, video tab, uncheck Enable 3D and 2D Acceleration for now. Put the video memory slider well into the green
trapperjohn
Level 5
Level 5
 
Posts: 686
Joined: Wed Jul 11, 2012 4:10 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Wed Sep 11, 2013 12:30 pm

trapperjohn wrote:Hi,

It can be overcome. The question is; will it be easier than a complete re-try? Let's see.


That's good to hear. Much better if we can fix it. But if not, I refuse to accept defeat. One way or another, I am having an LMDE guest box, so if yet another install is necessary, then that is what I'll do.


trapperjohn wrote:It's behaving like another user is active or logged-in and you don't have permission to shut them down. One possible other user is root. (Have you used a root terminal in your session?) Open a terminal and run the command:
who


I ran my updates and upgrades, guest additions etc. in a su terminal - to save having to sudo every command. But I typed exit when finished, and reverted to being my normal user.

Ok - ran the who command, and it returns this:

user1 tty8 2013-09-09 23:22 (:0)
user1 pts/2 2013-09-11 16:41 (:0)

(the abbreviations after username are not currently in my linux vocabulary). ;)



trapperjohn wrote:Also, let's make you an administrator. From the Menu>Administration>Users and Groups Window, click Account Type, enter password, and pick Administrator.


Ok, interesting. It seems that I am already an Administrator account. To the best of my knowledge, that is not something I have knowingly set up myself.

I get: user1 - Administrator (in the left hand side profile). And user1 - Account Type: Administrator, followed by login options on the right.

A curious thing though: I've never set a password (other than my initial password upon installation) - yet - it has five back dots representing my password in the box (I never set such ridiculously short passwords, so don't know where that came from).

So - I unlock the profile, and type in my authentication password as requested. and I'm presented with the "changing password for" menu. It wants me to change it for some reason, but I don't particularly want to change my password unless strictly necessary, so I have cancelled out of that, until I receive your further guidance, as it seems I'm already admin anyway.



trapperjohn wrote:Most likely, you are through the VBox part of the problem now and are on to a set-up/configuration challenge.


I like your style. No such thing as problems. Only challenges to be overcome. ;)


trapperjohn wrote:But let's look at the VBox machine's settings once more. At the system page, motherboard tab; how much memory have you allocated? Is your install a 32 bit version of LMDE? In general, the best place to start with memory is towards the high end of the green in the slider, but less <= 2048 with a 32 bit OS. On the processor tab, is your box for PAE/NX checked? (Mine's not.) At the display page, video tab, uncheck Enable 3D and 2D Acceleration for now. Put the video memory slider well into the green


Memory is set to 703mb. Should be enough, and any more takes my host's memory usage into the red, as I've found through this experience. Set as it is, the host is running at around 70% memory capacity whilst the VBox guest is in operation.

Install is 64 bit. I went with that to match that of my host machine. Open to correction if that was a wrong move though.

PAE/NX box is unchecked.

3D option is checked, but ghosted out - and unable to alter it whilst inside the snapshot. 2d was not checked in the first place.

Video memory is set to the full 128mb.

I shall patiently await your further instructions.

Many thanks. :)
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby trapperjohn on Wed Sep 11, 2013 1:12 pm

You won't be able to change machine settings while the guest is running. In general, I don't enable 3D.

Now, about that password, open a terminal and run:
sudo ls

Your machine should prompt for a password. Does it? I ask because you were presented with the "changing password for" menu. With VMs I usually make my user password exactly the same as my root password and I keep them simple.

Your who command tells us that the only active user is "user1." This is good (provided, of course, your user name is user1).

What still bugs me is that you are asked to authenticate the shutdown. If user1 is the only active user and if user1 is a proper administrator with a valid password this should not occur. After verifying that user1 does have a password, if the machine still barks at shutdown, post:
cat /usr/share/polkit-1/actions/org.freedesktop.consolekit.policy

See: http://community.linuxmint.com/tutorial/view/929
trapperjohn
Level 5
Level 5
 
Posts: 686
Joined: Wed Jul 11, 2012 4:10 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Wed Sep 11, 2013 3:44 pm

trapperjohn wrote:Now, about that password, open a terminal and run:
sudo ls

Your machine should prompt for a password. Does it? I ask because you were presented with the "changing password for" menu. With VMs I usually make my user password exactly the same as my root password and I keep them simple.


Yes. Prompted for password, and my expected password (same for root and user) works. System then returns an inventory of - desktop documents downloads etc.



trapperjohn wrote:Your who command tells us that the only active user is "user1." This is good (provided, of course, your user name is user1).


Lol. Yep, user1 at your service.


trapperjohn wrote:What still bugs me is that you are asked to authenticate the shutdown. If user1 is the only active user and if user1 is a proper administrator with a valid password this should not occur.


If this is indeed part of the issue preventing me from having a nice working LMDE guest - then it bugs me too.


trapperjohn wrote:After verifying that user1 does have a password, if the machine still barks at shutdown, post:
cat /usr/share/polkit-1/actions/org.freedesktop.consolekit.policy

See: http://community.linuxmint.com/tutorial/view/929


When you said "post" it, I presume you wanted me to run that string in the terminal, and share the result here?

If so, I get:

cat: /usr/share/polkit-1/actions/org.freedesktop.consolekit.policy: No such file or directory.

If not - oh well, it only took a few moments of my time anyway. ;)

Checking out your link now.

Ok - so I input - sudo gedit /usr/share/polkit-1/actions/org.freedesktop.consolekit.policy

Asked for password, entered it - returned a blank/empty window that popped up. (Likely to be expected, given that it apparently "doesn't exist"). ;)

Should I then copy/paste the entire code in that link into it? If so, what then?

Possible issue: can't copy/paste between the host and guest windows. Oh wait - I'm in the working snapshot. Logic dictates to open firefox in that and continue from there. Lol, long day - very tired. :lol:
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby trapperjohn on Wed Sep 11, 2013 4:46 pm

I cannot understand why the file isn't there. I have a fresh VBox LDME guest and it is. I'm worried about the install.


The advantage of VBox is: if you have a snapshot, you can run an experiment... then, if it's a dead end or you break your system, you can restore the snapshot and be back to the state before you made the change. So, your idea of pasting the code with 'sudo gedit /usr/share/polkit-1/actions/org.freedesktop.consolekit.policy'. is worth a shot. If you do this, you will probably have to reboot before the changes take effect. Be sure you have a snapshot to restore before you take this step.

Until you get the interface to let you quit normally, you can (and should) gracefully reboot with:
sudo reboot

And gracefully shutdown with:
sudo halt

BTW:
With guest additions installed in the guest you should be able to enable host-to-guest clipboard sharing. From your machine's settings, General>advanced tab>shared clipboard-bidirectional.
trapperjohn
Level 5
Level 5
 
Posts: 686
Joined: Wed Jul 11, 2012 4:10 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Wed Sep 11, 2013 5:47 pm

Lovely, thanks for the tips and commands.

I'll try that now, and if it still doesn't work, probably best I just try again from scratch with a fresh install, armed with the knowledge you've shared.

I've already taken up enough of your time already, but it is much appreciated mate. :D
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby Mr. Green on Wed Sep 11, 2013 6:41 pm

Ok, so what is really bizarre - bearing in mind when I typed into the terminal that it returned:

cat: /usr/share/polkit-1/actions/org.freedesktop.consolekit.policy: No such file or directory...

is that upon examining the directory in the GUI - the file is indeed there. :roll: :lol:

Yet, it will not allow me to edit it, as it's read only. I'm sure you could give me a command to fix that in the CLI, but I've already taken enough of your valuable time, especially considering that we seem only to keep encountering further stumbling blocks.

Therefore I propose that I'll go get some sleep, and then run a fresh install tomorrow, as for whatever reasons, this one seems terminally corrupted.

One (hopefully) final bit of guidance though please - would you mind just replying with a quick list of "basics" directions, for what I should do once the install has completed, to ensure I do not screw up yet another installation? ;)

Like - should I reboot normally from the guest to check everything is working correctly before I run updates upgrades and guest additions etc, and then take my snapshot? I'd imagine that you'd also recommend I forget all about "saved states" this time around.

Just anything you think of that would help me to get a nice clean install really, any specifics that should or should not be checked in the settings/config - and the best order to do things in, so as not to corrupt anything, and waste even more of our time, lol.

Thanks again for all your help. :D
Mr. Green
Level 1
Level 1
 
Posts: 31
Joined: Tue Sep 10, 2013 12:11 pm

Re: Failed to open a session for the virtual machine Linux M

Postby trapperjohn on Wed Sep 11, 2013 8:09 pm

OK,

I'll post back the steps I follow tomorrow morning (I'm on Atlantic time).

Meanwhile, let's look at that read only file. Open both a terminal and the file browser on the desktop, so you can see them both. In the file browser, navigate to the folder that has the file. Then, in the terminal type, but don't hit enter,
sudo gedit
hit the space bar once then drag the file from the file browser into the terminal window.

The terminal should now say:
sudo gedit /thefolder/thefile
where /thefolder/thefile is the exact file spec for your file.

The file may well be a blank we created in a previous step.
trapperjohn
Level 5
Level 5
 
Posts: 686
Joined: Wed Jul 11, 2012 4:10 pm

Re: Failed to open a session for the virtual machine Linux M

Postby trapperjohn on Thu Sep 12, 2013 11:34 am

Hi,

Here are my notes:

Installing LMDE-Mate in VBox: Log of events
Note: I am installing from a Debian native machine, but the process will be the same on a Windows native platform.

Vbox Software:
From virtualbox.org site (not Mint package manager)
    Virtualbox version:VirtualBox-4.2.18-88780-Linux_amd64 (released Sept 6, 2013)
    VirtualBox Extension Pack: Oracle_VM_VirtualBox_Extension_Pack-4.2.18-88780.vbox-extpack

Note: I always install the extension pack in VirtualBox. It provides improved features that I find essential.

From Linux Mint website I get:
LDME version for Demo: linuxmint-201303-mate-dvd-32bit.iso (I'll refer to this as LDME.iso)
Note: I usually pick the 32 bit version for VM installs because I rarely need 64x capabilities with virtual machines. Later, when you install on your native machine, you can pick the x64 version.

My first step was to check the md5sum for my LDME download.
Code: Select all
me@debian:~$ md5sum '/media/Extension/Files/Isos/linuxmint-201303-mate-dvd-32bit.iso'
06ae51a79afb8cf71ebc21e78fb630b0  /media/Extension/Files/Isos/linuxmint-201303-mate-dvd-32bit.iso

The above step is somewhat difficult if you have downloaded to a Windows machine. It can be skipped but, if your download is corrupt, there may be troubles.

I install all of my machines in a custom folder (Vbox has a default location). I create a folder within this folder called isos and move my install LDME.iso to it.

Start Vbox interface and Machine>New Name = LDME_Demo, Type = Linux, Version = Debian: Next
    Memory = 1024 MB: Next
    Create a virtual hard Drive now: Create
    Type VDI: Next
    Dynamically Allocated: Next
    Virtual size: 12GB: Create

Now the LDME_Demo VM appears in the Vbox interface list. I select it, then click Settings
    General>Advanced Tab: Shared Clipboard = Bidirectional
    Display>Video Tab: Video Memory = well into the green
    Storage: Add s a new CD/DVD to the Controller IDE, then click Choose disk and navigate to the LDME.iso that I downloaded from Mint.
    Still on Storage settings item, highlight the LDME.iso entry and, on the right, check the box for Live CD/DVD: OK

Start the VM: The Mint Live session desktop appears. Double-click the Install Linux Mint icon on the desktop.
    Language: select yours: Forward
    Time Zone: select yours: Forward
    Keyboard Layout: select yours: Forward
    Full Name: john
    User Name john
    Password: 6Easy6
    Hostname: demolmdevm: Foreward
    Hard Drive: /dev/sda: Forward
    No partition table. Do you want to create: yes
    Partitioning: [sta1 swap][sda2 ext4]: Right-click “/dev/sda2 ext4” in list and choose “assign to /”: Forward
    Bootloader [x] install grub @ /dev/sda (defaults): Forward
    Summary: Install
Installing................................: Get a donut and a coffee
Important: When the installer completes, do not “restart now.” Answer No.
From the Mint Menu in the bottom-left corner of the desktop, pick Quit and choose the Shut Down button. When you see the remove disk, close tray, press enter and wait a few seconds to close.

After the VM has closed, highlight the LMDE_demo VM in the vbox interface, click Settings>Storage and highlight the Linux Mint CD/DVD. Right-click it and Remove Attachment: OK
In the top right of the Vbox interface click the button for Snapshots. Right-click Current State and Take Snapshot. In the name box type freshInstallNoUpdate: OK
Start the VM, enter user & your password

Right click the panel at the bottom and pick add to panel: add a workspace switcher. Experiment with the workspace switcher and see how you can have multiple screens for spreading out your tasks. Also, from menu>accessories, drag the terminal icon to the desktop. Do this again for Pluma.

From the devices menu at the top of the guest (these menus are Vbox menus and not Mint menus), choose Install Guest Additions. A window will pop up with Open Autorun as a default action: scroll it to Open Folder. Start your terminal and type sudo sh[space] then drag the VboxLinuxAdditions.run file into the terminal window. It will read:
sudo sh '/media/VBOXADDITIONS_4.2.18_88780/VBoxLinuxAdditions.run'
Ignore the lecture and enter your password, say yes when asked, and let it run.
When done, type:
exit
When the terminal is closed, close all windows and Menu>quit>shutdown

Restart and open Pluma: go to your native install', open some document and copy some text. Come back to the VM and paste it into Pluma.

If everything is working so far, close the VM from the Mint menu (quit) and go to your snapshots tab for the machine. Right-click Delete Snapshot and remove it. Take another snapshot of the current state and call it freshWithGuest Additions. Note: you can see the pattern; we make our changes stepwise and, after verifying that all is well, we delete previous snapshots and make a new one. Why delete the older one? It's not a good idea to have more that 1 or 2 snapshots.

Start the machine again, open a terminal, and run:
sudo apt-get update
sudo apt-get upgrade
(Answer yes to “do you want to continue.”)

Note: This is a better way to run a complete update than using the Update Manager menu item. Running update manager caches the root privileges for the session by default and, when you log out, you must enter the password to bump-off the priveleges... which, as we know, can be a hateful experience.

As the machine upgrades, it may encounter “Failed to fetch” errors. If so, run:
sudo apt-get update –fix-missing
sudo apt-get upgrade

(It still may fail to fetch if a server is down. Just try later.)

Note that the term update that we used when we ran sudo apt-get update does not update the software. Instead, it synchronizes the list of available software. Update, in the Windows sense of the word, is done with sudo apt-get upgrade.

In the terminal type:
exit
Close all windows and quit from the mint menu.

Start again to verify that all is well. If so, quit and replace the snapshot with a new one: freshInstallUpdate

One final note: When you have a snap shot and you start the machine, you are not running the snapshot. Changes you make will be storred in the current state. If the current state gets botched somehow, Restoring the snapshot will bring you backwards in time. Beware, when you restore a snapshot, a dialog box opens with the are you sure warning. Also in the dialog, as a VBox default, an option box for creating another snapshot for the current state is checked. I almost always uncheck this box.
trapperjohn
Level 5
Level 5
 
Posts: 686
Joined: Wed Jul 11, 2012 4:10 pm

Linux Mint is funded by ads and donations.
 
Next

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 3 guests