[SOLVED] LMDE to KDE4 install stop with Pango-WARNING**

Questions about applications and software
Forum rules
Before you post please read this

[SOLVED] LMDE to KDE4 install stop with Pango-WARNING**

Postby juanito003 on Tue Dec 03, 2013 6:28 am

Hi. I installed Linux Mint Debian Edition (LMDE) with cinnamon (201303 Cinnamon 64-bit) some weeks ago and I wanted to change the desktop to KDE4. Here is what I did:

Code: Select all
sudo aptitude install kde-full libkactivities-bin nepomuk-core-data libnepomukcore4 libkactivities-models1  kdesdk kdetoys kdewebdev kdm konq-plugins


After that, when I restarted the laptop, the following message appears and nothing more is loaded. I cannot go in a debug session, I have to reboot in debug mode.
Code: Select all
(process:283): Pango-WARNING**: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='latin'


After searching on forums and here, I did the following but nothing worked so far.
I tried installing other packages related to pango:
Code: Select all
sudo aptitude install libpangomm-1.4-1 libpangoxft-1.0-0 libpango-perl libpangox-1.0-0 libpango-1.0-0 libpangocairo-1.0-0 libpango1.0-doc libpango1-ruby1.8 libpangoft2-1.0-0 libpango1-ruby libpango1.0-0 libpango1.0-common


I changed /usr/share/fonts/kanjistrokeorders/KanjiStrokeOrders.ttf to 755 permissions

As seen in other posts, I tried to install dejavu-sans-fonts dejavu-serif-fonts but they don't exists for debian.

I edited the file /etc/fonts/conf.d/53-monospace-lcd-filter.conf
and removed the line:
Code: Select all
<string>Bitstream Vera Sans Mono</string>


By the way libkactivities-bin could not be installed because of unmet dependences:
Code: Select all
nepomuk-core-data : brokes: kde-runtime-data (< 4:4.8.80) but 4:4.8.4-2 is installed.


Now I cannot log in a normal session anymore. Can anyone give me some help?

Thanks.
Last edited by juanito003 on Mon Dec 09, 2013 4:05 am, edited 1 time in total.
juanito003
Level 1
Level 1
 
Posts: 5
Joined: Mon Mar 12, 2012 2:53 am

Linux Mint is funded by ads and donations.
 

Re: LMDE to KDE4 install stop with Pango-WARNING**

Postby kurotsugi on Tue Dec 03, 2013 1:56 pm

Code: Select all
(process:283): Pango-WARNING**: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='latin'
this isn't a serious issue and it should not gives us any problem. based on your explanation you might forget to upgrade your system into latest UP. for a quick solution you can try to run
Code: Select all
sudo apt-get update && sudo apt-get -f install


anyway, we might need additional information about your system. if you could, please give us the result of 'inxi -Fxr'.
kurotsugi
Level 5
Level 5
 
Posts: 702
Joined: Fri Jan 25, 2013 3:54 am

Re: LMDE to KDE4 install stop with Pango-WARNING**

Postby juanito003 on Wed Dec 04, 2013 5:24 am

Thank you for your help. I didn't know about inxi. Below are the results. My system is up to date and I don't get any new packages to upgrade since weeks (except for jitsi).
Do you think it's coming from the apt sources configured?

Code: Select all
$ sudo apt-get update && sudo apt-get -f install
...
186 ko réceptionnés en 12s (15,1 ko/s)
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.



Code: Select all
$ inxi -Fxr
System:    Host frill25102013 Kernel 3.10-2-amd64 x86_64 (64 bit) Distro LinuxMint 1 debian
CPU:       Dual core Intel Core i3 M 380 (-HT-MCP-) cache 3072 KB flags (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips 10107.5
           Clock Speeds: (1) 933.00 MHz (2) 933.00 MHz (3) 933.00 MHz (4) 933.00 MHz
Graphics:  Card Intel Core Processor Integrated Graphics Controller X.Org 1.12.4 Res: 1366x768@60.0hz, 1680x1050@60.0hz
           GLX Renderer Mesa DRI Intel Ironlake Mobile  GLX Version 2.1 Mesa 9.1.6 Direct Rendering Yes
Audio:     Card Intel 5 Series/3400 Series Chipset High Definition Audio driver snd_hda_intel BusID: 00:1b.0
           Sound: Advanced Linux Sound Architecture Version k3.10-2-amd64
Network:   Card-1 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver r8169 v: 2.3LK-NAPI at port 3000 BusID: 04:00.0
           Card-2 Realtek RTL8191SEvB Wireless LAN Controller driver rtl8192se at port 2000 BusID: 03:00.0
Disks:     HDD Total Size: 320.1GB (11.8% used) 1: /dev/sda WDC_WD3200BEVT 320.1GB
Partition: ID:/ size: 283G used: 36G (14%) fs: ext4
Sensors:   System Temperatures: cpu: 0.0C mobo: 0.0C
           Fan Speeds (in rpm): cpu: 0
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream import
           deb http://mirrors.ircam.fr/pub/linuxmint-debian/latest testing main contrib non-free
           deb http://mirrors.ircam.fr/pub/linuxmint-debian/latest/security testing/updates main contrib non-free
           deb http://mirrors.ircam.fr/pub/linuxmint-debian/latest/multimedia testing main non-free
           deb http://download.jitsi.org/nightly/deb unstable/
           deb http://liveusb.info/multisystem/depot all main
           deb-src http://liveusb.info/multisystem/depot all main
           Active apt sources in file: /etc/apt/sources.list.d/jitsi.list
           deb http://download.jitsi.org/deb unstable/
Info:      Processes 177 Uptime 1:28 Memory 2100.9/3764.5MB Runlevel 2 Client Shell inxi 1.4.23
juanito003
Level 1
Level 1
 
Posts: 5
Joined: Mon Mar 12, 2012 2:53 am

Re: LMDE to KDE4 install stop with Pango-WARNING**

Postby kurotsugi on Wed Dec 04, 2013 6:34 pm

you said that you didn't got any update for weeks but we actually got a lot of update around september. I thought that your souces.list is pointing to wrong repo. however, after seeing your inxi result your system seems have correct repo. I'm not sure where the problem is but something is weird. I've checked your repo and the latest version of kde-runtime-data is 4:4.10. for some reason your system is still using the older version and refuse to install the latest version. you might have some packages kept in held by aptitude. if that's true then this command should solve libactivities-bin issue
Code: Select all
sudo apt-get install kde-full libkactivities-bin nepomuk-core-data libnepomukcore4 libkactivities-models1  kdesdk kdetoys kdewebdev kdm konq-plugins
kurotsugi
Level 5
Level 5
 
Posts: 702
Joined: Fri Jan 25, 2013 3:54 am

Re: LMDE to KDE4 install stop with Pango-WARNING**

Postby Monsta on Thu Dec 05, 2013 2:16 am

kurotsugi wrote:I've checked your repo and the latest version of kde-runtime-data is 4:4.10.

:shock: What repo was that?
I'm getting different results.

Code: Select all
$ apt-cache policy kde-runtime-data
kde-runtime-data:
  Installed: (none)
  Candidate: 4:4.8.4-2
  Version table:
     4:4.8.4-2 0
        500 http://debian.lth.se/lmde/latest/ testing/main amd64 Packages
Monsta
Level 8
Level 8
 
Posts: 2017
Joined: Fri Aug 19, 2011 3:46 am

Re: LMDE to KDE4 install stop with Pango-WARNING**

Postby kurotsugi on Thu Dec 05, 2013 12:21 pm

I follow the link on his sources.list and I found 4.10.5-1 there
http://mirrors.ircam.fr/pub/linuxmint-d ... e-runtime/
kurotsugi
Level 5
Level 5
 
Posts: 702
Joined: Fri Jan 25, 2013 3:54 am

Re: LMDE to KDE4 install stop with Pango-WARNING**

Postby Monsta on Thu Dec 05, 2013 3:30 pm

This package is from Unstable repo. Well, from its snapshot taken at the same time as the snapshot from Testing.
Monsta
Level 8
Level 8
 
Posts: 2017
Joined: Fri Aug 19, 2011 3:46 am

Re: LMDE to KDE4 install stop with Pango-WARNING**

Postby juanito003 on Fri Dec 06, 2013 3:50 am

Hi,

I changed repo in the first place, because when installing LMDE from the iso, something went wrong. At the end of the installation I had an empty desktop and could not do anything. I did formatting the disk and started the installation again, but at that time, it was the same, after upgrading, I think a package was broken (sorry I don't remember exactly) and I could not load the desktop correctly. So I switched sources. My installation is from 31st October 2013.

Are my apt preferences ok?
$ cat /etc/apt/preferences
Code: Select all
Package: *
Pin: release o=linuxmint
Pin-Priority: 700

Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 700

Package: *
Pin: release o=Debian
Pin-Priority: 500


I tried your command:
$ sudo apt-get install kde-full libkactivities-bin nepomuk-core-data libnepomukcore4 libkactivities-models1 kdesdk kdetoys kdewebdev kdm konq-plugins
Code: Select all
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
konq-plugins est déjà la plus récente version disponible.
kdm est déjà la plus récente version disponible.
kdesdk est déjà la plus récente version disponible.
kdetoys est déjà la plus récente version disponible.
kdewebdev est déjà la plus récente version disponible.
kde-full est déjà la plus récente version disponible.
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 kde-full : Dépend: kde-plasma-desktop (>= 5:77+deb7u1) mais ne sera pas installé
            Dépend: kde-plasma-netbook (>= 5:77+deb7u1) mais ne sera pas installé
            Dépend: kdeadmin (>= 4:4.8.4) mais ne sera pas installé
            Dépend: kdeartwork (>= 4:4.8.4) mais ne sera pas installé
            Dépend: kdegraphics (>= 4:4.8.4) mais ne sera pas installé
            Dépend: kdeedu (>= 4:4.8.4) mais ne sera pas installé
            Dépend: kdegames (>= 4:4.8.4) mais ne sera pas installé
            Dépend: kdemultimedia (>= 4:4.8.4) mais ne sera pas installé
            Dépend: kdenetwork (>= 4:4.8.4) mais ne sera pas installé
            Dépend: kdeutils (>= 4:4.8.4) mais ne sera pas installé
            Dépend: kdepim (>= 4:4.4.11) mais ne sera pas installé
            Dépend: kdeplasma-addons (>= 4:4.8.4) mais ne sera pas installé
            Recommande: kde-standard (>= 5:77+deb7u1) mais ne sera pas installé
            Recommande: kdeaccessibility (>= 4:4.8.4) mais ne sera pas installé
 kdesdk : Dépend: cervisia (>= 4:4.8.4+dfsg-1) mais ne sera pas installé
          Dépend: kapptemplate (>= 4:4.8.4+dfsg-1) mais ne sera pas installé
          Dépend: kcachegrind (>= 4:4.8.4+dfsg-1) mais ne sera pas installé
          Dépend: kdesdk-misc (>= 4:4.8.4+dfsg-1) mais ne sera pas installé
          Dépend: kompare (>= 4:4.8.4+dfsg-1) mais ne sera pas installé
          Dépend: kuiviewer (>= 4:4.8.4+dfsg-1) mais ne sera pas installé
          Dépend: lokalize (>= 4:4.8.4+dfsg-1) mais ne sera pas installé
          Dépend: umbrello (>= 4:4.8.4+dfsg-1) mais ne sera pas installé
          Dépend: kpartloader (>= 4:4.8.4+dfsg-1) mais ne sera pas installé
          Dépend: kmtrace (>= 4:4.8.4+dfsg-1) mais ne sera pas installé
          Dépend: kdesdk-dolphin-plugins (>= 4:4.8.4+dfsg-1) mais ne sera pas installé
          Dépend: okteta (>= 4:4.8.4+dfsg-1) mais ne sera pas installé
          Dépend: kate mais ne sera pas installé
 kdetoys : Dépend: amor (>= 4:4.8.4-1) mais ne sera pas installé
           Dépend: kteatime (>= 4:4.8.4-1) mais ne sera pas installé
 kdewebdev : Dépend: kfilereplace (>= 4:4.8.4-1) mais ne sera pas installé
             Dépend: kimagemapeditor (>= 4:4.8.4-1) mais ne sera pas installé
             Dépend: klinkstatus (>= 4:4.8.4-1) mais ne sera pas installé
             Dépend: kommander (>= 4:4.8.4-1) mais ne sera pas installé
 nepomuk-core-data : Casse: kde-runtime-data (< 4:4.8.80) mais 4:4.8.4-2 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


Sorry it's in french, but it says that it is not possible to correct the problem, packages are kept back.
So what do I do, should I change repo back to normal? (see below)
$ cat sources.list.bk
Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free
juanito003
Level 1
Level 1
 
Posts: 5
Joined: Mon Mar 12, 2012 2:53 am

Re: LMDE to KDE4 install stop with Pango-WARNING**

Postby Monsta on Fri Dec 06, 2013 5:22 am

I've reproduced it. Well, there's your problem:

Code: Select all
monsta@minty ~ $ sudo apt-get install kde-runtime-data nepomuk-core-data
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nepomuk-core-data : Breaks: kde-runtime-data (< 4:4.8.80) but 4:4.8.4-2 is to be installed
E: Unable to correct problems, you have held broken packages.
Code: Select all
monsta@minty ~ $ apt-cache policy kde-runtime-data
kde-runtime-data:
  Installed: (none)
  Candidate: 4:4.8.4-2
  Version table:
     4:4.8.4-2 0
        500 http://debian.lth.se/lmde/latest/ testing/main amd64 Packages
Code: Select all
monsta@minty ~ $ apt-cache policy nepomuk-core-data
nepomuk-core-data:
  Installed: (none)
  Candidate: 4:4.10.5-1
  Version table:
     4:4.10.5-1 0
        500 http://debian.lth.se/lmde/latest/ testing/main amd64 Packages


As you probably know, Update Packs are basically frozen snapshots of Debian Testing. The snapshot that later became UP7 has been taken at the unlucky time when there was a process of transitioning KDE from 4.8 to 4.10 in Testing. Some packages were already at version 4.10 while some remained at 4.8. There's no KDE edition of LMDE, and there are not many KDE users here, so when UP7 was being tested for release, this error slipped in unnoticed.
It's just my guess, but it really looks like that's what has happened.

Now about what you can do to install KDE. You can add Testing repo and install KDE 4.11 from there. Though I'm not sure if this transition is complete by now. You can also look at snapshot.debian.org and try to get KDE 4.10 packages from there.

Finally, you can just switch to SolydXK.
Monsta
Level 8
Level 8
 
Posts: 2017
Joined: Fri Aug 19, 2011 3:46 am

Re: LMDE to KDE4 install stop with Pango-WARNING**

Postby juanito003 on Sat Dec 07, 2013 1:01 pm

Hi Monsta,

Thanks a lot for this very valuable information, I hoped it will help other people in my case.
I didn't know about solidXK, that is exactly what I was looking for, a great debian distribution rolling release and based on KDE that do not broke every new upgrade.
I prefer not try to add Testing repo, I don't want to break anything as it is my work laptop. I cannot loose time to fix packages at work.

To switch to solidK without doing a complete reinstall, is it possible to simply change the repos by the one from solidK for exemple? Is this a secure way to proceed?

Thanks.
juanito003
Level 1
Level 1
 
Posts: 5
Joined: Mon Mar 12, 2012 2:53 am

Re: LMDE to KDE4 install stop with Pango-WARNING**

Postby Monsta on Sat Dec 07, 2013 2:10 pm

juanito003 wrote:To switch to solidK without doing a complete reinstall, is it possible to simply change the repos by the one from solidK for exemple? Is this a secure way to proceed?

I really don't know. I have never used SolydXK myself. It's probably better to ask on their forums.
Monsta
Level 8
Level 8
 
Posts: 2017
Joined: Fri Aug 19, 2011 3:46 am

Re: LMDE to KDE4 install stop with Pango-WARNING**

Postby kurotsugi on Sun Dec 08, 2013 2:40 am

there was a script to convert LMDE xfce version to solydxk but they never work perfectly. if you're using other DE like cinnamon or mate, the best choice is install it from solydxk iso. there are other possibility which you can use solydxk's debian snapshot without using solydxk's internal repository. since update manager no longer able to do the updates, the mayor drawback is that you'll need to upgrade your system manually. you'll also need to very carefull with the system breakage since current cinnamon isn't 100% compatible with debian testing.
kurotsugi
Level 5
Level 5
 
Posts: 702
Joined: Fri Jan 25, 2013 3:54 am

Re: LMDE to KDE4 install stop with Pango-WARNING**

Postby juanito003 on Mon Dec 09, 2013 4:07 am

Ok, then I prefer to start from a fresh install with solidxk iso. Thanks, I put the post as SOLVED.

By the way, I should rather post this on the solidxk forum, but why the team from solidxk didn't join linux mint to propose a linux mint KDE version instead of creating a new distro?
juanito003
Level 1
Level 1
 
Posts: 5
Joined: Mon Mar 12, 2012 2:53 am

Re: [SOLVED] LMDE to KDE4 install stop with Pango-WARNING**

Postby Monsta on Mon Dec 09, 2013 5:49 am

juanito003 wrote:why the team from solidxk didn't join linux mint to propose a linux mint KDE version instead of creating a new distro?

It was the other way around. First there were two unofficial editions of LMDE (KDE & Xfce), and then the author (Schoelje) went his own way. Here's the announcement.
Monsta
Level 8
Level 8
 
Posts: 2017
Joined: Fri Aug 19, 2011 3:46 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 5 guests