[SOLVED] Trouble trying to install VMWare View Client

Questions about applications and software
Forum rules
Before you post please read this

[SOLVED] Trouble trying to install VMWare View Client

Postby fschaap on Sat Apr 12, 2014 4:26 am

I'm running LMDE and I need to install the VMWare View Client because I need to connect with the pcoip protocol. Note: the VMWare View Open Client that is in the repo does not support pcoip.

It appears VMWare only releases an i386 .deb file through Ubuntu, here: http://archive.canonical.com/ubuntu/poo ... ew-client/

I have multiarch support installed, but when I try to install it with GDebi, it throws the error:

Code: Select all
Error: Dependency is not satisfiable: libssl0.9.8 (>= 0.9.8m-1)


So, how do I go about fixing the dependency problems?

I'd prefer not downgrading the openssl package to 0.9.8 system wide, if necessary only for the View Client...
Last edited by fschaap on Sun Jun 29, 2014 9:37 am, edited 1 time in total.
Linux Mint Debian Edition with Cinnamon
fschaap
Level 1
Level 1
 
Posts: 45
Joined: Mon Aug 02, 2010 8:37 am
Location: The Netherlands

Linux Mint is funded by ads and donations.
 

Re: Dependency trouble trying to install VMWare View Client

Postby fschaap on Sun Jun 29, 2014 9:36 am

Found the solution here: http://hyperinfo.wordpress.com/2014/04/ ... sed-linux/

Using the Horizon View Client on Debian (Ubuntu/Mint) based distributions gives some problems. Basically, the solution is to use multi-arch and libssl0.9.8 from Ubuntu (i386). You will want the i386 packages even if you are using the amd64 build of Debian. Please note that if you have anything that relies on the Debian version of libssl0.9.8, installing the Ubuntu version of libssl0.9.8 as seen below will break those packages and apt will want to remove them! If you get an error in apt asking to remove a number of packages or needing to run apt-get install -f to fix broken dependencies, this is the case. Removing the Ubuntu version of libssl0.9.8 and reinstalling libssl0.9.8 from squeeze will resolve that.

The packages that we will be using from Ubuntu are from 12.04 which is based on Debian wheezy and is currently under long term support (LTS).

With that being said, here is how it works:

(amd64 only) Enable multi-arch:

dpkg --add-architecture i386
apt-get update

(Optional) Install GDebi Package Installer (gui package installer that handles dependency installation for you)

apt-get install gdebi

Download vmware-view-client_2.2.0-0ubuntu0.14.04_i386.deb: http://archive.canonical.com/ubuntu/poo ... 4_i386.deb
Download libssl0.9.8_0.9.8o-7ubuntu3.1_i386.deb: http://packages.ubuntu.com/precise-upda ... 8/download
Install the Ubuntu 12.04 i386 version of libssl0.9.8. Just right click on the downloaded file and choose Open With GDebi Package Installer and click Install when it loads.
Install the Ubuntu 14.04 i386 version of vmware-view-client Just right click on the downloaded file and choose Open With GDebi Package Installer and click Install when it loads.
Now, vmware-view-client should be installed and available from Applications > Internet > VMware View Client.

This should work for both i386 and amd64, just make sure to follow the instructions above following your architecture’s instructions.
Linux Mint Debian Edition with Cinnamon
fschaap
Level 1
Level 1
 
Posts: 45
Joined: Mon Aug 02, 2010 8:37 am
Location: The Netherlands


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 3 guests