ibus and chinese input

Questions about applications and software
Forum rules
Before you post please read this

ibus and chinese input

Postby horizonbrave on Thu Apr 17, 2014 11:12 am

Hi,
I just set up an installation of Linux Mint Debian Edition (LMDE 201403) with everything working smooth except I'm not able to use the keyboard to input in Chinese characters (Mandarin, traditional Chinese). I tried to install ibus and ibus-pinyin packages.. it took me a while but apparently after the installation you need to start ibus because no system tray icon showing up. I did that through the command "ibus-daemon &" and had also to put it in the startup programs list as well because at the following log in the daemon did never show up again. After that a system tray icon appears and let me choose through different style of Chinese input.. but none of theme work! Everything I type is always in western/roman characters whatever I choose through that ibus system tray icon.

I also tried this instruction http://community.linuxmint.com/tutorial/view/619
but I'm not interested in login in Chinese configured desktop environment, I need to type in Chinese!

Please, any idea?
Thanks
horizonbrave
Level 1
Level 1
 
Posts: 1
Joined: Wed Apr 16, 2014 4:39 am

Linux Mint is funded by ads and donations.
 

Re: ibus and chinese input

Postby xenopeek on Thu Apr 17, 2014 4:20 pm

Assuming you are using Cinnamon. You would have needed to install the packages ibus and ibus-pinyin (and no other ibus packages!). Then the rest of my post here has the general steps for Linux Mint 15: viewtopic.php?f=90&t=143194#p756555. Might be relevant for LMDE also. The icon also didn't appear on Linux Mint 16, so additional step there was to instead of clicking on the icon on your panel (as it didn't appear) to press Alt+F2 or open a terminal and run the command: ibus-setup
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14996
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: ibus and chinese input

Postby happyhua on Tue May 13, 2014 8:16 am

I have the same issue.

The issue happens only to the Linux Mint Debian (Cinnamon 64-bit). There is no popup overlay, the input method is set to Chinese Pinyin, see attachment.

It works well on Linux Mint 16 (Cinnamon 64-bit), so it looks like a bug on Debian system.

@horizonbrace, as a temporary workaround, I suggest the following url for you.

https://chrome.google.com/webstore/deta ... cijmpgbhab

It allows you typing Chinese on chrome browser, from where you can copy your Chinese characters to the operation system program.
Attachments
NoOverlayOnLinuxMintDebian.png
happyhua
Level 1
Level 1
 
Posts: 1
Joined: Tue May 13, 2014 8:05 am

Re: ibus and chinese input

Postby Glacier on Sun Jun 22, 2014 10:48 am

This might help:

viewtopic.php?f=90&t=170002&p=878762&hilit=libpinyin#p878762

However, I've since found out this doesn't work with Firefox, which studiously ignores any attempt at Chinese input unless you copy and paste from another application. But at least it's something. Any help with getting this working properly with Firefox would be appreciated.

Glacier
Glacier
Level 1
Level 1
 
Posts: 5
Joined: Fri Jun 20, 2014 11:01 am

Re: ibus and chinese input

Postby highwind on Sun Jun 22, 2014 11:40 am

and may be you can try fcitx to input Chinese.
Nemo-Actions(learn from Thunar)http://docs.xfce.org/xfce/thunar/custom-actions
my unsolved posts:
47&t=162435
47&t=168608
211&t=170628
47&t=170642
90&t=170629
highwind
Level 2
Level 2
 
Posts: 71
Joined: Tue Jan 07, 2014 4:25 pm

Re: ibus and chinese input

Postby Glacier on Mon Jun 23, 2014 4:46 am

Thanks for the reminder, highwind. In the end I gave up trying to get ibus working with Firefox, so de-installed and tried fcitx instead. After a few attempts, not really knowing what I was doing, I got it working.

I was looking for a simple how-to (in English) on setting up fcitx, but didn't find one that works. I'll spend some more time on this and write up the minimum required steps to get it working with a fresh LMDE installation.
Glacier
Level 1
Level 1
 
Posts: 5
Joined: Fri Jun 20, 2014 11:01 am

Re: ibus and chinese input

Postby fu-sen on Mon Jun 23, 2014 5:09 am

I just found this topic. (Glacier has already replied...)

Please try this command if you use iBus:
Code: Select all
$ sudo apt-get install ibus-gtk ibus-gtk3 ibus-qt4 python-appindicator

Addition, iBus is specifications greatly changed in 1.5,
This comes under an influence of LMDE. (It was updated in UP8, Main Edition is after 16)
Please substitute Fcitx if you think of iBus unpleasantly.

Do you work for such a feeling?:
Code: Select all
$ sudo apt-get install im-config fcitx fcitx-sogoupinyin fcitx-table-wubi fcitx-frontend-gtk2 fcitx-frontend-gtk3 fcitx-frontend-qt4 fcitx-frontend-qt5 fcitx-ui-classic fcitx-config-gtk
$ im-config -n fcitx
BALLOON a.k.a. Fu-sen. | ふうせん Fu-sen.
17 Cinnamon / KDE | 13 MATE / Xfce | LMDE Cinnamon
Let's use Linux Mint (Japanese Information) http://linuxmintjp.jimdo.com/ | リナックスミントをつかおう
User avatar
fu-sen
Level 1
Level 1
 
Posts: 45
Joined: Thu Mar 06, 2014 4:16 am
Location: Miyagi, Japan

Re: ibus and chinese input

Postby highwind on Mon Jun 23, 2014 1:14 pm

Glacier wrote:Thanks for the reminder, highwind. In the end I gave up trying to get ibus working with Firefox, so de-installed and tried fcitx instead. After a few attempts, not really knowing what I was doing, I got it working.

I was looking for a simple how-to (in English) on setting up fcitx, but didn't find one that works. I'll spend some more time on this and write up the minimum required steps to get it working with a fresh LMDE installation.

as I know
Code: Select all
fcitx fcitx-ui-classic fcitx-config-gtk
and its deps , of course
Code: Select all
fcitx-frontend-gtk2 fcitx-frontend-gtk3 fcitx-frontend-qt4 fcitx-frontend-qt5
not sure if fcitx-frontend-gtk2 fcitx-frontend-qt5 are necessary (I think it depends on what software your are running)
Code: Select all
fcitx-sogoupinyin fcitx-table-wubi
that's option, I prefer rime, sunpinyin or libpinyin and cloudpinyin module as pinyin input method

and here is the wiki link:https://fcitx-im.org/wiki/Fcitx
Nemo-Actions(learn from Thunar)http://docs.xfce.org/xfce/thunar/custom-actions
my unsolved posts:
47&t=162435
47&t=168608
211&t=170628
47&t=170642
90&t=170629
highwind
Level 2
Level 2
 
Posts: 71
Joined: Tue Jan 07, 2014 4:25 pm

Re: ibus and chinese input

Postby menuhin on Tue Sep 02, 2014 11:06 am

I'm using LMDE and have done the following steps to change the iBus setup, however, I still cannot get iBus to work yet.
(And I speak Cantonese, and therefore I can't use Fcitx that uses pinyin which is for Mandarin speakers)
Is there any known work around right now?
Thanks!

fu-sen wrote:I just found this topic. (Glacier has already replied...)

Please try this command if you use iBus:
Code: Select all
$ sudo apt-get install ibus-gtk ibus-gtk3 ibus-qt4 python-appindicator

Addition, iBus is specifications greatly changed in 1.5,
This comes under an influence of LMDE. (It was updated in UP8, Main Edition is after 16)
Please substitute Fcitx if you think of iBus unpleasantly.

menuhin
Level 1
Level 1
 
Posts: 39
Joined: Fri Jun 26, 2009 12:52 pm

Re: ibus and chinese input

Postby highwind on Tue Sep 02, 2014 7:43 pm

I think fcitx should have a package for cantonese.
Nemo-Actions(learn from Thunar)http://docs.xfce.org/xfce/thunar/custom-actions
my unsolved posts:
47&t=162435
47&t=168608
211&t=170628
47&t=170642
90&t=170629
highwind
Level 2
Level 2
 
Posts: 71
Joined: Tue Jan 07, 2014 4:25 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 4 guests