Using Shutter as the default screen grabbing tool.

Questions about applications and software
Forum rules
Before you post please read this

Using Shutter as the default screen grabbing tool.

Postby requiem18th on Tue Apr 22, 2014 3:36 am

Is it possible to configure shutter under cinnamon? I have tried the keyboard bindings section in the settings applet but cinnamon refuses to give up these keys, it's almost like the printscreen key is hard coded into cinnamon. Please tell me there is a way to use shutter with the printscreen key under cinnamon. Is there?
requiem18th
Level 1
Level 1
 
Posts: 10
Joined: Fri Aug 13, 2010 11:40 pm

Linux Mint is funded by ads and donations.
 

Re: Using Shutter as the default screen grabbing tool.

Postby ficestat on Wed Apr 30, 2014 6:34 pm

You can create a custom keyboard shortcut for shutter for the selection tool.

In Mint Cinnamon 16
-I opened settings, keyboard, keyboard shortcuts, clicked add custom shortcut, name: shutter, command: shutter -s, and clicked update.
-Now, click Custom Shortcuts, click shutter, and under Keyboard bindings, click unassigned, and press the Insert key.
-Now press the Insert key to open the Shutter selection tool.

I haven't figured out what's bound to the Print Screen key yet, but I've learned several other people have the same exact issue with not being able to use Print Screen as the binded key. If anyone else knows how to fix this, let us know.
ficestat
Level 1
Level 1
 
Posts: 2
Joined: Tue Aug 06, 2013 9:14 am

Re: Using Shutter as the default screen grabbing tool.

Postby ron_h on Sun Jun 08, 2014 12:12 am

LMDE 201403 Cinnamon 64bit

I agree that PrintScreen and Alt-PrintScreen don't work, but Ctrl-PrintScreen does, on my system.

Ron
ron_h
Level 3
Level 3
 
Posts: 180
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Using Shutter as the default screen grabbing tool.

Postby krige on Thu Oct 09, 2014 8:03 am

I still can't get shutter grab the PrtSc key nor the Alt+PrtSc shortcut, using LMDE 201403.

In the attempt to replace the default screenshot grabbing tool I have first removed the preinstalled one by running:

Code: Select all
sudo apt-get remove gnome-screenshot


Then I ran:

Code: Select all
sudo apt-get install shutter


I have then opened the shutter settings from Edit > Preferences > Keyboard and checked both the keyboard bindings but they still don't work: when I press those key nothing happens.

I have also tried changing the shortcuts from the system preferences. I created two custom shortcuts for PrtSc and Alt+PrtSc, assigning "shutter -f" and "shutter -a" respectively, but it didn't work either.

EDIT: It looks like the Print Screen key is bound to execute "gnome-screenshot" and there is nothing we can do about it.

There is a pull request to fix this bug:
https://github.com/linuxmint/Cinnamon/issues/2564
User avatar
krige
Level 1
Level 1
 
Posts: 20
Joined: Wed Sep 18, 2013 8:36 am

Re: Using Shutter as the default screen grabbing tool.

Postby Flemur on Thu Oct 09, 2014 2:01 pm

I have tried the keyboard bindings section in the settings applet ...

For your safety and convenience, some keyboard settings are set/changed under "desktop settings".
(Xfce anyway, probably similar for other DEs).

Just to plug the Wonder of Fluxbox, where changing this stuff is reliable and as completely trivial as it should be:
107 :Exec /usr/bin/xfce4-screenshooter
Control 107 :Exec /usr/bin/scrot

... in the ~/.fluxbox/keys file.

Edit: you could try leaving it set to whatever screenshot program it likes, and hack that into a link to the one you want, e.g.
Change current-screenshot -> link to -> program you want.
Mint 17/Xfce/fluxbox & another Mint 17/Xfce/fluxbox with jackd audio.
User avatar
Flemur
Level 5
Level 5
 
Posts: 971
Joined: Mon Aug 20, 2012 9:41 pm


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 3 guests