Installation "acroread" missing dependencies on 64bit

Questions about applications and software
Forum rules
Before you post please read how to get help

Installation "acroread" missing dependencies on 64bit

Postby c.monty on Thu Jun 19, 2014 7:30 am

Hi!

I have successfully installed LMDE UP8 64-bit on my laptop.

Now, I want to install "acroread",
Code: Select all
]user@notebook-acer ~ $ apt-cache policy acroread
acroread:i386:
  Installiert:           (keine)
  Installationskandidat: 9.5.5-dmo1
  Versionstabelle:
     9.5.5-dmo1 0
        500 http://linuxmint-apt.killerhorse.eu/debian/latest/multimedia/ testing/non-free i386 Packages
but this fails due to missing dependencies:
Code: Select all
user@notebook-acer ~ $ sudo apt-get install acroread
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 acroread:i386 : Hängt ab von: libgtk2.0-0:i386 (>= 2.24.0) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


I understand that this software is 32bit, but when I try to install the depending libraries, the system would uninstall Cinnamon and others:
Code: Select all
user@notebook-acer ~ $ sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386 libcups2:i386 libgcrypt11:i386 libgnutls26:i386 libgcrypt11:i386
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
libxml2:i386 is already the newest version.
libstdc++6:i386 is already the newest version.
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  cheese-common geany-common git-man gnome-control-center-data libaudclient2
  libbit-vector-perl libbonoboui2-common libcarp-clan-perl
  libclass-data-inheritable-perl libcommon-sense-perl libconfig-general-perl
  libcrack2 libcrypt-openssl-bignum-perl libcrypt-openssl-rsa-perl
  libdata-random-perl libdate-calc-perl liberror-perl libextutils-depends-perl
  libextutils-pkgconfig-perl libfile-which-perl libfont-ttf-perl libgd-perl
  libgee2 libgnomeui-common libgoocanvas-common libgphoto2-6 libgphoto2-port10
  libhttp-server-simple-perl libjson-perl libjson-xs-perl liblog-log4perl-perl
  libmono-sqlite4.0-cil
  libmono-system-runtime-serialization-formatters-soap4.0-cil
  libmono-system-web-applicationservices4.0-cil
  libmono-system-web-services4.0-cil libmono-system-web4.0-cil
  libmono-web4.0-cil libmouse-perl libnet-dropbox-api-perl libnet-oauth-perl
  libpath-class-perl libpdf-api2-perl libproc-processtable-perl
  libproc-simple-perl libpwquality-common libpwquality1 libreadonly-perl
  libset-intspan-perl libsocialweb-client2 libsocialweb-common
  libsort-naturally-perl libtiff-tools libtry-tiny-perl libwine-gecko-2.21
  libwww-mechanize-perl libxmmsclient6 libxnvctrl0 perlmagick
  ttf-ancient-fonts
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  libatk1.0-0:i386 libavahi-client3:i386 libavahi-common-data:i386
  libavahi-common3:i386 libcairo2:i386 libcomerr2:i386 libdrm2:i386
  libegl1-mesa:i386 libgbm1:i386 libgdk-pixbuf2.0-0:i386 libgl1-mesa-glx:i386
  libglapi-mesa:i386 libgpg-error0:i386 libgraphite2-3:i386
  libgssapi-krb5-2:i386 libharfbuzz0a:i386 libjasper1:i386 libk5crypto3:i386
  libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 libllvm3.3:i386
  libnspr4:i386 libnss3:i386 libp11-kit0:i386 libpango-1.0-0:i386
  libpangocairo-1.0-0:i386 libpangoft2-1.0-0:i386 libpixman-1-0:i386
  libtasn1-6:i386 libudev1:i386 libwayland-client0:i386
  libwayland-server0:i386 libxcb-dri2-0:i386 libxcb-glx0:i386
  libxcb-render0:i386 libxcb-shape0:i386 libxcb-shm0:i386 libxcb-xfixes0:i386
  libxcomposite1:i386 libxcursor1:i386 libxinerama1:i386 libxxf86vm1:i386
  tint2
Vorgeschlagene Pakete:
  rng-tools:i386 krb5-doc:i386 krb5-user:i386 librsvg2-common:i386 gvfs:i386
  libjasper-runtime:i386 ttf-baekmuk:i386 ttf-arphic-gbsn00lp:i386
  ttf-arphic-bsmi00lp:i386 ttf-arphic-gkai00mp:i386 ttf-arphic-bkai00mp:i386
Empfohlene Pakete:
  libegl1-mesa-drivers:i386 libgl1-mesa-dri:i386 hicolor-icon-theme:i386
Die folgenden Pakete werden ENTFERNT:
  apt-file apt-transport-https apturl banshee brasero ca-certificates-java
  caribou cinnamon cinnamon-bluetooth cinnamon-control-center
  cinnamon-screensaver cinnamon-session cinnamon-settings-daemon colord
  command-not-found conky-all conky-manager cryptsetup cryptsetup-bin cups
  cups-client cups-daemon cups-driver-gutenprint cups-filters cups-pdf
  cups-pk-helper cups-ppdc curl davfs2 default-jre default-jre-headless docky
  ecryptfs-utils eog espeak evince ffmpegthumbnailer file-roller gcalctool
  gconf-service gconf2 gcr gdebi geany gedit ghostscript ghostscript-cups
  ghostscript-x gimp gir1.2-caribou-1.0 gir1.2-cinnamondesktop-3.0
  gir1.2-clutter-1.0 gir1.2-gconf-2.0 gir1.2-gkbd-3.0
  gir1.2-gnomebluetooth-1.0 gir1.2-gnomedesktop-3.0 gir1.2-gtk-3.0
  gir1.2-gtkclutter-1.0 gir1.2-muffin-3.0 gir1.2-networkmanager-1.0
  gir1.2-peas-1.0 gir1.2-soup-2.4 gir1.2-vte-2.90 gir1.2-webkit-3.0 git
  gkbd-capplet gksu glib-networking gnome-bluetooth gnome-calculator
  gnome-disk-utility gnome-icon-theme gnome-icon-theme-symbolic gnome-keyring
  gnome-media gnome-panel gnome-screenshot gnome-session-bin
  gnome-settings-daemon gnome-system-monitor gnome-terminal
  gnome-themes-standard gnupg-agent gnupg2 gparted gpgsm grsync gscan2pdf
  gstreamer0.10-gconf gstreamer0.10-gnomevfs gstreamer0.10-nice
  gstreamer0.10-plugins-bad gstreamer0.10-plugins-good
  gstreamer0.10-pulseaudio gstreamer1.0-clutter gstreamer1.0-nice
  gstreamer1.0-plugins-bad gstreamer1.0-plugins-good gstreamer1.0-pulseaudio
  gthumb gtk2-engines gtk2-engines-aurora gtk2-engines-candido
  gtk2-engines-murrine gtk2-engines-pixbuf gucharmap gvfs gvfs-backends
  gvfs-daemons gvfs-libs hplip icedtea-6-plugin icedtea-7-plugin icedtea-netx
  icedtea-plugin ideviceinstaller intel-linux-graphics-installer iputils-ping
  libasound2-plugins libatk-wrapper-java libatk-wrapper-java-jni libavformat54
  libbonoboui2-0 libbrasero-media3-1 libcanberra-gtk0 libcanberra-gtk3-0
  libcanberra-pulse libcaribou0 libcinnamon-control-center1
  libcinnamon-desktop0 libclutter-1.0-0 libclutter-gst-2.0-0
  libclutter-gtk-1.0-0 libcmis-0.3-3 libcryptsetup4 libcups2 libcupscgi1
  libcupsfilters1 libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3
  libcurl3-gnutls libecal-1.2-15 libedataserver-1.2-17 libespeak1
  libevdocument3-4 libevview3-3 libfarstream-0.1-0 libffmpegthumbnailer4
  libfluidsynth1 libgail-3-0 libgail-common libgail18 libgconf2-4
  libgconf2.0-cil libgcr-3-1 libgcr-base-3-1 libgcr-ui-3-1 libgcrypt11
  libgimp2.0 libgksu2-0 libglade2-0 libgmime-2.6-0 libgnome-bluetooth11
  libgnome-desktop-2-17 libgnome-desktop-3-7 libgnome-keyring0
  libgnome-keyring1.0-cil libgnome-media-profiles-3.0-0 libgnome2-0
  libgnome2-canvas-perl libgnome2-common libgnome2-gconf-perl libgnome2-perl
  libgnome2-vfs-perl libgnome2-wnck-perl libgnomecanvas2-0
  libgnomedesktop2.20-cil libgnomekbd8 libgnomeui-0 libgnomevfs2-0
  libgnomevfs2-common libgnutls-openssl27 libgnutls26 libgoa-1.0-0
  libgoo-canvas-perl libgoocanvas3 libgpgme11 libgpod4 libgs9 libgssdp-1.0-3
  libgtk-3-0 libgtk-3-bin libgtk-sharp-beans-cil libgtk2-ex-simple-list-perl
  libgtk2-imageview-perl libgtk2-perl libgtk2-unique-perl libgtk2.0-0
  libgtk2.0-bin libgtk2.0-cil libgtkglext1 libgtkimageview0 libgtkmm-2.4-1c2a
  libgtkmm-3.0-1 libgtksourceview-3.0-1 libgtkspell0 libgucharmap-2-90-7
  libgupnp-1.0-4 libgupnp-igd-1.0-4 libgweather-3-3 libhdb9-heimdal
  libimobiledevice-utils libimobiledevice4 libindicator3-7 libkdc2-heimdal
  libldap-2.4-2 libldb1 libloudmouth1-0 libmetacity-private0a
  libmono-addins-gui0.2-cil libmtp-runtime libmtp9 libmuffin0
  libnautilus-extension1a libnemo-extension1 libneon27-gnutls libnice10
  libnm-glib-vpn1 libnm-glib4 libnm-gtk0 libnm-util2 libnotify0.4-cil
  libopencv-calib3d2.4 libopencv-contrib2.4 libopencv-features2d2.4
  libopencv-highgui2.4 libopencv-legacy2.4 libopencv-objdetect2.4
  libpam-systemd libpanel-applet-4-0 libpeas-1.0-0 libpulse-mainloop-glib0
  libpulse0 libpulsedsp libpurple0 libquvi7 libraptor2-0 librasqal3 librdf0
  libreoffice-base libreoffice-base-core libreoffice-calc libreoffice-core
  libreoffice-draw libreoffice-gnome libreoffice-gtk libreoffice-help-en-us
  libreoffice-impress libreoffice-math libreoffice-writer librest-0.7-0
  librsvg2-2.18-cil librtmp0 libsane libsane-hpaio libsane-perl
  libsdl-image1.2 libsdl1.2debian libsecret-1-0 libseed-gtk3-0 libsexy2
  libslv2-9 libsmbclient libsoup-gnome2.4-1 libsoup2.4-1 libspectre1 libssh2-1
  libsystemd-journal0 libtotem-plparser17 libtotem0 libunique-1.0-0
  libvte-2.90-9 libvte9 libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 libwine
  libwnck-3-0 libwnck2.20-cil libwnck22 libxslt1.1 libyelp0 mdm metacity
  mint-artwork-debian mint-common mint-meta-codecs mint-meta-debian-cinnamon
  mint-meta-debian-codecs mint-meta-debian-core mintbackup mintinstall
  mintnanny mintsources mintstick mintsystem mintupdate-debian mintupload
  mintwelcome mousetweaks nemo nemo-fileroller nemo-share network-manager
  network-manager-gnome network-manager-pptp network-manager-pptp-gnome
  notification-daemon ntfs-3g openjdk-6-jre openjdk-6-jre-headless
  openjdk-6-jre-lib openjdk-7-jre openjdk-7-jre-headless openjdk-7-jre-lib
  pidgin pinentry-gtk2 plymouth-x11 policykit-1-gnome printer-driver-c2050
  printer-driver-c2esp printer-driver-escpr printer-driver-foo2zjs
  printer-driver-gutenprint printer-driver-hpcups printer-driver-pnm2ppa
  printer-driver-postscript-hp printer-driver-ptouch printer-driver-sag-gdi
  printer-driver-splix pulseaudio pulseaudio-esound-compat
  pulseaudio-module-bluetooth pulseaudio-module-x11 pulseaudio-utils
  python-aptdaemon.gtk3widgets python-cups python-cupshelpers python-gconf
  python-glade2 python-gtk2 python-ldb python-lxml python-notify python-opencv
  python-pyatspi python-pycurl python-samba python-sexy python-vte
  python-webkit samba samba-common-bin samba-dsdb-modules samba-libs
  sane-utils scdaemon seahorse shutter simple-scan smbclient synaptic
  system-config-printer system-config-printer-udev systemd telepathy-gabble
  telepathy-mission-control-5 testdisk tomboy totem totem-mozilla
  transmission-gtk upower vino virtualbox-guest-x11 vlc vlc-nox
  vlc-plugin-notify vlc-plugin-pulse wine wine64 winetricks xchat xchat-common
  xdg-user-dirs-gtk xnest xorg xserver-xorg xserver-xorg-core
  xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-mouse
  xserver-xorg-input-synaptics xserver-xorg-input-vmmouse
  xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-ati
  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-intel
  xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-modesetting xserver-xorg-video-neomagic
  xserver-xorg-video-nouveau xserver-xorg-video-openchrome
  xserver-xorg-video-qxl xserver-xorg-video-r128 xserver-xorg-video-radeon
  xserver-xorg-video-savage xserver-xorg-video-siliconmotion
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-vesa xserver-xorg-video-vmware xsltproc yelp zenity
Die folgenden NEUEN Pakete werden installiert:
  lib32nss-mdns libatk1.0-0:i386 libavahi-client3:i386
  libavahi-common-data:i386 libavahi-common3:i386 libcairo2:i386
  libcomerr2:i386 libcups2:i386 libdrm2:i386 libegl1-mesa:i386 libgbm1:i386
  libgcrypt11:i386 libgdk-pixbuf2.0-0:i386 libgl1-mesa-glx:i386
  libglapi-mesa:i386 libgnutls26:i386 libgpg-error0:i386 libgraphite2-3:i386
  libgssapi-krb5-2:i386 libgtk2.0-0:i386 libharfbuzz0a:i386 libjasper1:i386
  libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386
  libllvm3.3:i386 libnspr4:i386 libnspr4-0d:i386 libnss3:i386 libnss3-1d:i386
  libp11-kit0:i386 libpango-1.0-0:i386 libpangocairo-1.0-0:i386
  libpangoft2-1.0-0:i386 libpixman-1-0:i386 libtasn1-6:i386 libudev1:i386
  libwayland-client0:i386 libwayland-server0:i386 libxcb-dri2-0:i386
  libxcb-glx0:i386 libxcb-render0:i386 libxcb-shape0:i386 libxcb-shm0:i386
  libxcb-xfixes0:i386 libxcomposite1:i386 libxcursor1:i386 libxinerama1:i386
  libxslt1.1:i386 libxxf86vm1:i386 tint2
0 aktualisiert, 52 neu installiert, 430 zu entfernen und 0 nicht aktualisiert.
Es müssen 16,9 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 1.093 MB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n]


This is in-acceptable, because I don't want to uninstall any of this packages.

I have insured that i386 architecture is enabled
Code: Select all
user@notebook-acer ~ $ dpkg --print-foreign-architectures
i386

and successfully installed e.g. wine and teamviewer.

How must I proceed to install "acroread"?

THX
c.monty
Level 1
Level 1
 
Posts: 42
Joined: Tue Apr 26, 2011 4:23 am

Linux Mint is funded by ads and donations.
 

Re: Installation "acroread" missing dependencies on 64bit

Postby nomko on Thu Jun 19, 2014 8:47 am

try installing this package using the terminal:
Code: Select all
sudo apt-get install ia32-libs

what happens then?
MSI GE70-2PE*Quad core Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel 4th Gen. Integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*Sitecom X5-N600 Router (WLR-5100)

Visit my website:
My personal website
User avatar
nomko
Level 9
Level 9
 
Posts: 2920
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Installation "acroread" missing dependencies on 64bit

Postby Monsta on Thu Jun 19, 2014 9:59 am

nomko wrote:what happens then?

Nothing - because there's no such package in LMDE.
Monsta
Level 9
Level 9
 
Posts: 2513
Joined: Fri Aug 19, 2011 3:46 am

Re: Installation "acroread" missing dependencies on 64bit

Postby Monsta on Thu Jun 19, 2014 10:07 am

c.monty wrote:
Code: Select all
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 acroread:i386 : Hängt ab von: libgtk2.0-0:i386 (>= 2.24.0) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Try to install one package at a time.
Run this and post the output:
Code: Select all
apt install libgtk2.0-0:i386
Monsta
Level 9
Level 9
 
Posts: 2513
Joined: Fri Aug 19, 2011 3:46 am

Re: Installation "acroread" missing dependencies on 64bit

Postby c.monty on Thu Jun 19, 2014 1:21 pm

Try to install one package at a time.
Run this and post the output:
Code: Select all
apt install libgtk2.0-0:i386


What's the strategy behind that?
When I try to install single packages, the installer will complain about other missing dependencies:
Code: Select all
sudo apt-get install libgtk2.0-0:i386
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libgtk2.0-0:i386 : Hängt ab von: libcups2:i386 (>= 1.6.0) soll aber nicht installiert werden
                    Hängt ab von: libgcrypt11:i386 (>= 1.4.5) soll aber nicht installiert werden
                    Hängt ab von: libgnutls26:i386 (>= 2.12.17-0) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


The idea of using an installer is that all dependencies are resolved automatically.
But here, the dependencies are resolved by proposing to uninstall cinnamon etc.

THX
c.monty
Level 1
Level 1
 
Posts: 42
Joined: Tue Apr 26, 2011 4:23 am

Re: Installation "acroread" missing dependencies on 64bit

Postby Monsta on Thu Jun 19, 2014 1:33 pm

c.monty wrote:What's the strategy behind that?

To go down the dependency chain, hopefully finding the package at its end that introduces some conflict.

c.monty wrote:
Code: Select all
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libgtk2.0-0:i386 : Hängt ab von: libcups2:i386 (>= 1.6.0) soll aber nicht installiert werden
                    Hängt ab von: libgcrypt11:i386 (>= 1.4.5) soll aber nicht installiert werden
                    Hängt ab von: libgnutls26:i386 (>= 2.12.17-0) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Now you can try installing one of these three packages, for example, libcups2:i386.
Monsta
Level 9
Level 9
 
Posts: 2513
Joined: Fri Aug 19, 2011 3:46 am

Re: Installation "acroread" missing dependencies on 64bit

Postby c.monty on Thu Jun 19, 2014 3:05 pm

Monsta wrote:
c.monty wrote:What's the strategy behind that?


Now you can try installing one of these three packages, for example, libcups2:i386.


I don't see why this should work... and my concern is confirmed:
Code: Select all
sudo apt-get install libgnutls26:i386
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libgnutls26:i386 : Hängt ab von: libgcrypt11:i386 (>= 1.5.1) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

user@notebook-acer ~ $ sudo apt-get install libgcrypt11:i386
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  cheese-common geany-common git-man gnome-control-center-data libaudclient2
  libbit-vector-perl libbonoboui2-common libcarp-clan-perl
  libclass-data-inheritable-perl libcommon-sense-perl libconfig-general-perl
  libcrack2 libcrypt-openssl-bignum-perl libcrypt-openssl-rsa-perl
  libdata-random-perl libdate-calc-perl liberror-perl libextutils-depends-perl
  libextutils-pkgconfig-perl libfile-which-perl libfont-ttf-perl libgd-perl
  libgee2 libgnomeui-common libgoocanvas-common libgphoto2-6 libgphoto2-port10
  libhttp-server-simple-perl libjson-perl libjson-xs-perl liblog-log4perl-perl
  libmono-sqlite4.0-cil
  libmono-system-runtime-serialization-formatters-soap4.0-cil
  libmono-system-web-applicationservices4.0-cil
  libmono-system-web-services4.0-cil libmono-system-web4.0-cil
  libmono-web4.0-cil libmouse-perl libnet-dropbox-api-perl libnet-oauth-perl
  libpath-class-perl libpdf-api2-perl libproc-processtable-perl
  libproc-simple-perl libpwquality-common libpwquality1 libreadonly-perl
  libset-intspan-perl libsocialweb-client2 libsocialweb-common
  libsort-naturally-perl libtiff-tools libtry-tiny-perl libwine-gecko-2.21
  libwww-mechanize-perl libxmmsclient6 libxnvctrl0 perlmagick
  ttf-ancient-fonts
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  libgpg-error0:i386 tint2
Vorgeschlagene Pakete:
  rng-tools:i386
Die folgenden Pakete werden ENTFERNT:
  apt-file apt-transport-https apturl banshee brasero ca-certificates-java
  caribou cinnamon cinnamon-bluetooth cinnamon-control-center
  cinnamon-screensaver cinnamon-session cinnamon-settings-daemon colord
  command-not-found conky-all conky-manager cryptsetup cryptsetup-bin cups
  cups-client cups-daemon cups-driver-gutenprint cups-filters cups-pdf
  cups-pk-helper cups-ppdc curl davfs2 default-jre default-jre-headless docky
  ecryptfs-utils eog espeak evince ffmpegthumbnailer file-roller gcalctool
  gconf-service gconf2 gcr gdebi geany gedit ghostscript ghostscript-cups
  ghostscript-x gimp gir1.2-caribou-1.0 gir1.2-cinnamondesktop-3.0
  gir1.2-clutter-1.0 gir1.2-gconf-2.0 gir1.2-gkbd-3.0
  gir1.2-gnomebluetooth-1.0 gir1.2-gnomedesktop-3.0 gir1.2-gtk-3.0
  gir1.2-gtkclutter-1.0 gir1.2-muffin-3.0 gir1.2-networkmanager-1.0
  gir1.2-peas-1.0 gir1.2-soup-2.4 gir1.2-vte-2.90 gir1.2-webkit-3.0 git
  gkbd-capplet gksu glib-networking gnome-bluetooth gnome-calculator
  gnome-disk-utility gnome-icon-theme gnome-icon-theme-symbolic gnome-keyring
  gnome-media gnome-panel gnome-screenshot gnome-session-bin
  gnome-settings-daemon gnome-system-monitor gnome-terminal
  gnome-themes-standard gnupg-agent gnupg2 gparted gpgsm grsync gscan2pdf
  gstreamer0.10-gconf gstreamer0.10-gnomevfs gstreamer0.10-nice
  gstreamer0.10-plugins-bad gstreamer0.10-plugins-good
  gstreamer0.10-pulseaudio gstreamer1.0-clutter gstreamer1.0-nice
  gstreamer1.0-plugins-bad gstreamer1.0-plugins-good gstreamer1.0-pulseaudio
  gthumb gtk2-engines gtk2-engines-aurora gtk2-engines-candido
  gtk2-engines-murrine gtk2-engines-pixbuf gucharmap gvfs gvfs-backends
  gvfs-daemons gvfs-libs hplip icedtea-6-plugin icedtea-7-plugin icedtea-netx
  icedtea-plugin ideviceinstaller intel-linux-graphics-installer iputils-ping
  libasound2-plugins libatk-wrapper-java libatk-wrapper-java-jni libavformat54
  libbonoboui2-0 libbrasero-media3-1 libcanberra-gtk0 libcanberra-gtk3-0
  libcanberra-pulse libcaribou0 libcinnamon-control-center1
  libcinnamon-desktop0 libclutter-1.0-0 libclutter-gst-2.0-0
  libclutter-gtk-1.0-0 libcmis-0.3-3 libcryptsetup4 libcups2 libcupscgi1
  libcupsfilters1 libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3
  libcurl3-gnutls libecal-1.2-15 libedataserver-1.2-17 libespeak1
  libevdocument3-4 libevview3-3 libfarstream-0.1-0 libffmpegthumbnailer4
  libfluidsynth1 libgail-3-0 libgail-common libgail18 libgconf2-4
  libgconf2.0-cil libgcr-3-1 libgcr-base-3-1 libgcr-ui-3-1 libgcrypt11
  libgimp2.0 libgksu2-0 libglade2-0 libgmime-2.6-0 libgnome-bluetooth11
  libgnome-desktop-2-17 libgnome-desktop-3-7 libgnome-keyring0
  libgnome-keyring1.0-cil libgnome-media-profiles-3.0-0 libgnome2-0
  libgnome2-canvas-perl libgnome2-common libgnome2-gconf-perl libgnome2-perl
  libgnome2-vfs-perl libgnome2-wnck-perl libgnomecanvas2-0
  libgnomedesktop2.20-cil libgnomekbd8 libgnomeui-0 libgnomevfs2-0
  libgnomevfs2-common libgnutls-openssl27 libgnutls26 libgoa-1.0-0
  libgoo-canvas-perl libgoocanvas3 libgpgme11 libgpod4 libgs9 libgssdp-1.0-3
  libgtk-3-0 libgtk-3-bin libgtk-sharp-beans-cil libgtk2-ex-simple-list-perl
  libgtk2-imageview-perl libgtk2-perl libgtk2-unique-perl libgtk2.0-0
  libgtk2.0-bin libgtk2.0-cil libgtkglext1 libgtkimageview0 libgtkmm-2.4-1c2a
  libgtkmm-3.0-1 libgtksourceview-3.0-1 libgtkspell0 libgucharmap-2-90-7
  libgupnp-1.0-4 libgupnp-igd-1.0-4 libgweather-3-3 libhdb9-heimdal
  libimobiledevice-utils libimobiledevice4 libindicator3-7 libkdc2-heimdal
  libldap-2.4-2 libldb1 libloudmouth1-0 libmetacity-private0a
  libmono-addins-gui0.2-cil libmtp-runtime libmtp9 libmuffin0
  libnautilus-extension1a libnemo-extension1 libneon27-gnutls libnice10
  libnm-glib-vpn1 libnm-glib4 libnm-gtk0 libnm-util2 libnotify0.4-cil
  libopencv-calib3d2.4 libopencv-contrib2.4 libopencv-features2d2.4
  libopencv-highgui2.4 libopencv-legacy2.4 libopencv-objdetect2.4
  libpam-systemd libpanel-applet-4-0 libpeas-1.0-0 libpulse-mainloop-glib0
  libpulse0 libpulsedsp libpurple0 libquvi7 libraptor2-0 librasqal3 librdf0
  libreoffice-base libreoffice-base-core libreoffice-calc libreoffice-core
  libreoffice-draw libreoffice-gnome libreoffice-gtk libreoffice-help-en-us
  libreoffice-impress libreoffice-math libreoffice-writer librest-0.7-0
  librsvg2-2.18-cil librtmp0 libsane libsane-hpaio libsane-perl
  libsdl-image1.2 libsdl1.2debian libsecret-1-0 libseed-gtk3-0 libsexy2
  libslv2-9 libsmbclient libsoup-gnome2.4-1 libsoup2.4-1 libspectre1 libssh2-1
  libsystemd-journal0 libtotem-plparser17 libtotem0 libunique-1.0-0
  libvte-2.90-9 libvte9 libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 libwine
  libwnck-3-0 libwnck2.20-cil libwnck22 libxslt1.1 libyelp0 mdm metacity
  mint-artwork-debian mint-common mint-meta-codecs mint-meta-debian-cinnamon
  mint-meta-debian-codecs mint-meta-debian-core mintbackup mintinstall
  mintnanny mintsources mintstick mintsystem mintupdate-debian mintupload
  mintwelcome mousetweaks nemo nemo-fileroller nemo-share network-manager
  network-manager-gnome network-manager-pptp network-manager-pptp-gnome
  notification-daemon ntfs-3g openjdk-6-jre openjdk-6-jre-headless
  openjdk-6-jre-lib openjdk-7-jre openjdk-7-jre-headless openjdk-7-jre-lib
  pidgin pinentry-gtk2 plymouth-x11 policykit-1-gnome printer-driver-c2050
  printer-driver-c2esp printer-driver-escpr printer-driver-foo2zjs
  printer-driver-gutenprint printer-driver-hpcups printer-driver-pnm2ppa
  printer-driver-postscript-hp printer-driver-ptouch printer-driver-sag-gdi
  printer-driver-splix pulseaudio pulseaudio-esound-compat
  pulseaudio-module-bluetooth pulseaudio-module-x11 pulseaudio-utils
  python-aptdaemon.gtk3widgets python-cups python-cupshelpers python-gconf
  python-glade2 python-gtk2 python-ldb python-lxml python-notify python-opencv
  python-pyatspi python-pycurl python-samba python-sexy python-vte
  python-webkit samba samba-common-bin samba-dsdb-modules samba-libs
  sane-utils scdaemon seahorse shutter simple-scan smbclient synaptic
  system-config-printer system-config-printer-udev systemd telepathy-gabble
  telepathy-mission-control-5 testdisk tomboy totem totem-mozilla
  transmission-gtk upower vino virtualbox-guest-x11 vlc vlc-nox
  vlc-plugin-notify vlc-plugin-pulse wine wine64 winetricks xchat xchat-common
  xdg-user-dirs-gtk xnest xorg xserver-xorg xserver-xorg-core
  xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-mouse
  xserver-xorg-input-synaptics xserver-xorg-input-vmmouse
  xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-ati
  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-intel
  xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-modesetting xserver-xorg-video-neomagic
  xserver-xorg-video-nouveau xserver-xorg-video-openchrome
  xserver-xorg-video-qxl xserver-xorg-video-r128 xserver-xorg-video-radeon
  xserver-xorg-video-savage xserver-xorg-video-siliconmotion
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-vesa xserver-xorg-video-vmware xsltproc yelp zenity
Die folgenden NEUEN Pakete werden installiert:
  libgcrypt11:i386 libgpg-error0:i386 tint2
0 aktualisiert, 3 neu installiert, 430 zu entfernen und 0 nicht aktualisiert.
Es müssen 463 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 1.143 MB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n]


As you can see, with the latest depending lib the uninstallation would be triggered again.
c.monty
Level 1
Level 1
 
Posts: 42
Joined: Tue Apr 26, 2011 4:23 am

Re: Installation "acroread" missing dependencies on 64bit

Postby Monsta on Fri Jun 20, 2014 12:39 am

Post the output of:
Code: Select all
apt policy libgcrypt11 libgcrypt11:i386
Monsta
Level 9
Level 9
 
Posts: 2513
Joined: Fri Aug 19, 2011 3:46 am

Re: Installation "acroread" missing dependencies on 64bit

Postby killer de bug on Fri Jun 20, 2014 10:42 am

And post also the content of
Code: Select all
inxi -r
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1924
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Re: Installation "acroread" missing dependencies on 64bit

Postby c.monty on Fri Jun 20, 2014 2:23 pm

Code: Select all
user@notebook-acer ~ $ apt policy libgcrypt11 libgcrypt11:i386
libgcrypt11:
  Installiert:           1.5.3-4
  Installationskandidat: 1.5.3-4
  Versionstabelle:
 *** 1.5.3-4 0
        100 /var/lib/dpkg/status
     1.5.3-2 0
        600 http://linuxmint-apt.killerhorse.eu/debian/latest/ testing/main amd64 Packages
libgcrypt11:i386:
  Installiert:           (keine)
  Installationskandidat: 1.5.3-2
  Versionstabelle:
     1.5.3-2 0
        600 http://linuxmint-apt.killerhorse.eu/debian/latest/ testing/main i386 Packages


Code: Select all
user@notebook-acer ~ $ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list.d/conky-manager.list
           deb http://ppa.launchpad.net/teejee2008/ppa/ubuntu trusty main
           deb-src http://ppa.launchpad.net/teejee2008/ppa/ubuntu trusty main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com debian main upstream import
           deb http://linuxmint-apt.killerhorse.eu/debian/latest/ testing main contrib non-free
           deb http://linuxmint-apt.killerhorse.eu/debian/latest/security testing/updates main contrib non-free
           deb http://linuxmint-apt.killerhorse.eu/debian/latest/multimedia testing main non-free
           deb http://extra.linuxmint.com debian main
c.monty
Level 1
Level 1
 
Posts: 42
Joined: Tue Apr 26, 2011 4:23 am

Re: Installation "acroread" missing dependencies on 64bit

Postby killer de bug on Sat Jun 21, 2014 4:50 am

Start by removing these ppa please. They have nothing to do here and probably messed up your install.
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1924
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Re: Installation "acroread" missing dependencies on 64bit

Postby c.monty on Sat Jun 21, 2014 9:12 am

Code: Select all
deb http://ppa.launchpad.net/teejee2008/ppa/ubuntu trusty main

is the repo for "Conky-Manager"
-> I have disabled it.

Code: Select all
http://linuxmint-apt.killerhorse.eu/debian/latest/

is a mirror LMDE repo and I don't see necessity to remove it.

So, obviously there are dependencies for 32bit libs that cannot be resolved.
I have successfully installed Teamviewer and Wine, both 32bit applications...

What is the root cause for this error when installing Acroread?

Who has installed Acroread on 64bit with LMDE UP8?

I didn't find any success story for Acroread for Debian Wheezy, therefore I have some doubts that this application would ever run on LMDE 64bit.
c.monty
Level 1
Level 1
 
Posts: 42
Joined: Tue Apr 26, 2011 4:23 am

Re: Installation "acroread" missing dependencies on 64bit

Postby Monsta on Sun Jun 22, 2014 4:37 am

c.monty wrote:
Code: Select all
user@notebook-acer ~ $ apt policy libgcrypt11 libgcrypt11:i386
libgcrypt11:
  Installiert:           1.5.3-4
  Installationskandidat: 1.5.3-4
  Versionstabelle:
 *** 1.5.3-4 0
        100 /var/lib/dpkg/status
     1.5.3-2 0
        600 http://linuxmint-apt.killerhorse.eu/debian/latest/ testing/main amd64 Packages
libgcrypt11:i386:
  Installiert:           (keine)
  Installationskandidat: 1.5.3-2
  Versionstabelle:
     1.5.3-2 0
        600 http://linuxmint-apt.killerhorse.eu/debian/latest/ testing/main i386 Packages

Well there's your problem right here.
These packages must be the same version in 32-bit and 64-bit - but you have a newer version of 64-bit libgcrypt11 (1.5.3-4 instead of 1.5.3-2). You've probably got it from Debian Testing repo and forgot about it.

Downgrade it to 1.5.3-2:
Code: Select all
apt install libgcrypt11=1.5.3-2
Monsta
Level 9
Level 9
 
Posts: 2513
Joined: Fri Aug 19, 2011 3:46 am

Re: Installation "acroread" missing dependencies on 64bit

Postby c.monty on Mon Jun 23, 2014 10:20 am

That makes sense... I will verify this for any missing/required lib and repair it accordingly.

I'll keep you updated on the progress.

THX

Update:
Problem solved.
c.monty
Level 1
Level 1
 
Posts: 42
Joined: Tue Apr 26, 2011 4:23 am

Re: Installation "acroread" missing dependencies on 64bit

Postby Monsta on Tue Jun 24, 2014 1:31 am

c.monty wrote:Problem solved.

Good, now you can edit the thread title, marking the thread as "solved".
Monsta
Level 9
Level 9
 
Posts: 2513
Joined: Fri Aug 19, 2011 3:46 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 2 guests