docky

Questions about applications and software
Forum rules
Before you post please read this

docky

Postby jesica on Sun Dec 26, 2010 8:12 am

I haven installed docky on my latop and pc and when i start it, it gives a a black screen ontop of docky

what can be wrong with that
Image

My Linux Counter number # 566377
Mate
IT Ninja
Happy apt-get-ing!
Linux Mint Donar # 2159


Security is the separation of an asset from a threat.
User avatar
jesica
Level 9
Level 9
 
Posts: 2543
Joined: Sat Jul 18, 2009 3:54 am
Location: South Africa

Linux Mint is funded by ads and donations.
 

Re: docky

Postby rivenathos on Sun Dec 26, 2010 8:27 am

I am thinking this may be fixed by either Metacity Compositing or Compiz. One or the other may need to be enabled. I do not currently use Docky, so I am tossing out ideas.
Debian 7 with GNOME 64-bit
User avatar
rivenathos
Level 6
Level 6
 
Posts: 1066
Joined: Wed May 06, 2009 7:32 am
Location: USA

Re: docky

Postby jesica on Sun Dec 26, 2010 8:35 am

sorry i have no idea what that means
Image

My Linux Counter number # 566377
Mate
IT Ninja
Happy apt-get-ing!
Linux Mint Donar # 2159


Security is the separation of an asset from a threat.
User avatar
jesica
Level 9
Level 9
 
Posts: 2543
Joined: Sat Jul 18, 2009 3:54 am
Location: South Africa

Re: docky

Postby Aging Technogeek on Sun Dec 26, 2010 9:04 am

Docky needs a composited desktop to run and display correctly. In Gnome, either enable Compiz by going to Menu=>Preferences=>Appearance=>Visual Effects and checking "Normal" or higher, or gor to Menu=>Preferences=>Desktop Settings and, in Windows=>Performance, check "Use Gnome Compositing"

You may also find that you get the same black outline for a few seconds when you boot Mint. Or, you could get a notification box saying that Docky requires desktop compositing to work properly. If this is too annoying, you will need to put in a delay before Docky starts.

Open Gedit and type "sleep 10 && docky" ( without the quotes). Save this to your /home folder in a file labeled ".dockysh" (again, no quotes). Right click the file and open Properties. In the Permissions section, make sure the box for "Allow executing the file as a program" is checked

Open Startup Applications (Menu=.Preferences=>Startup Applications), find the entry for Docky, click it to select it, click Edit, and change the command to read "/home/your username/.dockysh.

Now, when you boot into Mint, the desktop compositor will have time to start before Docky starts so you have no black outline at startup. :D
Image

Registered Linux User 483387
User avatar
Aging Technogeek
Level 13
Level 13
 
Posts: 4605
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: docky

Postby rivenathos on Sun Dec 26, 2010 9:53 am

Yes, Aging Technogeek explained it in more detail. :D
Debian 7 with GNOME 64-bit
User avatar
rivenathos
Level 6
Level 6
 
Posts: 1066
Joined: Wed May 06, 2009 7:32 am
Location: USA

Re: docky

Postby jesica on Mon Dec 27, 2010 2:41 pm

thanks for the info

i also saw on ubuntu forums this fix works

but i cant get the Visual Effects tab

I use LMDE
Image

My Linux Counter number # 566377
Mate
IT Ninja
Happy apt-get-ing!
Linux Mint Donar # 2159


Security is the separation of an asset from a threat.
User avatar
jesica
Level 9
Level 9
 
Posts: 2543
Joined: Sat Jul 18, 2009 3:54 am
Location: South Africa

Re: docky

Postby GeneC on Mon Dec 27, 2010 3:10 pm

Jessica

I had the same problem but with AWN dock. I think Docky may be the same. Aging Technogeek explained it in his post. Your right LMDE doesn't have the settings in "Appearance" but he also mentioned ...
or go to Menu=>Preferences=>Desktop Settings and, in Windows=>Performance, check "Use Gnome Compositing"


That worked for me with AWN in LMDE.. I suspect it will with Docky.

Good Luck!
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon/XFCE)
Sparky XFCE (Debian Testing)
Sparky Cin 2.2 (SID)
OpenSUSE 13.1 (Gnome)
Evolve OS (Budgie)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1559
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: docky

Postby jesica on Tue Dec 28, 2010 1:02 am

okay

sorry :(

it did work thanks :mrgreen:
Image

My Linux Counter number # 566377
Mate
IT Ninja
Happy apt-get-ing!
Linux Mint Donar # 2159


Security is the separation of an asset from a threat.
User avatar
jesica
Level 9
Level 9
 
Posts: 2543
Joined: Sat Jul 18, 2009 3:54 am
Location: South Africa

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 2 guests