Can't start Evolution - DBUS error

Questions about applications and software
Forum rules
Before you post please read this

Can't start Evolution - DBUS error

Postby windy_miller on Fri Feb 04, 2011 5:25 am

Hi all

I very occasionally use Evolution on my home PC because it lets me access my work Microsoft Exchange email using the Webmail settings

It's probably a couple of months since I last used it but on trying today the only component I can get to start is the Account setup.

On trying to start the actual email client I see the error message below. I have deleted the one account I had setup through the setup page but I still get this error.

I have googled around and I see lots of bug reports but no fixes / workarounds. Can anybody help me get this going please?

Thanks


kevin@kev-laptop ~ $ evolution --component=mail

(evolution:2290): Unique-DBus-WARNING **: Error while sending message: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
windy_miller
Level 1
Level 1
 
Posts: 48
Joined: Mon Nov 30, 2009 8:39 am

Linux Mint is funded by ads and donations.
 

Re: Can't start Evolution - DBUS error

Postby GSXR750L on Fri Feb 04, 2011 10:31 am

Not knowing how you should really fix this but I would try going into your home folder and viewing the hidden files, delete or rename the .evolution folder, then reinstall the evolution package from Package Manager and then start from scratch setting up evolution again with your details and an evolution backup if you made one in the past.
GSXR750L
Level 3
Level 3
 
Posts: 167
Joined: Fri Nov 27, 2009 9:31 pm

Re: Can't start Evolution - DBUS error

Postby Habitual on Fri Feb 04, 2011 1:33 pm

You could try this:
Shutdown Evolution.
Open a terminal and type
Code: Select all
mv ~/.dbus ~/.dbus.org


Start Evolution.

If it doesn't work simply mv it back with
Code: Select all
mv ~/.dbus.org ~/.dbus


Please let us know
What's a landing but a take off in reverse?
My DorkBlog
User avatar
Habitual
Level 8
Level 8
 
Posts: 2002
Joined: Sun Nov 21, 2010 8:31 pm
Location: Slackware

Re: Can't start Evolution - DBUS error

Postby windy_miller on Mon Feb 07, 2011 6:14 am

Thanks for responses. Went away for the weekend but am back now so can look at this some more.

Weird thing was that after trying seemingly unsuccessfully to start Evolution i went away to make (more) coffee and returned to find a number of Evolution sessions opened. They must have been sat there trying to start even so seemingly have failed and returned to command prompt.

Anyway. I recreated the account I had in there previously but could not apparently connect to and authenticate against the server .... :roll:

Will perhaps try a couple of things as suggested and perhaps turn off Firewall temporarily as well just to see what happens.

Back laters ...
windy_miller
Level 1
Level 1
 
Posts: 48
Joined: Mon Nov 30, 2009 8:39 am


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 3 guests