Error while trying to install Iceweasel 4.

Questions about applications and software
Forum rules
Before you post please read this

Error while trying to install Iceweasel 4.

Postby Imagus on Tue Mar 29, 2011 7:18 am

Can anyone please tell me how to install Iceweasel 4? I followed the instructions on www.geticeweasel.org (apt-get update && apt-get install iceweasel), but the terminal gives me the following message:

=======
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
iceweasel : Depends: xulrunner-2.0 (>= 2.0) but it is not going to be installed
E: Broken packages
=======

What do I do this fix this? Also, will Iceweasel 4 totally replace my current version 3.5.17? Isn't it possible to have it installed separately so I can still keep my previous version?

I do NOT want Firefox 4, just Iceweasel, thank you.
User avatar
Imagus
Level 3
Level 3
 
Posts: 118
Joined: Tue Aug 28, 2007 2:33 pm
Location: Belgium

Linux Mint is funded by ads and donations.
 

Re: Error while trying to install Iceweasel 4.

Postby wayne128 on Tue Mar 29, 2011 8:45 am

I used this procedure on
http://mozilla.debian.net/

However I ignore the key.
actual procedure I used:

1. add the following entry in /etc/apt/sources.list

deb http://mozilla.debian.net/ squeeze-backports iceweasel-4.0

2. Open Synaptic, reload, search iceweasel, I can see the installed version 3.x, and the 4.0-1 version in the repos.
3. then I click the iceweasel, Mark for reinstallation, Apply, all the dependencies will be installed.
Last edited by wayne128 on Tue Mar 29, 2011 6:04 pm, edited 1 time in total.
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

Re: Error while trying to install Iceweasel 4.

Postby craigevil on Tue Mar 29, 2011 1:45 pm

Yes you can have both versions see:
glandium.org » Blog Archive » Iceweasel 4.0 beta 1 preliminary packages for Debian, and a nice trick : http://glandium.org/blog/?p=1032

The version in Debian experimental is newer than the version at mozilla.debian.net

Personally I upgraded Iceweasel and left Firefox at the current 3.6.16.

Firefox: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16

$ apt-cache policy iceweasel
iceweasel:
Installed: 4.0-3
Candidate: 4.0-3
Version table:
*** 4.0-3 0
1 http://mirrors.kernel.org/debian/ experimental/main i386 Packages
100 /var/lib/dpkg/status
4.0~rc1-1 0
500 http://mozilla.debian.net/ experimental/iceweasel-4.0 i386 Packages
3.5.18-1 0
500 http://mirrors.kernel.org/debian/ unstable/main i386 Packages
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: Error while trying to install Iceweasel 4.

Postby wayne128 on Tue Mar 29, 2011 8:40 pm

craigevil wrote:$
iceweasel:
Installed: 4.0-3
Candidate: 4.0-3
Version table:
*** 4.0-3 0
1 http://mirrors.kernel.org/debian/ experimental/main i386 Packages
100 /var/lib/dpkg/status
4.0~rc1-1 0
500 http://mozilla.debian.net/ experimental/iceweasel-4.0 i386 Packages
3.5.18-1 0
500 http://mirrors.kernel.org/debian/ unstable/main i386 Packages


Thanks craigevil for the procedure using experimental

Now I have 4.0.3 and it is very fast
$ apt-cache policy iceweasel
Installed: 4.0-3
Candidate: 4.0-3
Version table:
*** 4.0-3 0
1 http://mirrors.kernel.org/debian/ experimental/main amd64 Packages
100 /var/lib/dpkg/status
3.5.17-1 0
500 http://ftp.jp.debian.org/debian/ wheezy/main amd64 Packages
500 http://http.us.debian.org/debian/ wheezy/main amd64 Packages
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

Re: Error while trying to install Iceweasel 4.

Postby middling on Wed Mar 30, 2011 4:11 pm

Imagus wrote:What do I do this fix this?


You need to upgrade your libcairo2. It's up there in the mozilla.debian.net repository. You may have to install it manually.

Go to http://mozilla.debian.net/dists and choose the distro you are tracking (i've pinned mine to Debian Stable/Squeeze for the time being) then the iceweasel-4.0 directory, then your architecture and download the libcairo2_1.10.2-1.1 package. For instance the Debian Squeeze x64 version is located here.

Install it using the terminal command
Code: Select all
sudo dpkg -i Downloads/libcairo2_1.10.2-1.1*


Then follow the commands from mozilla.debian.net to install Iceweasel 4.0.

I held off on installing for a while because the Debian libcairo2 packages don't usually contain the Ubuntu patches that give nice font rendering, but after some research it seems that Debian now does include them and, indeed, after installing Iceweasel 4.0 my fonts render as nicely as ever.


Also, will Iceweasel 4 totally replace my current version 3.5.17? Isn't it possible to have it installed separately so I can still keep my previous version?


It should replace the existing Iceweasel version. The LMDE version of Firefox (3.6.13) wont be affected although you can't run them at the same time.
middling
Level 1
Level 1
 
Posts: 9
Joined: Sat Mar 26, 2011 3:45 am

Re: Error while trying to install Iceweasel 4.

Postby Imagus on Tue Apr 05, 2011 4:31 am

Thank you all for the replies. I have succesfully installed IW4 just by following the instructions on debian.net after first upgrading libcairo2.

I have been using IW4 for a few days now, and I think I'm going to restore a disk image of my LMDE partition with IW3 because this new IW4 is soooo slow it's just not bearable. To make things worse, also Icedove has become much slower than before. It's not very fun to have to watch windows being drawn on the screen when you click on a link or an article in Icedove.

I admit I am thinking about switching back to Windows because Mint just never gives me the same "snappiness" like Windows does, and this latest experience with IW4 only made things worse.

It's actually funny when you think about it: Windows 7 runs very smooth and fast on my machine, but Mint (or any other Linux distro) always manages to slow things down terribly, even with 2 Gb ram at its disposal.
User avatar
Imagus
Level 3
Level 3
 
Posts: 118
Joined: Tue Aug 28, 2007 2:33 pm
Location: Belgium

Re: Error while trying to install Iceweasel 4.

Postby Yeticannotski on Sun Apr 10, 2011 6:14 pm

middling wrote: Go to http://mozilla.debian.net/dists and choose the distro you are tracking (i've pinned mine to Debian Stable/Squeeze for the time being) then the iceweasel-4.0 directory, then your architecture and download the libcairo2_1.10.2-1.1 package. For instance the Debian Squeeze x64 version is located here.

Install it using the terminal command
Code: Select all
sudo dpkg -i Downloads/libcairo2_1.10.2-1.1*




Thanks!
Yeticannotski
Level 1
Level 1
 
Posts: 15
Joined: Mon Mar 14, 2011 5:34 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 1 guest