Remove Epiphany?

Questions about applications and software
Forum rules
Before you post please read this

Remove Epiphany?

Postby ScoobyDan on Sun Apr 10, 2011 3:37 am

This morning I did my daily:

Code: Select all
sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade


This resulted in:

Code: Select all
The following packages have been kept back:
  epiphany-browser libclutter-1.0-0 libseed0 libssl-dev libssl0.9.8 openssl
The following packages will be upgraded:
  binutils cpp-4.4 cruft epiphany-browser-data g++-4.4 gcc-4.4 gcc-4.4-base
  gstreamer0.10-alsa gstreamer0.10-plugins-base
  gstreamer0.10-plugins-really-bad gstreamer0.10-tools gstreamer0.10-x
  libatk1.0-0 libatk1.0-data libgssdp-1.0-2 libgssglue1
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libgudev-1.0-0
  libgupnp-1.0-3 libjson-glib-1.0-0 libpango1.0-0 libpolkit-agent-1-0
  libpolkit-backend-1-0 libpolkit-gobject-1-0 libstdc++6-4.4-dev libudev0
  libupower-glib1 libwebkit-1.0-2 libwebkit-1.0-common policykit-1
  python-gst0.10 udev upower
34 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
Need to get 40.0 MB of archives.
After this operation, 3,662 kB of additional disk space will be used.
Do you want to continue [Y/n]?


I accepted these updates, which I note included epiphany-browser-data. Next came the dist-upgrade selection:

Code: Select all
The following packages will be REMOVED:
  epiphany-browser gir1.0-clutter-1.0 gir1.0-freedesktop gir1.0-glib-2.0
  gir1.0-gstreamer-0.10 gir1.0-gtk-2.0 gir1.0-json-glib-1.0 gnome-core
  libseed0
The following NEW packages will be installed:
  gir1.2-freedesktop gir1.2-glib-2.0 gir1.2-gstreamer-0.10
  gir1.2-json-glib-1.0 gir1.2-pango-1.0 libcairo-gobject2
  libclutter-1.0-common libgirepository-1.0-1 libssl-doc libssl1.0.0
The following packages will be upgraded:
  libclutter-1.0-0 libssl-dev libssl0.9.8 openssl
4 upgraded, 10 newly installed, 9 to remove and 0 not upgraded.
Need to get 8,491 kB of archives.
After this operation, 1,884 kB of additional disk space will be used.
Do you want to continue [Y/n]?


Which wants to remove epiphany and gnome-core :shock:

Is it safe to allow this? I don't use epiphany (I prefer Chrome), but I don't want this removal to affect something else.

Many thanks for the advice.

Daniel
ScoobyDan
Level 1
Level 1
 
Posts: 8
Joined: Thu Feb 10, 2011 5:07 am
Location: West Sussex, England

Linux Mint is funded by ads and donations.
 

Re: Remove Epiphany?

Postby JasonLG on Sun Apr 10, 2011 4:38 am

No go ahead if you don't use a program get rid of it.
"I see" said the blind man to the deaf man who stuck his wooden leg out the window to check the weather.
JasonLG
Level 7
Level 7
 
Posts: 1624
Joined: Thu May 20, 2010 9:15 pm
Location: Polk City, Iowa USA

Re: Remove Epiphany?

Postby Jaime Frontero on Sun Apr 10, 2011 5:24 am

JasonLG wrote:No go ahead if you don't use a program get rid of it.


gnome-core??? i use that.

(sorry for the redundant thread above ["gnome-core removed in latest updates?"], but i'll leave it...)
Jaime Frontero
Level 1
Level 1
 
Posts: 23
Joined: Sat Feb 19, 2011 4:44 pm

Re: Remove Epiphany?

Postby Dr.m0x on Sun Apr 10, 2011 6:35 am

I removed gnome-core without any ill effect. It was for the same reason - to remove epiphany and evolution. Gnome-core is the gnome desktop and various "default" gnome apps.

Gnome-session is the meta package which installs the bare bones gnome desktop. Obviously you don't want to remove that if you want to log into gnome desktop.

Gnome-core is perfectly safe to remove however.

Sent from my Android baby.
Image
User avatar
Dr.m0x
Level 3
Level 3
 
Posts: 117
Joined: Thu Nov 25, 2010 4:12 am

Re: Remove Epiphany?

Postby zerozero on Sun Apr 10, 2011 6:55 am

ScoobyDan, one should mention when asking these questions that is running a self-made LMDE: in this case one pointing to sid repos
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: Remove Epiphany?

Postby craig10x on Sun Apr 10, 2011 9:29 am

I had done those updates and i think what it did was replace epiphany with an newer version that is why it removed the old one :wink:
craig10x
Level 7
Level 7
 
Posts: 1502
Joined: Fri Jul 03, 2009 12:44 pm

Re: Remove Epiphany?

Postby ScoobyDan on Sun Apr 10, 2011 11:12 am

zerozero wrote:ScoobyDan, one should mention when asking these questions that is running a self-made LMDE: in this case one pointing to sid repos


zerozero,

I don't quite know what you are referring to: The LMDE I am running is pretty much stock - I am using the standard kernel, testing repos (not sid) - the only non-standard repos I have added are for conky and VirtualBox.

ScoobyDan
ScoobyDan
Level 1
Level 1
 
Posts: 8
Joined: Thu Feb 10, 2011 5:07 am
Location: West Sussex, England

Re: Remove Epiphany?

Postby zerozero on Sun Apr 10, 2011 12:40 pm

so i question myself :mrgreen:

- my vanilla LMDE:

Code: Select all
amadeu amadeu # cat /etc/apt/sources.list
deb http://packages.linuxmint-fr.net/ debian main upstream import backport romeo
deb-src http://packages.linuxmint-fr.net/ debian main upstream import backport romeo #Added by software-properties
deb http://ftp.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free


Code: Select all
Commit Log for Sun Apr 10 10:43:01 2011


Removed the following packages:
gir1.0-clutter-1.0
gir1.0-freedesktop
gir1.0-glib-2.0
gir1.0-gstreamer-0.10
gir1.0-gtk-2.0
gir1.0-json-glib-1.0

Upgraded the following packages:
cpp-4.4 (4.4.5-14) to 4.4.5-15
epiphany-browser (2.30.6-1) to 2.30.6-2
epiphany-browser-data (2.30.6-1) to 2.30.6-2
g++-4.4 (4.4.5-14) to 4.4.5-15
gcc-4.4 (4.4.5-14) to 4.4.5-15
gcc-4.4-base (4.4.5-14) to 4.4.5-15
gstreamer0.10-alsa (0.10.30-1) to 0.10.32-2
gstreamer0.10-plugins-base (0.10.30-1) to 0.10.32-2
gstreamer0.10-plugins-really-bad (0.10.20-0.1) to 0.10.21-0.0
gstreamer0.10-tools (0.10.32-4) to 0.10.32-6
gstreamer0.10-x (0.10.30-1) to 0.10.32-2
libatk1.0-0 (1.32.0-1+sid1) to 1.32.0-3
libatk1.0-data (1.32.0-1+sid1) to 1.32.0-3
libclutter-1.0-0 (1.2.12-3) to 1.6.10-3
libgssdp-1.0-2 (0.8.0-2) to 0.8.2-2
libgstreamer-plugins-base0.10-0 (0.10.30-1) to 0.10.32-2
libgstreamer0.10-0 (0.10.32-4) to 0.10.32-6
libgudev-1.0-0 (166-1) to 167-1
libgupnp-1.0-3 (0.14.0-2) to 0.14.1-2
libjson-glib-1.0-0 (0.10.2-2) to 0.12.0-3
libpango1.0-0 (1.28.3-1+squeeze2) to 1.28.3-6
libpolkit-agent-1-0 (0.99-3) to 0.101-2
libpolkit-backend-1-0 (0.99-3) to 0.101-2
libpolkit-gobject-1-0 (0.99-3) to 0.101-2
libseed0 (2.30.0-2) to 2.31.91-1+sid1
libstdc++6-4.4-dev (4.4.5-14) to 4.4.5-15
libudev0 (166-1) to 167-1
libupower-glib1 (0.9.8-2) to 0.9.9-2
libwebkit-1.0-2 (1.2.7-1) to 1.2.7-2
libwebkit-1.0-common (1.2.7-1) to 1.2.7-2
policykit-1 (0.99-3) to 0.101-2
python-gst0.10 (0.10.19-2) to 0.10.21-2
udev (166-1) to 167-1
upower (0.9.8-2) to 0.9.9-2

Installed the following packages:
gir1.2-atk-1.0 (1.32.0-3)
gir1.2-clutter-1.0 (1.6.10-3)
gir1.2-freedesktop (0.10.4-2)
gir1.2-glib-2.0 (0.10.4-2)
gir1.2-gstreamer-0.10 (0.10.32-6)
gir1.2-gtk-2.0 (0.6.5-10)
gir1.2-json-glib-1.0 (0.12.0-3)
gir1.2-pango-1.0 (1.28.3-6)
libcairo-gobject2 (1.10.0-1ubuntu2)
libclutter-1.0-common (1.6.10-3)
libgirepository-1.0-1 (0.10.4-2)


edit: and the output here in the laptop with LMDE-sid

Code: Select all
Commit Log for Sun Apr 10 11:59:26 2011


Removed the following packages:
epiphany-browser
gir1.0-clutter-1.0
gir1.0-freedesktop
gir1.0-glib-2.0
gir1.0-gstreamer-0.10
gir1.0-gtk-2.0
gir1.0-json-glib-1.0
gnome-core
libseed0

Upgraded the following packages:
apt (0.8.13) to 0.8.13.2
apt-utils (0.8.13) to 0.8.13.2
aptitude (0.6.3-3.2) to 0.6.3-4
avahi-daemon (0.6.29-1) to 0.6.30-1
base-files (6.1) to 6.3
bogofilter (1.2.2-2) to 1.2.2-3
bogofilter-bdb (1.2.2-2) to 1.2.2-3
bogofilter-common (1.2.2-2) to 1.2.2-3
busybox (1:1.18.4-1) to 1:1.18.4-2
conky-all (1.8.0-1) to 1.8.0-1.1
debhelper (8.1.2) to 8.1.3
dpkg (1.15.8.10) to 1.16.0.1
dpkg-dev (1.15.8.10) to 1.16.0.1
dselect (1.15.8.10) to 1.16.0.1
epiphany-browser-data (2.30.6-1) to 2.30.6-2
equinox-themes (1.30.2-2) to 1.30.2-3
faenza-icon-theme (0.9-0.1) to 0.9.1-0.1
fancontrol (1:3.2.0-1) to 1:3.3.0-1
gdm3 (2.30.5-8) to 2.30.5-9
ghostscript (9.01~dfsg-2) to 9.02~dfsg-1
ghostscript-cups (9.01~dfsg-2) to 9.02~dfsg-1
ghostscript-x (9.01~dfsg-2) to 9.02~dfsg-1
gnome-settings-daemon (2.30.2-2) to 2.30.2-3
grub-common (1.99~rc1-8) to 1.99~rc1-10
grub-pc (1.99~rc1-8) to 1.99~rc1-10
gs-common (9.01~dfsg-2) to 9.02~dfsg-1
gtk2-engines-equinox (1.30.2-2) to 1.40-1
guayadeque (0.2.9-2) to 0.2.9-2+b1
gwibber (2.91.92-1) to 3.0.0.1-1
gwibber-service (2.91.92-1) to 3.0.0.1-1
gwibber-service-facebook (2.91.92-1) to 3.0.0.1-1
gwibber-service-identica (2.91.92-1) to 3.0.0.1-1
gwibber-service-twitter (2.91.92-1) to 3.0.0.1-1
gwibber-themes (2.91.92-1) to 3.0.0.1-1
hal (0.5.14-5) to 0.5.14-6
iproute (20110107-2) to 20110315-1
iso-codes (3.24.2-1) to 3.25-1
libaprutil1 (1.3.10+dfsg-1) to 1.3.10+dfsg-2
libaprutil1-dbd-sqlite3 (1.3.10+dfsg-1) to 1.3.10+dfsg-2
libaprutil1-ldap (1.3.10+dfsg-1) to 1.3.10+dfsg-2
libavahi-client3 (0.6.29-1) to 0.6.30-1
libavahi-common-data (0.6.29-1) to 0.6.30-1
libavahi-common3 (0.6.29-1) to 0.6.30-1
libavahi-core7 (0.6.29-1) to 0.6.30-1
libavahi-glib1 (0.6.29-1) to 0.6.30-1
libavahi-gobject0 (0.6.29-1) to 0.6.30-1
libavahi-qt3-1 (0.6.29-1) to 0.6.30-1
libavahi-ui0 (0.6.29-1) to 0.6.30-1
libburn4 (1.0.4.pl00-1) to 1.0.6.pl00-1
libccid (1.4.2-2) to 1.4.3-1
libcln6 (1.3.1-2.1) to 1.3.1-2.2
libdbusmenu-qt2 (0.7.0-1) to 0.8.0-1
libdpkg-perl (1.15.8.10) to 1.16.0.1
libgexiv2-0 (0.2.2-3) to 0.2.2-4
libgpm2 (1.20.4-3.3) to 1.20.4-3.4
libgpod-common (0.7.95-2) to 0.8.0-2
libgpod4 (0.7.95-2) to 0.8.0-2
libgs9 (9.01~dfsg-2) to 9.02~dfsg-1
libgs9-common (9.01~dfsg-2) to 9.02~dfsg-1
libgudev-1.0-0 (166-1) to 167-1
libhal-storage1 (0.5.14-5) to 0.5.14-6
libhal1 (0.5.14-5) to 0.5.14-6
libieee1284-3 (0.2.11-6) to 0.2.11-7
libimlib2 (1.4.2-8+b2) to 1.4.4-1
libiodbc2 (3.52.6-5) to 3.52.7-2
libisofs6 (1.0.4-3) to 1.0.6-1
libltdl7 (2.2.6b-2) to 2.4-2
libnet-ssleay-perl (1.36-1) to 1.36-2
libnm-glib-vpn1 (0.8.3.998-1) to 0.8.3.999-1
libnm-glib2 (0.8.3.998-1) to 0.8.3.999-1
libnm-util1 (0.8.3.998-1) to 0.8.3.999-1
libpango1.0-0 (1.28.3-5) to 1.28.3-6
libphonon4 (4:4.6.0really4.4.4-3) to 4:4.6.0really4.5.0-2
libpkcs11-helper1 (1.07-1) to 1.08-1
libqtwebkit4 (2.1.0~2011week09-3) to 2.1.0~2011week13-1
libreoffice (1:3.3.2-1) to 1:3.3.2-2
libreoffice-base (1:3.3.2-1) to 1:3.3.2-2
libreoffice-base-core (1:3.3.2-1) to 1:3.3.2-2
libreoffice-calc (1:3.3.2-1) to 1:3.3.2-2
libreoffice-common (1:3.3.2-1) to 1:3.3.2-2
libreoffice-core (1:3.3.2-1) to 1:3.3.2-2
libreoffice-draw (1:3.3.2-1) to 1:3.3.2-2
libreoffice-emailmerge (1:3.3.2-1) to 1:3.3.2-2
libreoffice-filter-binfilter (1:3.3.2-1) to 1:3.3.2-2
libreoffice-filter-mobiledev (1:3.3.2-1) to 1:3.3.2-2
libreoffice-gnome (1:3.3.2-1) to 1:3.3.2-2
libreoffice-gtk (1:3.3.2-1) to 1:3.3.2-2
libreoffice-help-en-gb (1:3.3.2-1) to 1:3.3.2-2
libreoffice-impress (1:3.3.2-1) to 1:3.3.2-2
libreoffice-java-common (1:3.3.2-1) to 1:3.3.2-2
libreoffice-l10n-en-gb (1:3.3.2-1) to 1:3.3.2-2
libreoffice-math (1:3.3.2-1) to 1:3.3.2-2
libreoffice-report-builder-bin (1:3.3.2-1) to 1:3.3.2-2
libreoffice-style-crystal (1:3.3.2-1) to 1:3.3.2-2
libreoffice-style-galaxy (1:3.3.2-1) to 1:3.3.2-2
libreoffice-style-tango (1:3.3.2-1) to 1:3.3.2-2
libreoffice-writer (1:3.3.2-1) to 1:3.3.2-2
libsensors4 (1:3.2.0-1) to 1:3.3.0-1
libservlet2.5-java (6.0.32-1) to 6.0.32-2
libsigc++-2.0-0c2a (2.2.4.2-1) to 2.2.9-1
libslang2 (2.2.2-4) to 2.2.3-3
libssh2-1 (1.2.7-1) to 1.2.8-1
libssl0.9.8 (0.9.8o-6) to 0.9.8o-7
libtag1-vanilla (1.6.3-1) to 1.7-1
libtag1c2a (1.6.3-1) to 1.7-1
libtagc0 (1.6.3-1) to 1.7-1
libtiff-tools (3.9.4-8) to 3.9.4-9
libtiff4 (3.9.4-8) to 3.9.4-9
libts-0.0-0 (1.0-7) to 1.0-8
libudev0 (166-1) to 167-1
libva-x11-1 (1.0.8-3) to 1.0.12-1
libva1 (1.0.8-3) to 1.0.12-1
libwww-perl (5.837-1) to 6.01-3
libx11-6 (2:1.4.2-1) to 2:1.4.3-1
libx11-data (2:1.4.2-1) to 2:1.4.3-1
libx11-xcb1 (2:1.4.2-1) to 2:1.4.3-1
libxapian22 (1.2.4-1) to 1.2.5-1
linux-headers-2.6.38-2-686 (2.6.38-2) to 2.6.38-3
linux-headers-2.6.38-2-common (2.6.38-2) to 2.6.38-3
linux-image-2.6.38-2-686 (2.6.38-2) to 2.6.38-3
linux-libc-dev (2.6.38-2) to 2.6.38-3
lm-sensors (1:3.2.0-1) to 1:3.3.0-1
m4 (1.4.14-3) to 1.4.16-1
make (3.81-8) to 3.81-8.1
man-db (2.5.9-4) to 2.6.0-1
network-manager (0.8.3.998-1) to 0.8.3.999-1
network-manager-gnome (0.8.3.998-1) to 0.8.3.999-1
openssh-client (1:5.8p1-3) to 1:5.8p1-4
openssl (0.9.8o-5) to 1.0.0d-1
phonon (4:4.6.0really4.4.4-3) to 4:4.6.0really4.5.0-2
python-apt (0.7.100.2) to 0.7.100.3
python-apt-common (0.7.100.2) to 0.7.100.3
python-avahi (0.6.29-1) to 0.6.30-1
python-feedparser (4.1-14) to 5.0.1-1
python-glade2 (2.17.0-4) to 2.17.0-4+b1
python-gpod (0.7.95-2) to 0.8.0-2
python-gtk2 (2.17.0-4) to 2.17.0-4+b1
python-iniparse (0.3.2-1) to 0.4-2
python-lxml (2.3-0.1) to 2.3-0.1+b1
python-mako (0.4.0-1) to 0.4.1-1
python-markupsafe (0.12-1) to 0.12-1+b1
python-numpy (1:1.4.1-5) to 1:1.5.1-2
python-sip (4.12.1-1) to 4.12.1-1+b1
python-software-properties (0.60.debian-3) to 0.76.7debian2
python-uno (1:3.3.2-1) to 1:3.3.2-2
python-xapian (1.2.4-1) to 1.2.5-1
shotwell (0.8.1-4) to 0.9.1-1
software-properties-gtk (0.60.debian-3) to 0.76.7debian2
tsconf (1.0-7) to 1.0-8
ttf-opensymbol (2:2.4.3+LibO3.3.2-1) to 2:2.4.3+LibO3.3.2-2
udev (166-1) to 167-1
uno-libs3 (1.7.0+LibO3.3.2-1) to 1.7.0+LibO3.3.2-2
ure (1.7.0+LibO3.3.2-1) to 1.7.0+LibO3.3.2-2
x11-common (1:7.6+5) to 1:7.6+6
x11-xserver-utils (7.6+1) to 7.6+2
xkb-data (1.8-2) to 2.1-2
xserver-xorg (1:7.6+5) to 1:7.6+6
xserver-xorg-input-all (1:7.6+5) to 1:7.6+6

Installed the following packages:
equinox-themes-evolution (1.40-1)
gir1.2-freedesktop (0.10.4-2)
gir1.2-glib-2.0 (0.10.4-2)
gir1.2-gstreamer-0.10 (0.10.32-6)
gir1.2-json-glib-1.0 (0.12.0-3)
gir1.2-pango-1.0 (1.28.3-6)
libencode-locale-perl (1.02-1)
libfile-listing-perl (6.01-1)
libgirepository-1.0-1 (0.10.4-2)
libhtml-form-perl (6.00-1)
libhttp-cookies-perl (6.00-2)
libhttp-daemon-perl (6.00-1)
libhttp-date-perl (6.00-1)
libhttp-message-perl (6.01-1)
libhttp-negotiate-perl (6.00-2)
liblwp-mediatypes-perl (6.01-1)
libnet-http-perl (6.00-1)
libssl1.0.0 (1.0.0d-1)
libwww-robotrules-perl (6.01-1)

just saying that funny enough the removed pkgs is the same in my sid install and in your standard one, and i can't replicate that in my vanilla lmde
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: Remove Epiphany?

Postby AlbertP on Sun Apr 10, 2011 12:52 pm

gnome-core is only a dummy package used to install many Gnome components at once - those Gnome components remain installed.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6520
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 7 guests