KXStitch, install headache [ GIVEN UP ]

Questions about applications and software
Forum rules
Before you post please read this

KXStitch, install headache [ GIVEN UP ]

Postby Dar-es-Salaam on Thu May 19, 2011 4:22 am

Hi.
I have just found a program called KXStitch, which is a cross stitch program and I am having trouble installing it. It is a tar.gz download. I have extracted it ok but when I try to run ./configure it come up with " configure: error: The important program kde-config was not found! ". Does this mean that it won't install on LMDE at all or that I have to find another file 'kde.config' from somewhere, if so where do I find the required file(s)?. Help please :D
As you can see I am new to doing this.
Last edited by Dar-es-Salaam on Sat May 21, 2011 5:47 am, edited 1 time in total.
Cheers
Gordon :D

O/S. LMDE , Motherboard Asus A7N8X Delux , CPU AMD XP1500+ (1300Mhz) (overclocked running at 1866Mhz), Graphics Card GeForce Nvidia PNY 6200 (512 Meg), 2 40gig hard drives, 1 gig RAM
User avatar
Dar-es-Salaam
Level 3
Level 3
 
Posts: 152
Joined: Mon Mar 01, 2010 6:23 am
Location: Blackpool, Lancashire, England, UK.

Linux Mint is funded by ads and donations.
 

Re: KXStitch, install headache

Postby dagon on Thu May 19, 2011 5:37 am

I've never compiled anything for KDE (which is the intended environment for this program), but for Gnome I would need to
install build depends for bigger software projects (stuff using guis and whatelse). It needs, if not the whole KDE desktop so
at least the base packages. I don't know what package/-s to install but if you install another package like kolourpaint it
will maybe pull in the same dependencies.

Here's a good place to start though:
http://forums.linuxmint.com/viewtopic.php?f=90&t=9234

Oskar
Image
User avatar
dagon
Level 7
Level 7
 
Posts: 1690
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden

Re: KXStitch, install headache

Postby Dar-es-Salaam on Fri May 20, 2011 9:05 am

Hi Oskar

Thanks for that, i've had a look at where you said to start an have no idea what they are talking about. I am not a program writer at all, I merely use programs that other clever people have written.

I emailed the program writer himself and he said that I need to install kde3 / qt3, kde libraries, ImageMagick and ImageMagick++. I am struggling to find them though I think qt3 is already part of LMDE but I am not certain. I've just noticed that ImageMagic is already on my PC but I am not sure about ImageMagic++
Cheers
Gordon :D

O/S. LMDE , Motherboard Asus A7N8X Delux , CPU AMD XP1500+ (1300Mhz) (overclocked running at 1866Mhz), Graphics Card GeForce Nvidia PNY 6200 (512 Meg), 2 40gig hard drives, 1 gig RAM
User avatar
Dar-es-Salaam
Level 3
Level 3
 
Posts: 152
Joined: Mon Mar 01, 2010 6:23 am
Location: Blackpool, Lancashire, England, UK.

Re: KXStitch, install headache

Postby xircon on Fri May 20, 2011 1:43 pm

Just had a go at compiling it, but it ends up in dependency hell, qt3/kde3 is just too old, think you will be very lucky if you get this to work.

Code: Select all
checking for Qt... configure: error: Qt (>= Qt 3.3 and < 4.0) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!


When I try to install qt3-mt it all gets very silly very quickly :(
Code: Select all
sudo aptitude install libqt3-mt-dev
The following NEW packages will be installed:
  comerr-dev{ab} krb5-multidev{ab} libcups2-dev{a} libkrb5-dev{a} libqt3-mt-dev
The following packages will be REMOVED:
  libprotobuf6{u} libprotoc6{u}
0 packages upgraded, 5 newly installed, 2 to remove and 3 not upgraded.
Need to get 553 kB of archives. After unpacking 382 kB will be used.
The following packages have unmet dependencies:
  comerr-dev: Depends: libcomerr2 (= 1.41.12-4) but 1.41.14-1 is installed.
  krb5-multidev: Depends: libkrb5-3 (= 1.9+dfsg-1+b1) but 1.9+dfsg-1+moonshot1 is installed.
                 Depends: libk5crypto3 (= 1.9+dfsg-1+b1) but 1.9+dfsg-1+moonshot1 is installed.
                 Depends: libgssapi-krb5-2 (= 1.9+dfsg-1+b1) but 1.9+dfsg-1+moonshot1 is installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     comerr-dev [Not Installed]                         
2)     krb5-multidev [Not Installed]                     
3)     libcups2-dev [Not Installed]                       
4)     libkrb5-dev [Not Installed]                       
5)     libqt3-mt-dev [Not Installed]                     

Accept this solution? [Y/n/q/?]
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: KXStitch, install headache

Postby Dar-es-Salaam on Sat May 21, 2011 5:45 am

Thanks to All,

By the sounds of things I may as well forget it as it obviously beyond my ability to sort it out. I have installed KDE-Full and it still does not work still never mind, keep on smiling. :D

Again thanks for all your help :D
Cheers
Gordon :D

O/S. LMDE , Motherboard Asus A7N8X Delux , CPU AMD XP1500+ (1300Mhz) (overclocked running at 1866Mhz), Graphics Card GeForce Nvidia PNY 6200 (512 Meg), 2 40gig hard drives, 1 gig RAM
User avatar
Dar-es-Salaam
Level 3
Level 3
 
Posts: 152
Joined: Mon Mar 01, 2010 6:23 am
Location: Blackpool, Lancashire, England, UK.

Re: KXStitch, install headache [ GIVEN UP ]

Postby dagon on Sat May 21, 2011 6:37 am

Well, if you run something Ubuntu based it's in the repository and works.
Image
User avatar
dagon
Level 7
Level 7
 
Posts: 1690
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden

Re: KXStitch, install headache [ GIVEN UP ]

Postby xircon on Sat May 21, 2011 8:08 am

dagon wrote:Well, if you run something Ubuntu based it's in the repository and works.
.
Virtualbox with Ubuntu? - might work. Tried to install the Ubuntu deb but it fails on imagemagic++2, Debian has ++3.

Steve
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: KXStitch, install headache [ GIVEN UP ]

Postby eMcE on Tue Jan 21, 2014 3:00 pm

Dar-es-Salaam wrote:Hi.
I have just found a program called KXStitch, which is a cross stitch program and I am having trouble installing it. It is a tar.gz download. I have extracted it ok but when I try to run ./configure it come up with " configure: error: The important program kde-config was not found! ". Does this mean that it won't install on LMDE at all or that I have to find another file 'kde.config' from somewhere, if so where do I find the required file(s)?. Help please :D
As you can see I am new to doing this.


Code: Select all
sudo add-apt-repository ppa:ubuntuhandbook1/apps
sudo apt-get update
sudo apt-get install kxstitch
Miłość i prawda rządzą :] a hipokrytom chooy w tylny exit :]
Image
User avatar
eMcE
Level 2
Level 2
 
Posts: 96
Joined: Tue Oct 30, 2012 9:53 am
Location: Czołg.. Gdzieś na pustyni..

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 6 guests