[SOLVED] Problems updating after trying install Iceweasel 4

Questions about applications and software
Forum rules
Before you post please read this

[SOLVED] Problems updating after trying install Iceweasel 4

Postby menuhin on Mon May 30, 2011 4:02 pm

Hi all,

I'm quite new to Debian.
I tried to install Iceweasel 4 on LMDE 10 using the method of this thread
viewtopic.php?f=141&t=70998

It did not install correctly and the firefox-bin was always missing.
Then problems arise for even console based updates using
Code: Select all
$ sudo apt-get update && sudo apt-get dist-upgrade


The error messages read:
...
W: GPG error: http://mozilla.debian.net squeeze-backports Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 85A3D26506C4AE2A
...
Building dependency tree
Reading state information... Done
...
Calculating upgrade... Failed
The following packages have unmet dependencies:
gnome-menus : Breaks: gnome-panel (<2.91) but 2.30.2-4 is to be installed
gnome-panel : Depends: gnome-pangel-data (<2.31) but 3.0.0.1-2 is to be installed
Recommends: gnome-applets (>= 2.12.1-1) but it is not going to be installed
Recommends: gnome-session (>= 2.26) but it is not going to be installed
libgdu-gtk0: Breaks: gnome-disk-utility (< 3.0.0) but 2.30.1-2 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

What should I do to make the upgrade work again?
(Of course, I did all these because I want to install Firefox 4,, therefore Iceweasel 4)
Thanks in advance for all the helps.
Last edited by menuhin on Fri Jun 03, 2011 9:52 am, edited 1 time in total.
menuhin
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 26, 2009 12:52 pm

Linux Mint is funded by ads and donations.
 

Re: Problems of updating after trying to install Iceweasel 4

Postby zerozero on Mon May 30, 2011 4:37 pm

well from that output i believe you are in a "little mess" :o
can you please give us the output of
Code: Select all
cat /etc/apt/sources.list
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: Problems of updating after trying to install Iceweasel 4

Postby menuhin on Mon May 30, 2011 4:53 pm

deb http://packages.linuxmint.com/ debian main upstream import
deb http://ftp.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free
deb http://ftp.debian.org/debian/ experimental main contrib non-free
deb-src http://ftp-debian.org/debian/ experimental main non-free contrib
deb http://mozilla.debian.net/ squeeze-backports iceweasel-4.0

(I'm sending this message from a different computer)
menuhin
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 26, 2009 12:52 pm

Re: Problems of updating after trying to install Iceweasel 4

Postby zerozero on Mon May 30, 2011 5:19 pm

menuhin wrote:(I'm sending this message from a different computer)

but it's referring to the system where you have the issue?

menuhin wrote:deb http://ftp.debian.org/debian/ experimental main contrib non-free
deb-src http://ftp-debian.org/debian/ experimental main non-free contrib

here is the issue: you have experimental repo enabled, how?

menuhin wrote:deb http://packages.linuxmint.com/ debian main upstream import
deb http://ftp.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free

this is the default lmde sources.list

ok! how you solve this? assuming that you don't want the experimental repo (and that it is there by some kind of accident), first disable it or deleted from sources.list (both entries);

then, your other problem, you want ff4, ok, there's an easier way (i think) to do it:
- you already have
Code: Select all
deb http://mozilla.debian.net/ squeeze-backports iceweasel-4.0
in your sources.list, leave it there;
- update the system
Code: Select all
sudo apt-get update

- get iceweasel4
Code: Select all
apt-get install -t squeeze-backports iceweasel


from here http://mozilla.debian.net/
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: Problems of updating after trying to install Iceweasel 4

Postby menuhin on Mon May 30, 2011 5:20 pm

I commented out the last 3 lines and it can update again, but in no way I can get iceweasel installed still.
menuhin
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 26, 2009 12:52 pm

Re: Problems of updating after trying to install Iceweasel 4

Postby zerozero on Mon May 30, 2011 5:24 pm

the last entry (mozilla) must be enabled;
and then check the last part of my last post
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: Problems of updating after trying to install Iceweasel 4

Postby menuhin on Mon May 30, 2011 5:33 pm

Did the followings:
Code: Select all
sudo apt-get update
sudo apt-get install -t squeeze-backports iceweasel


Seemingly successful but instead
Got the followings:
Code: Select all
 ~ $ which iceweasel
/usr/bin/iceweasel
 ~ $ iceweasel &
[1] 3958
 ~ $ exec: 193: /usr/lib/iceweasel/firefox-bin: not found
menuhin
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 26, 2009 12:52 pm

Re: Problems of updating after trying to install Iceweasel 4

Postby menuhin on Mon May 30, 2011 5:35 pm

Had this error at the end of update:
Code: Select all
...
W: GPG error: http://mozilla.debian.net squeeze-backports Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 85A3D26506C4AE2A
menuhin
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 26, 2009 12:52 pm

Re: Problems of updating after trying to install Iceweasel 4

Postby zerozero on Mon May 30, 2011 5:55 pm

just for the sake of it i tried now and it installed
Code: Select all
apt-get install -t squeeze-backports iceweasel
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libmozjs4d xulrunner-2.0
Suggested packages:
  ttf-lyx latex-xft-fonts ttf-mathematica4.1 xprint mozplugger
The following NEW packages will be installed:
  iceweasel libmozjs4d xulrunner-2.0
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 13.9 MB of archives.
After this operation, 36.6 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://mozilla.debian.net/ squeeze-backports/iceweasel-4.0 libmozjs4d amd64 2.0.1-1~bpo60+1 [1,379 kB]
Get:2 http://mozilla.debian.net/ squeeze-backports/iceweasel-4.0 xulrunner-2.0 amd64 2.0.1-1~bpo60+1 [10.9 MB]
Get:3 http://mozilla.debian.net/ squeeze-backports/iceweasel-4.0 iceweasel amd64 4.0.1-1~bpo60+1 [1,569 kB]
Fetched 13.9 MB in 25s (547 kB/s)                                             
Selecting previously deselected package libmozjs4d.
(Reading database ... 215532 files and directories currently installed.)
Unpacking libmozjs4d (from .../libmozjs4d_2.0.1-1~bpo60+1_amd64.deb) ...
Selecting previously deselected package xulrunner-2.0.
Unpacking xulrunner-2.0 (from .../xulrunner-2.0_2.0.1-1~bpo60+1_amd64.deb) ...
Selecting previously deselected package iceweasel.
Unpacking iceweasel (from .../iceweasel_4.0.1-1~bpo60+1_amd64.deb) ...
Adding 'diversion of /usr/bin/firefox to /usr/bin/firefox.real by iceweasel'
Processing triggers for man-db ...
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for menu ...
Processing triggers for mintsystem ...
Setting up libmozjs4d (2.0.1-1~bpo60+1) ...
Setting up xulrunner-2.0 (2.0.1-1~bpo60+1) ...
update-alternatives: using /usr/lib/xulrunner-2.0/xulrunner-stub to provide /usr/bin/xulrunner-stub (xulrunner-stub) in auto mode.
Setting up iceweasel (4.0.1-1~bpo60+1) ...
Processing triggers for menu ...
amadeu amadeu # exit
exit
amadeu@amadeu ~ $ iceweasel
amadeu@amadeu ~ $ apt-cache policy iceweasel
iceweasel:
  Installed: 4.0.1-1~bpo60+1
  Candidate: 4.0.1-1~bpo60+1
  Version table:
 *** 4.0.1-1~bpo60+1 0
        500 http://mozilla.debian.net/ squeeze-backports/iceweasel-4.0 amd64 Packages
        100 /var/lib/dpkg/status
     3.5.19-2 0
        700 http://ftp.debian.org/debian/ testing/main amd64 Packages
amadeu@amadeu ~ $


in what is your output different from this?
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: Problems of updating after trying to install Iceweasel 4

Postby menuhin on Tue May 31, 2011 10:05 am

Here's the output:

Code: Select all
 ~ $ apt-cache policy iceweasel
iceweasel:
  Installed: 4.0.1-1~bpo60+1
  Candidate: 4.0.1-1~bpo60+1
  Version table:
 *** 4.0.1-1~bpo60+1 0
        500 http://mozilla.debian.net/ squeeze-backports/iceweasel-4.0 amd64 Packages
        100 /var/lib/dpkg/status
     3.5.19-2 0
        500 http://ftp.debian.org/debian/ testing/main amd64 Packages


However:

Code: Select all
 ~ $ iceweasel &
[1] 25056
 ~ $ exec: 193: /usr/lib/iceweasel/firefox-bin: not found
menuhin
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 26, 2009 12:52 pm

Re: Problems of updating after trying to install Iceweasel 4

Postby zerozero on Tue May 31, 2011 10:08 am

well, it's installed! look for it in the menu, but bare in mind that you can't have both (iceweasel and ff) running at the same time, and try
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: Problems of updating after trying to install Iceweasel 4

Postby menuhin on Tue May 31, 2011 10:20 am

Iceweasel is present in the menu and according to Control Center's User menu, that icon points to "iceweasel %u"
The problem is iceweasel is not properly installed.

And in the console if I type "firefox &", the same error will appear, i.e.
("which firefox" points to "/usr/bin/firefox")
Code: Select all
~ $ exec: 193: /usr/lib/iceweasel/firefox-bin: not found


i.e. Firefox is not present either.
These were the things that I gone through therefore went to modify the sources.list to try the experimental distribution.
menuhin
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 26, 2009 12:52 pm

Re: Problems of updating after trying to install Iceweasel 4

Postby zerozero on Tue May 31, 2011 10:31 am

sorry, i can't replicate your errors, and therefore it's very hard to come with any idea to fix them;

maybe try to re-install ff, and see if it runs, and then the same to iceweasel, other than that, i'm out of ideas :(
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: Problems of updating after trying to install Iceweasel 4

Postby menuhin on Tue May 31, 2011 10:57 am

zerozero: Thanks a lot for your help. I shall report my solution here if I can find one.
menuhin
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 26, 2009 12:52 pm

Re: Problems of updating after trying to install Iceweasel 4

Postby craigevil on Tue May 31, 2011 11:04 am

No issues with using the mozilla.debian.net repo to install Iceweasel.

# apt-cache policy iceweasel
iceweasel:
Installed: 5.0~b2-1
Candidate: 5.0~b2-1
Version table:
*** 5.0~b2-1 0
500 http://mozilla.debian.net/ experimental/iceweasel-5.0 i386 Packages
100 /var/lib/dpkg/status
4.0.1-2 0
1 http://mirrors.kernel.org/debian/ experimental/main i386 Packages
3.5.19-2 0
500 http://mirrors.kernel.org/debian/ unstable/main i386 Packages

# which iceweasel
/usr/bin/iceweasel
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: Iceweasel 4 for amd64 instead

Postby menuhin on Tue May 31, 2011 4:19 pm

Hi craigevil,

Thanks for letting me know.
Mine's a 64-bit (amd64)...
Last edited by menuhin on Wed Jun 01, 2011 9:25 am, edited 1 time in total.
menuhin
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 26, 2009 12:52 pm

Re: Cannot install xulrunner-2.0 (xulrunner-2.0.2pre)

Postby menuhin on Wed Jun 01, 2011 6:34 am

Found iceweasel depends on xulrunner-2.0 but xulrunner-2.0 has some error, so I removed the followings:
iceweasel
xulrunner-2.0
xulrunner-1.9
eclipse (which depends on xulrunner-1.9)

And then tried reinstalling everything using Synaptic again and iceweasel first.
But Synaptic gave me the following error message when I tried to install iceweasel:

Code: Select all
Could not mark all packages for installation or upgrade
iceweasel:
Depends: xulrunner-2.0 but it is not going to be installed


Really puzzled. I can't remember it well but it might be the reason I switched to try the experimental distribution using the sources.list.
Please suggest any solution. Thanks.
menuhin
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 26, 2009 12:52 pm

Re: Problems of updating after trying to install Iceweasel 4

Postby menuhin on Wed Jun 01, 2011 10:44 am

Can some members who have iceweasel 4 installed on LMDE amd64 kindly tell me what version(s) of xulrunner is installed on their system?
Thanks a lot for your help.
menuhin
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 26, 2009 12:52 pm

Re: Problems of updating after trying to install Iceweasel 4

Postby zerozero on Wed Jun 01, 2011 12:43 pm

hope this helps a bit

Code: Select all
amadeu@amadeu ~ $ apt-cache policy xulrunner-2.0
xulrunner-2.0:
  Installed: 2.0.1-1~bpo60+1
  Candidate: 2.0.1-1~bpo60+1
  Version table:
 *** 2.0.1-1~bpo60+1 0
        500 http://mozilla.debian.net/ squeeze-backports/iceweasel-4.0 amd64 Packages
        100 /var/lib/dpkg/status
amadeu@amadeu ~ $ apt-cache policy iceweasel
iceweasel:
  Installed: 4.0.1-1~bpo60+1
  Candidate: 4.0.1-1~bpo60+1
  Version table:
 *** 4.0.1-1~bpo60+1 0
        500 http://mozilla.debian.net/ squeeze-backports/iceweasel-4.0 amd64 Packages
        100 /var/lib/dpkg/status
     3.5.19-2 0
        700 http://ftp.debian.org/debian/ testing/main amd64 Packages
amadeu@amadeu ~ $ apt-cache policy xulrunner-1.9
xulrunner-1.9:
  Installed: (none)
  Candidate: (none)
  Version table:
amadeu@amadeu ~ $ apt-cache policy firefox
firefox:
  Installed: 3.6.13-1linuxmint1
  Candidate: 3.6.13-1linuxmint1
  Version table:
 *** 3.6.13-1linuxmint1 0
        700 http://mirror.tuxis.nl/packages/ debian/import amd64 Packages
        100 /var/lib/dpkg/status
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: Problems of updating after trying to install Iceweasel 4

Postby cwgtex on Wed Jun 01, 2011 10:55 pm

If you use this command to install, it should install iceweasel and its dependencies from the backports repo specifically.
Code: Select all
apt-get install -t squeeze-backports libcairo2 xulrunner-2.0 libmozjs4d iceweasel

The commands listed on the mozilla.debian.net website (as well as the script I wrote here viewtopic.php?f=141&t=70998) work perfectly on a fresh install of LMDE. From your sources.list it looks like you are trying to use the experimental repo. Use the squeeze-backports repo instead.

If you do want to keep the experimental repos, I highly recommend you read up on "apt pinning". Here is a helpful guide:
http://crunchbanglinux.org/forums/topic ... edge-with/

Its possible you had problems fetching the key because the mozilla.debian.net website was down sporadically over the last few weeks. Its up now though. Try to install again.
"If it ain't broke, fix it till it is." - Anonymous 33W
User avatar
cwgtex
Level 1
Level 1
 
Posts: 17
Joined: Sun Jan 09, 2011 9:19 pm
Location: San Antonio, TX

Linux Mint is funded by ads and donations.
 
Next

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 5 guests