Firefox 5 broke after update - 64 bit edition

Questions about applications and software
Forum rules
Before you post please read this

Firefox 5 broke after update - 64 bit edition

Postby jd27 on Sat Jun 25, 2011 12:13 pm

I upgraded through the update manager and now Firefox will not load.

Received this error:

/opt/firefox/firefox-bin: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/firefox/libxul.so)

Thanks for the help.

Joe
jd27
Level 1
Level 1
 
Posts: 1
Joined: Sat Jun 25, 2011 12:07 pm

Linux Mint is funded by ads and donations.
 

Re: Firefox 5 broke after update - 64 bit edition

Postby xenopeek on Wed Jul 06, 2011 5:42 am

Which LM version are you running? You mention 64 bit, but the error you get is for th 32 bit library I think.

On a clean LM 11 64-bit install, with Firefox 5, the libstdc++.so.6 is located in: /usr/lib/x86_64-linux-gnu

And a `strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBC` does not show GLIBCXX_3.4.15 either.
Code: Select all
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_3.4.14
GLIBC_2.2.5
GLIBC_2.3
GLIBC_2.4
GLIBC_2.3.4
GLIBC_2.3.2
GLIBCXX_FORCE_NEW
GLIBCXX_DEBUG_MESSAGE_LENGTH


Something else must be wrong. Is it 32 bit version of Firefox perhaps?
Forum Rules | IRC Channel Rules
Image
Arch Linux / 64-bit / Gnome Shell
User avatar
xenopeek
Level 21
Level 21
 
Posts: 13696
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 9 guests