Flightgear uninstallable: libavdevice diff from Testing

Questions about applications and software
Forum rules
Before you post please read how to get help

Flightgear uninstallable: libavdevice diff from Testing

Postby graeme on Sat Aug 27, 2011 1:17 am

I cannot install Flightgear because the version of libavdevice I have has a higher version number than in Debian testing.

The source is shown as "local"

If I force the version down it will uninstall VLC, gmstreamer and mint-codecs.

Is there a faster solution than waiting until Debian testing moves up to the version of libav I have, that will not make me lose multimedia codecs?
graeme
Level 3
Level 3
 
Posts: 108
Joined: Sat Feb 14, 2009 3:38 am
Location: Far away from proper beer.

Linux Mint is funded by ads and donations.
 

Re: Flightgear uninstallable: libavdevice diff from Testing

Postby xenopeek on Sat Aug 27, 2011 3:01 am

What do you with with:
If I force the version down it will uninstall VLC, gmstreamer and mint-codecs.

And how exactly are you forcing the version down? I think you can just get the .deb file from the repo's from the older version, and install that alongside the existing version. Check if the version you need is on this list somewhere: http://packages.debian.org/search?keywords=libavdevice&searchon=names&suite=all&section=all
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15449
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Flightgear uninstallable: libavdevice diff from Testing

Postby graeme on Sat Aug 27, 2011 11:29 pm

Sorry, its actually libavcodec52 (on which libavdevice52 depends,which was why the right version was not installing) that I tired to force the version down on. I tried to force the version using Synaptic (package -> force version).

I will try installing the lower version of libavcodec from a downloaded deb and see if that works.

Is there no way of installing the lower version from the repos without removing the existing one?
graeme
Level 3
Level 3
 
Posts: 108
Joined: Sat Feb 14, 2009 3:38 am
Location: Far away from proper beer.


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 4 guests