Wrong mixer opens for sound preferences.

Questions about applications and software
Forum rules
Before you post please read this

Wrong mixer opens for sound preferences.

Postby cdysthe on Mon Sep 19, 2011 10:58 pm

Hi,

Today when I right click on the volume control icon in the notification area (where network, volume, battery etc. is controlled) and select "Sound Preferences" I get "gnome-volume-control.gstreamer" opened instead of "gnome-volume-control.pulse" as it used to be. Also, when I click on "Sound" in the Control Center I get the gstreamer mixer, not the pulse one like I used to.i Pulse audio runs fine and I can open "gnome-volume-control.pulse" from a terminal without problems. I have no idea how this got changed and how to change it back. Anyone know how to set back to the way it was?
User avatar
cdysthe
Level 3
Level 3
 
Posts: 105
Joined: Sun Oct 05, 2008 12:18 pm

Linux Mint is funded by ads and donations.
 

Re: Wrong mixer opens for sound preferences.

Postby viking777 on Tue Sep 20, 2011 12:07 pm

Could you have accidentally switched to alsa from pulseaudio? About the easiest way to find out that I know of is to type the command

Code: Select all
alsamixer


into a terminal. If it says your card and chip are 'pulseaudio' then that is what you are using, if it says something else then that is why the wrong sound controller is opening.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Wrong mixer opens for sound preferences.

Postby gregorovius on Tue Dec 13, 2011 3:14 am

Hi. I was using Ubuntu until recently and this worked OK. I also have a wireless USB headset with volume control and it functioned correctly. I installed LMDE in a laptop and I experience this same problem, as well as the volume control always affecting the first device and not the active one. Anyway, I deleted gnome-volume-control-applet, gnome-volume-control.pulse/gstreamer in /usr/bin and replaced it with Ubuntu's versions (it has the same version number) and it fixed the issue you're experiencing. I also replaced libmedia-keys.so in /usr/lib/gnome-settings-daemon-2.0/ to fix the volume issue. I uploaded these files here, hope they are of use. If you wanna be paranoid you can also get them from an Ubuntu 10.04 Live CD.
http://dl.dropbox.com/u/372214/gnome-audio.tar.gz

Cheers.
gregorovius
Level 1
Level 1
 
Posts: 1
Joined: Tue Dec 13, 2011 3:06 am


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 3 guests