Xserver fails to load after removing optional packages

Questions about applications and software
Forum rules
Before you post please read how to get help

Xserver fails to load after removing optional packages

Postby Brian49 on Fri Sep 30, 2011 5:08 pm

I'm fairly sure that this piece of weirdness is peculiar to my system and not a problem with LMDE as such, but I would be very grateful for any advice, please.

Recently I've been removing some unwanted packages from my system. They are optional packages; they don't come ready installed, and as far as I can see, removing them shouldn't affect anything else on the system - but it does. After removing the two packages gnome-specimen (a font preview utility) and simple-scan (a scanning utility), the Xserver failed to load the next time I tried to boot up the computer. I went through this routine a couple more times to make sure that the removal of these packages was indeed the trigger for the failure.

Can anyone suggest what might be going on here, please? Tracking Debian Unstable, with most updates installed and only about a dozen or so Gnome-related packages pinned. There were no warnings of possible issues when I removed the two packages via Synaptic. Using the 'free' Radeon driver. Many thanks.
Brian49
Level 5
Level 5
 
Posts: 612
Joined: Thu Oct 29, 2009 2:27 pm

Linux Mint is funded by ads and donations.
 

Re: Xserver fails to load after removing optional packages

Postby rhodry on Sat Oct 01, 2011 1:55 am

Try having a read through 'man apt-cache' and 'man apt-get'. Apart from finding all sorts of useful stuff to learn, you will see that you can find the packages that a particular package depends on as well as the packages that depend on it. You do this before trying package management where you are not sure of the outcome. You can also run "apt remove" with the -s option. That does a simulation of proposed actions without actually affecting your system.

for example:

Code: Select all
$ apt-cache depends gnome-specimen
gnome-specimen
  Depends: python
  Depends: python-support
  Depends: gconf2
  Depends: python-glade2
  Depends: python-gnome2
  Depends: python-gtk2
$ apt-cache rdepends gnome-specimen
gnome-specimen
Reverse Depends:
  open-font-design-toolkit


cheers,
rhodry.
Life isn't about waiting for the storm to pass...
it's about learning to dance in the rain.
rhodry
Level 4
Level 4
 
Posts: 347
Joined: Mon Jun 04, 2007 7:32 am

Re: Xserver fails to load after removing optional packages

Postby Brian49 on Sat Oct 01, 2011 5:26 am

Thanks for the suggestion. But now I'm more puzzled then ever, because running apt-cache depends confirms that the two packages I tried to remove shouldn't affect the Xserver. As I mentioned, Synaptic didn't give any warning of trouble either, which it usually does if there are possible complications with a removal.
Brian49
Level 5
Level 5
 
Posts: 612
Joined: Thu Oct 29, 2009 2:27 pm


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 6 guests