[SOLVED] Getting DraftSight CAD to run on LMDE 64bit?

Questions about applications and software
Forum rules
Before you post please read how to get help

[SOLVED] Getting DraftSight CAD to run on LMDE 64bit?

Postby GeneC on Tue Oct 04, 2011 12:58 pm

I have been struggling with this for a few hours.
I am attempting to install a CAD program called DraftSight
http://www.3ds.com/products/draftsight/overview/

Onto my LMDE 64 bit installation.
I downloaded the .deb (It only comes in 32bit), but searching the net.
http://www.ubuntubuzz.com/2011/03/ubunt ... ation.html

I found that its possible to install with the following command
Code: Select all
sudo dpkg --force-architecture –i <package name>

After downloading a few dependicies

Code: Select all
Commit Log for Tue Oct  4 12:19:09 2011

Installed the following packages:
libc6-i386 (2.13-21)
libdirectfb-extra (1.2.10.0-4.2)
libxcb-render-util0 


I have the .deb file in my HOME.
I "SU" and enter my password
I run the command.
Code: Select all
gene@zordon ~ $ su
Password:
zordon gene # sudo dpkg -i --force-architecture DraftSight.deb
dpkg: warning: overriding problem because --force enabled:
 package architecture (i386) does not match system (amd64)
(Reading database ... 170951 files and directories currently installed.)
Unpacking dassault-systemes-draftsight (from DraftSight.deb) ...

access control disabled, clients can connect from any host
access control disabled, clients can connect from any host
/var/lib/dpkg/tmp.ci/ShowLicence: error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory
access control enabled, only authorized clients can connect
access control enabled, only authorized clients can connect
dpkg: error processing DraftSight.deb (--install):
 subprocess new pre-installation script returned error exit status 127
Errors were encountered while processing:
 DraftSight.deb


I downloaded the .deb twice, and checked the MD5. It ok.

What to check next? :cry:

===============================

My inxi -F
gene@zordon ~ $ inxi -F
System: Host zordon Kernel 3.0.0-4.dmz.2-liquorix-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition

CPU: Quad core AMD Phenom II X4 955 (-MCP-) cache 2048 KB flags (lm nx sse sse2 sse3 sse4a svm) bmips 25715.5
Clock Speeds: (1) 3200.00 MHz (2) 800.00 MHz (3) 800.00 MHz (4) 800.00 MHz

Graphics: Card nVidia GF104 [GeForce GTX 460] X.Org 1.11.1 Res: 1680x1050@50.0hz
GLX Renderer GeForce GTX 460/PCI/SSE2 GLX Version 4.1.0 NVIDIA 275.28 Direct Rendering Yes

Audio: Card-1 ATI SBx00 Azalia (Intel HDA) driver HDA Intel BusID: 00:14.2
Card-2 nVidia GF104 High Definition Audio Controller driver HDA Intel BusID: 01:00.1
Sound: Advanced Linux Sound Architecture Version 1.0.24

Network: Card Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver r8169 v: 2.3LK-NAPI at port e800 BusID: 04:00.0

Disks: HDD Total Size: 322.0GB (4.0% used) 1: /dev/sda ST3320613AS 320.1GB
2: USB /dev/sde CardReader_SD 2.0GB

Partition: ID:/ size: 17G used: 5.1G (33%) fs: ext4 ID:swap-1 size: 0.00GB used: 0.00GB (0%) fs: swap

Sensors: System Temperatures: cpu: 32.0C mobo: 37.0C gpu: 0.0:40C
Fan Speeds (in rpm): cpu: 864 sys-1: 1134

Info: Processes 175 Uptime 1:04 Memory 884.9/5985.3MB Runlevel 2 Client Shell inxi 1.4.23
Last edited by GeneC on Tue Oct 04, 2011 4:58 pm, edited 1 time in total.
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Sparky Cin 2.2 (SID)
Manjaro .9.0dev Cin 2.4 (Testing)
Arch XFCE/Budgie
User avatar
GeneC
Level 7
Level 7
 
Posts: 1582
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Linux Mint is funded by ads and donations.
 

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby DrHu on Tue Oct 04, 2011 1:45 pm

GeneC wrote:sudo dpkg --force-architecture –i <package name>

I assume you used this process, and do have the 32bit compatible libvs installed..
http://courira.ca/en/2011/03/draftsight ... ntu-64-bit
    DraftSight for Linux is available in two different packages: Ubuntu .deb and Fedora/SuSE/Mandriva .rpm. I'm not sure about the latter, but the former is 32-bit only. So does that mean that it's tough luck for 64-bit OS' users? Hardly. You'll just have to use the terminal.
I think they (draftsight) only have 32bit verions, so I would be skipping any forced architecture options, maybe it won't work..

Code: Select all
 To circumvent that, make sure that these three packages are installed as well before continuing: libaudio2, libdirectfb-extra and libxcb-render-util0. (To get these, I checked the DraftSight.deb package with GDebi in a brand-new Ubuntu 10.10 32-bit install.)

--dependency list Ubuntu writer gave..
If it is really proving a problem, I might also have tried converting an .rpm package (64bit) to a .deb package and see if that worked out better..

http://www.debian.org/doc/FAQ/ch-pkgtools.en.html

Possible, but won't always work, depending on the package set
--one option, create your own deb package from the sources for the 64bit architecture, checking that you had the complete 64bit build setups required..
    If you are playing in the 64bit arena, you might find that is necessary sometimes..
8.5 How can I find out what package produced a particular file
zgrep foo Contents-ARCH.gz
This searches for files which contain the substring foo in their full path names. The files Contents-ARCH.gz (where ARCH represents the wanted architecture) reside in the major package directories (main, non-free, contrib) at a Debian FTP site (i.e. under /debian/dists/squeeze). A Contents file refers only to the packages in the subdirectory tree where it resides. Therefore, a user might have to search more than one Contents files to find the package containing the file foo. [/list]

This method has the advantage over dpkg --search in that it will find files in packages that are not currently installed on your system.

But, since you are trying that, Iw ould check the dpkg errros and see what you can make of 'EM
http://raphaelhertzog.com/2011/06/27/de ... ffer-copy/
http://raphaelhertzog.com/?s=dpkg+errors

Nope, I just use the 32bit version of draftsight on LXDE

Personally, if a 64bit version isn't readily already available, I don't try and make it work since I think a 32bit application whether that be a browser or an extension/plugin to a browser is working; I use that instead..
--then I stop worrying about the 64bit vs 32bit questioning..
Last edited by DrHu on Tue Oct 04, 2011 2:11 pm, edited 1 time in total.
User avatar
DrHu
Level 17
Level 17
 
Posts: 7104
Joined: Wed Jun 17, 2009 8:20 pm

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby GeneC on Tue Oct 04, 2011 2:08 pm

Thanks Dr Hu (Who?) :D

Sounds like more work, than I am qualified to do..
Still pretty much a newbie.

I see where folks got it to run on 64 but Ubuntu.
Looks like Debian is another story.

I've got a spare partition, perhaps I will just add a LMDE 32 bit install.
But, I am going to keep trying on the 64 bit. :wink:

=====================================


EDIT:

I did NOT have the ia32libs installed. I do now.
I had the other dependencies installed at the first try.
But, still get a similar error message.

gene@zordon ~ $ sudo dpkg -i --force-architecture DraftSight.deb
[sudo] password for gene:
dpkg: warning: overriding problem because --force enabled:
package architecture (i386) does not match system (amd64)
(Reading database ... 171750 files and directories currently installed.)
Unpacking dassault-systemes-draftsight (from DraftSight.deb) ...
access control disabled, clients can connect from any host
access control disabled, clients can connect from any host
/var/lib/dpkg/tmp.ci/ShowLicence: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
access control enabled, only authorized clients can connect
access control enabled, only authorized clients can connect
dpkg: error processing DraftSight.deb (--install):
subprocess new pre-installation script returned error exit status 127
Errors were encountered while processing:
DraftSight.deb



I'll keep working at it. :)
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Sparky Cin 2.2 (SID)
Manjaro .9.0dev Cin 2.4 (Testing)
Arch XFCE/Budgie
User avatar
GeneC
Level 7
Level 7
 
Posts: 1582
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby xircon on Tue Oct 04, 2011 2:26 pm

I have it installed and working, but installed it a while ago and can't remember if I had to do anything special to get it to work. It is version 11.2.705.
Code: Select all
Linux n5010 3.0.0-1-amd64 #1 SMP Sat Aug 27 16:21:11 UTC 2011 x86_64 GNU/Linux

Image
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby GeneC on Tue Oct 04, 2011 2:32 pm

Hi xircon

I saw your post on DraftSight while doing a search on it, and was hoping you would see this thread.
I am finding folks are saying that the new Beta .deb download can cause problems. I guess they are right.
The only downloads now are Beta's? that seems odd. Cant find any older versions.

Back to work on this... :x
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Sparky Cin 2.2 (SID)
Manjaro .9.0dev Cin 2.4 (Testing)
Arch XFCE/Budgie
User avatar
GeneC
Level 7
Level 7
 
Posts: 1582
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby xircon on Tue Oct 04, 2011 2:36 pm

Let me see if I still have the old deb on my system, unlikely as I had a big clear out a week back :( But anything else I can do to help, give me a shout.
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby GeneC on Tue Oct 04, 2011 2:43 pm

Thanks.
I had the bad habit of cleaning out my archives after every big update.. :lol:
MS Windows habit I think.
No worries.
I'll work at this, and if "no-go", then load a 32 LMDE on a spare partition.
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Sparky Cin 2.2 (SID)
Manjaro .9.0dev Cin 2.4 (Testing)
Arch XFCE/Budgie
User avatar
GeneC
Level 7
Level 7
 
Posts: 1582
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby xircon on Tue Oct 04, 2011 2:45 pm

Nope deleted :(

But does this help? It shows all the depends. I don't use it so will try the new deb of their website:

Code: Select all
Info for debian package '/home/molly/Downloads/DraftSight.deb':
 new debian package, version 2.0.
 size 79849876 bytes: control archive= 71532 bytes.
    2208 bytes,    12 lines      control             
      23 bytes,     2 lines      copyright           
      87 bytes,     3 lines      license.cs.conf     
   12156 bytes,   180 lines      license.cs.txt       
      86 bytes,     3 lines      license.de.conf     
   13030 bytes,   207 lines      license.de.txt       
      79 bytes,     3 lines      license.en.conf     
   11227 bytes,   180 lines      license.en.txt       
      85 bytes,     3 lines      license.es.conf     
   11880 bytes,   186 lines      license.es.txt       
      86 bytes,     3 lines      license.fr.conf     
   12855 bytes,   194 lines      license.fr.txt       
      85 bytes,     3 lines      license.it.conf     
   12437 bytes,   196 lines      license.it.txt       
      95 bytes,     3 lines      license.ja.conf     
   13614 bytes,   170 lines      license.ja.txt       
      87 bytes,     3 lines      license.ko.conf     
   11428 bytes,   140 lines      license.ko.txt       
      85 bytes,     3 lines      license.pl.conf     
   12071 bytes,   183 lines      license.pl.txt       
      85 bytes,     3 lines      license.pt.conf     
   12571 bytes,   192 lines      license.pt.txt       
     124 bytes,     3 lines      license.ru.conf     
   22064 bytes,   195 lines      license.ru.txt       
      86 bytes,     3 lines      license.tr.conf     
   11245 bytes,   171 lines      license.tr.txt       
      77 bytes,     3 lines      license.zh.conf     
      86 bytes,     3 lines      license.zh_TW.conf   
    9081 bytes,   115 lines      license.zh_TW.txt   
    8732 bytes,   130 lines      license.zh.txt       
   12490 bytes,   106 lines   *  postinst             #!/bin/bash
     888 bytes,    24 lines   *  preinst              #!/bin/bash
    6105 bytes,    59 lines   *  prerm                #!/bin/bash
   14372 bytes,     9 lines   *  ShowLicence         
 Package: dassault-systemes-draftsight
 Version: 2011.5.1081
 Section: applications
 Priority: extra
 Architecture: i386
 Pre-Depends: libexpat1 (>=2.0.1-4), libglib2.0-0 (>=2.22.3-0), libpcre3 (>=7.8-3), libselinux1 (>=2.0.85-2), zlib1g (>=1:1.2.3.3.dfsg-13), libc6 (>=2.10.1-0), libx11-6 (>=2:1.2.2-1), libxau6 (>=1:1.0.4-2), libxcomposite1 (>=1:0.4.0-4), libxcursor1 (>=1:1.1.9-1build1), libxdamage1 (>=1:1.1.1-4), libxdmcp6 (>=1:1.0.2-3), libxext6 (>=2:1.0.99.1-0), libxfixes3 (>=1:4.0.3-2build1), libxi6 (>=2:1.2.1-2), libxinerama1 (>=2:1.0.3-2), libxrandr2 (>=2:1.3.0-2), libxrender1 (>=1:0.9.4-2), libatk1.0-0 (>=1.28.0-0), libcairo2 (>=1.8.8-2), libdirectfb-extra (>=1.2.7-2), libfontconfig1 (>=2.6.0-1), libfreetype6 (>=2.3.9-5), libgtk2.0-0 (>=2.18.3-1), libpango1.0-0 (>=1.26.0-1), libpixman-1-0 (>=0.14.0-1), libpng12-0 (>=1.2.37-1), libxcb-render-util0 (>=0.3.6-1), libxcb-render0 (>=1.4-1), libxcb1 (>=1.4-1), debconf (>= 1.1) | debconf-2.0
 Depends: libcomerr2 (>=1.41.9-1), libdbus-1-3 (>=1.2.16-0), libexpat1 (>=2.0.1-4), libgcc1 (>=1:4.4.1-4), libgcrypt11 (>=1.4.4-2), libglib2.0-0 (>=2.22.3-0), libgpg-error0 (>=1.6-1), libkeyutils1 (>=1.2-10), libpcre3 (>=7.8-3), libuuid1 (>=2.16-1), zlib1g (>=1:1.2.3.3.dfsg-13), libc6 (>=2.10.1-0), libgl1-mesa-glx (>=7.6.0-1), libglu1-mesa (>=7.6.0-1), libice6 (>=2:1.0.5-1), libsm6 (>=2:1.1.0-2), libx11-6 (>=2:1.2.2-1), libxau6 (>=1:1.0.4-2), libxdamage1 (>=1:1.1.1-4), libxdmcp6 (>=1:1.0.2-3), libxext6 (>=2:1.0.99.1-0), libxfixes3 (>=1:4.0.3-2build1), libxrender1 (>=1:0.9.4-2), libxt6 (>=1:1.0.5-3), libxxf86vm1 (>=1:1.0.2-1), libaudio2 (>=1.9.2-1), libavahi-client3 (>=0.6.25-1), libavahi-common3 (>=0.6.25-1), libcups2 (>=1.4.1-5), libdrm2 (>=2.4.14-1), libfontconfig1 (>=2.6.0-1), libgnutls26 (>=2.8.3-2), libgssapi-krb5-2 (>=1.7dfsg~beta3-1), libk5crypto3 (>=1.7dfsg~beta3-1), libkrb5-3 (>=1.7dfsg~beta3-1), libkrb5support0 (>=1.7dfsg~beta3-1), libstdc++6 (>=4.4.1-4), libtasn1-3 (>=2.2-1), libxcb1 (>=1.4-1), sendmail
 Installed-Size: 210260
 Maintainer: Dassault Systemes <CrashReports@DraftSight.com>
 Homepage: www.3ds.com
 Description: With DraftSight, you can easily create professional CAD drawings. Supported file formats are DWT, DXF and DWG.
 
 
Do you wish to:
 - I)nstall the package now,
 - S)ave it to a file, or
 - Q)uit now
Your choice (I/S/Q)?
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby GeneC on Tue Oct 04, 2011 2:49 pm

Thanks... Looks like I have some work ahead of me. :lol:
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Sparky Cin 2.2 (SID)
Manjaro .9.0dev Cin 2.4 (Testing)
Arch XFCE/Budgie
User avatar
GeneC
Level 7
Level 7
 
Posts: 1582
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby xircon on Tue Oct 04, 2011 3:01 pm

Gene

Had to install sendmail to get it to install, it removed exim. but..........
Code: Select all
sudo dpkg -i --force-architecture DraftSight.deb
dpkg: warning: overriding problem because --force enabled:
 package architecture (i386) does not match system (amd64)
(Reading database ... 650982 files and directories currently installed.)
Preparing to replace dassault-systemes-draftsight 2011.5.1081 (using DraftSight.deb) ...
access control disabled, clients can connect from any host

(ShowLicence:24002): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

^^^^ repeated a few times - I cut them out!!!!!

(ShowLicence:24002): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
access control enabled, only authorized clients can connect
Unpacking replacement dassault-systemes-draftsight ...
Setting up dassault-systemes-draftsight (2011.5.1081) ...


And this may help.................

Code: Select all
 locate libgtk-x11-2.0.so.0
/usr/lib/libgtk-x11-2.0.so.0
/usr/lib/libgtk-x11-2.0.so.0.2400.4
/usr/lib32/libgtk-x11-2.0.so.0
/usr/lib32/libgtk-x11-2.0.so.0.2000.1


Runs fine, now asks for registration (hence sendmail :) )
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby GeneC on Tue Oct 04, 2011 3:06 pm

Synaptic wont let me install "sendmail". Broken dependencies.
But this is from a SID partiton.
Perhaps that is a problem.

I'll try this all again from the Testing partition. :wink:

EDIT:

(From Testing).

Nope still no good.
Cant install sendmail

sendmail:
Depends: sendmail-bin but it is not going to be installed


Code: Select all
gene@zordon ~ $ sudo dpkg -i --force-architecture DraftSight.deb
dpkg: warning: overriding problem because --force enabled:
 package architecture (i386) does not match system (amd64)
(Reading database ... 193135 files and directories currently installed.)
Unpacking dassault-systemes-draftsight (from DraftSight.deb) ...
access control disabled, clients can connect from any host
/var/lib/dpkg/tmp.ci/ShowLicence: error while loading shared libraries: libgtk-x11-2.0.so.0: wrong ELF class: ELFCLASS64
access control enabled, only authorized clients can connect
dpkg: error processing DraftSight.deb (--install):
 subprocess new pre-installation script returned error exit status 127
Errors were encountered while processing:
 DraftSight.deb
Last edited by GeneC on Tue Oct 04, 2011 3:18 pm, edited 1 time in total.
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Sparky Cin 2.2 (SID)
Manjaro .9.0dev Cin 2.4 (Testing)
Arch XFCE/Budgie
User avatar
GeneC
Level 7
Level 7
 
Posts: 1582
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby xircon on Tue Oct 04, 2011 3:08 pm

I follow Testing, Sid is a bit brown trousers for me, spent years following Mandriva Cooker, just want a computer that (nearly ;)) works!
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby GeneC on Tue Oct 04, 2011 3:51 pm

One step forwards and two steps back. :roll:

In Testing.
Had to add some dependencies to add "getmail"

Now install runs until "license agreement" gui comes on.
I accept, it continues and then fails.

Code: Select all
 gene@zordon ~ $ sudo dpkg -i --force-architecture DraftSight.deb
[sudo] password for gene:
dpkg: warning: overriding problem because --force enabled:
 package architecture (i386) does not match system (amd64)
(Reading database ... 194299 files and directories currently installed.)
Preparing to replace dassault-systemes-draftsight 2011.5.1081 (using DraftSight.deb) ...
access control disabled, clients can connect from any host

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libmurrine.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libmurrine.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libmurrine.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libmurrine.so: wrong ELF class: ELFCLASS64

(ShowLicence:2749): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so: wrong ELF class: ELFCLASS64
access control enabled, only authorized clients can connect
Unpacking replacement dassault-systemes-draftsight ...
Setting up dassault-systemes-draftsight (2011.5.1081) ...
/usr/bin/xdg-mime: 667: /usr/bin/xdg-mime: cannot create /root/.local/share/applications/defaults.list.new: Directory nonexistent
grep: /root/.local/share/applications/defaults.list.new: No such file or directory
/usr/bin/xdg-mime: 669: /usr/bin/xdg-mime: cannot create /root/.local/share/applications/defaults.list.new: Directory nonexistent
/usr/bin/xdg-mime: 671: /usr/bin/xdg-mime: cannot create /root/.local/share/applications/defaults.list.new: Directory nonexistent
mv: cannot stat `/root/.local/share/applications/defaults.list.new': No such file or directory
/usr/bin/xdg-mime: 667: /usr/bin/xdg-mime: cannot create /root/.local/share/applications/defaults.list.new: Directory nonexistent
grep: /root/.local/share/applications/defaults.list.new: No such file or directory
/usr/bin/xdg-mime: 669: /usr/bin/xdg-mime: cannot create /root/.local/share/applications/defaults.list.new: Directory nonexistent
/usr/bin/xdg-mime: 671: /usr/bin/xdg-mime: cannot create /root/.local/share/applications/defaults.list.new: Directory nonexistent
mv: cannot stat `/root/.local/share/applications/defaults.list.new': No such file or directory
/usr/bin/xdg-mime: 667: /usr/bin/xdg-mime: cannot create /root/.local/share/applications/defaults.list.new: Directory nonexistent
grep: /root/.local/share/applications/defaults.list.new: No such file or directory
/usr/bin/xdg-mime: 669: /usr/bin/xdg-mime: cannot create /root/.local/share/applications/defaults.list.new: Directory nonexistent
/usr/bin/xdg-mime: 671: /usr/bin/xdg-mime: cannot create /root/.local/share/applications/defaults.list.new: Directory nonexistent
mv: cannot stat `/root/.local/share/applications/defaults.list.new': No such file or directory
 


Putting this away as "UNSOLVED" for the time being.
(Unless someone sees something obviously wrong.)
Thanks all.

xircon, We were on the right track with the "getmail" . :?
Dont know why yours installed and mine would not?
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Sparky Cin 2.2 (SID)
Manjaro .9.0dev Cin 2.4 (Testing)
Arch XFCE/Budgie
User avatar
GeneC
Level 7
Level 7
 
Posts: 1582
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby xircon on Tue Oct 04, 2011 3:58 pm

Weird :?

I have a file in /root/.local/share/applications/ called defaults.list:

Code: Select all
cat defaults.list
[Default Applications]
application/x-extension-faillog=gedit-usercreated.desktop
application/vnd.dassault-systemes.draftsight-dwg=dassault-systemes_draftsight.desktop
application/vnd.dassault-systemes.draftsight-dxf=dassault-systemes_draftsight.desktop
application/vnd.dassault-systemes.draftsight-dwt=dassault-systemes_draftsight.desktop


It is related to DraftSight. Don't know what to do next :(

Steve
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby GeneC on Tue Oct 04, 2011 4:06 pm

Hey Steve

Thanks a lot for helping. :)
I am putting this on the back burner for the time being.
Heck, I am retired from CAD work anyway.
Just wanted to play.

If I solve this. I'll post.

Cheers.
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Sparky Cin 2.2 (SID)
Manjaro .9.0dev Cin 2.4 (Testing)
Arch XFCE/Budgie
User avatar
GeneC
Level 7
Level 7
 
Posts: 1582
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby xircon on Tue Oct 04, 2011 4:10 pm

Final thought - does /root/.local/share/applications exist on your system? and does defaults.list? Create and/or Delete or rename and have one last blast :)
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby phil on Tue Oct 04, 2011 4:22 pm

I got Draftsight working on 32 bit Mint XFCE but it did not work as good as CMS Intellicad on
Windows XP and I had work to do, so I abandoned it. And Draftsight costs more than CMS Intellicad.
13 Xfce, Win XP, GA-MA785GM-US2h, Athlon II X2 240, 4G mem, OCZ SSD, WD 230G, nVidia 210
13 Xfce, Win XP, N68C-5, Athlon II X2 255, 4G mem, OCZ SSD, WD 120G, nVidia 7025
13 Xfce, Win XP, N68C-5, Athlon II X2 250, 4G mem, OCZ SSD, WD 1T, nVidia 7025
phil
Level 3
Level 3
 
Posts: 142
Joined: Sun Dec 30, 2007 12:46 pm
Location: Consejo, Belize, Central America

Re: Has anyone gotten DraftSight CAD to run on LMDE 64bit?

Postby GeneC on Tue Oct 04, 2011 4:57 pm

Finally got it.

To recap

Download DraftSight .deb
(DraftSight CAD for Ubuntu Beta2 -32bit)

http://www.3ds.com/products/draftsight/ ... raftsight/

Download these dependencies from Synaptic
Code: Select all
libdirectfb-extra
libxcb-render-util0
libaudio2

sendmail-base (8.14.4-2)
sendmail-bin (8.14.4-2+b1)
sendmail-cf (8.14.4-2)

sendmail (8.14.4-2)
sensible-mda (8.14.4-2+b1)

ia32-libs
ia-32-libs-gtk
nvidia-glx-ia32


NOTE:
Sendmail packages remove (5) packages below.

exim4
exim4-base
exim4-config
exim4-daemon-light
libpq5


Nvidia-glx-ia32 for Nvidia cards only.

Put .deb in Home

Open terminal and run

Code: Select all
sudo dpkg -i --force-architecture DraftSight.deb


Keep your fingers crossed.

(Will work better with a light theme, this is Atolm)

Screenshot-1.png
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Sparky Cin 2.2 (SID)
Manjaro .9.0dev Cin 2.4 (Testing)
Arch XFCE/Budgie
User avatar
GeneC
Level 7
Level 7
 
Posts: 1582
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 5 guests