Can't mark text for copy/paste (Solved)

Questions about applications and software
Forum rules
Before you post please read this

Can't mark text for copy/paste (Solved)

Postby msm on Mon Oct 10, 2011 3:34 pm

For some reason it doesn't seem possible to mark text for copy/pasting. I usually hold down the left mouse button on my laptop whilst using the trackpad to roll over the text to be copied. But now when I hold down the left button a pop-up menu appears - the same menu as when clicking on the right mouse button,. Anyone know what could have caused this? I don't see anything unusual under Mouse Preferences.
Last edited by msm on Tue Oct 11, 2011 1:43 pm, edited 1 time in total.
msm
Level 3
Level 3
 
Posts: 138
Joined: Tue Mar 23, 2010 7:40 am
Location: Dublin, Ireland

Linux Mint is funded by ads and donations.
 

Re: Can't mark text for copy/paste

Postby Vermind on Mon Oct 10, 2011 5:53 pm

Hey,
I have the same issue since yesterday,
i.e. marking/painting/highlighting text with the mouse or keyboard or shortcuts causes the text to highlight, then un-highlight. If I highlight the same text twice, (for example ctrl-a ctrl-a) it works, but single highlight does not work.
The issue occurs also with automatic text highlight, such as when opening the Mint Menu and typing. My new search in the mint menu will be added to the end of the previous one, not replacing it, making it necessary to hold backspace and erase the previous search first before making a new one.
I think the same issue causes the need to copy or cut a file or folder twice as well. In nautilus, a single copy command does not enable the paste, but ctrl-c twice in a row works.

I am investigating why this is happening. I recently downgraded from direct debian testing to Mint testing.

Update: My issue was caused by the parcellite clipboard manager. I removed it and highlighting works.
Vermind
Level 1
Level 1
 
Posts: 8
Joined: Fri Aug 26, 2011 1:04 am

Re: Can't mark text for copy/paste

Postby msm on Tue Oct 11, 2011 4:49 am

I'm at work now, but I'll check when I come home if I have the parcellite clipboard manager installed. If it is I'll remove it to see if that helps. Thanks for your reply!
msm
Level 3
Level 3
 
Posts: 138
Joined: Tue Mar 23, 2010 7:40 am
Location: Dublin, Ireland

Re: Can't mark text for copy/paste

Postby Stanie on Tue Oct 11, 2011 8:17 am

Vermind wrote:Hey,
I have the same issue since yesterday,
i.e. marking/painting/highlighting text with the mouse or keyboard or shortcuts causes the text to highlight, then un-highlight. If I highlight the same text twice, (for example ctrl-a ctrl-a) it works, but single highlight does not work.
The issue occurs also with automatic text highlight, such as when opening the Mint Menu and typing. My new search in the mint menu will be added to the end of the previous one, not replacing it, making it necessary to hold backspace and erase the previous search first before making a new one.
I think the same issue causes the need to copy or cut a file or folder twice as well. In nautilus, a single copy command does not enable the paste, but ctrl-c twice in a row works.

I am investigating why this is happening. I recently downgraded from direct debian testing to Mint testing.

Update: My issue was caused by the parcellite clipboard manager. I removed it and highlighting works.


Thank you!!! I have had the same issue for a couple of weeks (see http://forums.linuxmint.com/viewtopic.php?f=199&t=81913) - removing parcellite solved it.

BTW you can still use parcellite, just not this rc version from lmde latest/incoming repo. I now use the old stable version 0.9.2 from debian stable and have no trouble with copy/paste or highlighting the text whatsoever :D
But if you know of any other good clipboard manager, let me know. I have tried lots of them both in lmde and mint main edition: glipper, clipper, glippy, diodon, clipit, even klipper in gnome desktop. I like parcellite most, because it is very lightweight without many dependencies and it can be launched without tray icon - that's how I use it.
Stanie
Level 1
Level 1
 
Posts: 11
Joined: Fri Aug 12, 2011 5:50 am

Re: Can't mark text for copy/paste

Postby Vermind on Tue Oct 11, 2011 12:06 pm

Actually, I downloaded the parcellite deb from the site at http://parcellite.sourceforge.net/?page_id=10 . It seems to work well and is the latest. My current version is Parcellite 1.0.2rc2.
Vermind
Level 1
Level 1
 
Posts: 8
Joined: Fri Aug 26, 2011 1:04 am

Re: Can't mark text for copy/paste

Postby Stanie on Tue Oct 11, 2011 1:34 pm

Vermind wrote:Actually, I downloaded the parcellite deb from the site at http://parcellite.sourceforge.net/?page_id=10 . It seems to work well and is the latest. My current version is Parcellite 1.0.2rc2.


Yeah, I know. I played a little with the latest 1.0.2rc5 from SoufceForge. It works also well. But in the end I decided to install the latest stable version 1.0.1 - just in case...
Stanie
Level 1
Level 1
 
Posts: 11
Joined: Fri Aug 12, 2011 5:50 am

Re: Can't mark text for copy/paste

Postby msm on Tue Oct 11, 2011 1:42 pm

Jeez, this is embarrassing. Just found out that the mouse settings were set to left handed which caused the issue for me. Don't know how that happened as I don't recall having set the settings to left-handed, but I guess I must have at some stage :shock:
msm
Level 3
Level 3
 
Posts: 138
Joined: Tue Mar 23, 2010 7:40 am
Location: Dublin, Ireland

Re: Can't mark text for copy/paste

Postby Vermind on Tue Oct 11, 2011 1:44 pm

msm wrote:Jeez, this is embarrassing. Just found out that the mouse settings were set to left handed which caused the issue for me. Don't know how that happened as I don't recall having set the settings to left-handed, but I guess I must have at some stage :shock:

Great that you found the cause. Now I don't feel so bad accidentally hijacking your thread :)
Vermind
Level 1
Level 1
 
Posts: 8
Joined: Fri Aug 26, 2011 1:04 am

Re: Can't mark text for copy/paste

Postby msm on Tue Oct 11, 2011 2:01 pm

Vermind wrote:
msm wrote:Jeez, this is embarrassing. Just found out that the mouse settings were set to left handed which caused the issue for me. Don't know how that happened as I don't recall having set the settings to left-handed, but I guess I must have at some stage :shock:

Great that you found the cause. Now I don't feel so bad accidentally hijacking your thread :)


No problem at all. Looks like other people benefited from it.
msm
Level 3
Level 3
 
Posts: 138
Joined: Tue Mar 23, 2010 7:40 am
Location: Dublin, Ireland

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 3 guests