Wine for LMDE?

Questions about applications and software
Forum rules
Before you post please read this

Wine for LMDE?

Postby /dev/urandom on Thu Oct 13, 2011 9:25 am

So what is the repository for LMDE where I can find Wine?
Linux is not the only answer! :: eD2k/Kad mirrors for Linux Mint and LMDE.
Users who misspell "Windows" as "Windoze" intentionally will be considered stupid.

Image
User avatar
/dev/urandom
Level 4
Level 4
 
Posts: 353
Joined: Sun Jul 17, 2011 8:02 pm

Linux Mint is funded by ads and donations.
 

Re: Wine for Mint?

Postby wyrdoak on Thu Oct 13, 2011 10:37 am

-Dell Mini Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(Maya-Xfce) LInux 3.2.0.57-generic(i686)
SolydX (32bit)
User avatar
wyrdoak
Level 6
Level 6
 
Posts: 1310
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: Wine for Mint?

Postby /dev/urandom on Thu Oct 13, 2011 10:55 am

That does not work for me, it says I use incompatible packages or something.
Linux is not the only answer! :: eD2k/Kad mirrors for Linux Mint and LMDE.
Users who misspell "Windows" as "Windoze" intentionally will be considered stupid.

Image
User avatar
/dev/urandom
Level 4
Level 4
 
Posts: 353
Joined: Sun Jul 17, 2011 8:02 pm

Re: Wine for Mint?

Postby wyrdoak on Thu Oct 13, 2011 11:18 am

by lmdeman on Wed Jul 13, 2011 5:19 am

FYI there is an unofficial repository for aptosid (debian based) from which you can easily install (and automatically update) the latest wine package.
CODE: SELECT ALL
deb http://frickelplatz.de/debian/ sid main

Add the line above to /etc/apt/sources.list.

I also changed the pinning policy by adding the following lines to /etc/apt/preferences, in order to avoid undesired updates from packages other than wine.
CODE: SELECT ALL
Package: *
Pin: origin frickelplatz.de
Pin-Priority: 200

Package: wine
Pin: origin frickelplatz.de
Pin-Priority: 800

(may not be the best policy ever, but it just worked in my case. If anyone knows a more robust one please let me know)

Update as usual:
CODE: SELECT ALL
sudo apt-get update

You may want to install their keyrings before installing the wine package:
CODE: SELECT ALL
sudo apt-get install frickelplatz-archive-keyring frickelplatz-keyring frickelplatz-keyrings

then you're ready to go with wine:
CODE: SELECT ALL
sudo apt-get install wine

of course you may use Synaptic instead.
I used it with LMDE for several months without problems then I dismissed it just because I got tired of wine.
Note that the repository is not officially supported (like many others) and you can find it down from time to time so try it at your own risk.
Also, mixing distribution repositories is not recommended for beginners; watch carefully every operation or you can easily screw up your system.
-Dell Mini Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(Maya-Xfce) LInux 3.2.0.57-generic(i686)
SolydX (32bit)
User avatar
wyrdoak
Level 6
Level 6
 
Posts: 1310
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: Wine for LMDE?

Postby proxima_centauri on Thu Oct 13, 2011 11:39 am

/dev/urandom,

Please don't resurrect threads with activity older than 6 months. It's much easier to create your own thread :D

* Posts split into own thread.
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3968
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: Wine for LMDE?

Postby /dev/urandom on Thu Oct 13, 2011 11:41 am

Hmm, I'm not a big fan of splitting the same subject over a dozen of topics...
Anyway, thanks for the hint!

---------------------------

OK, that did the trick. :)
Are the libs also included? Q4Wine did not find them.
Linux is not the only answer! :: eD2k/Kad mirrors for Linux Mint and LMDE.
Users who misspell "Windows" as "Windoze" intentionally will be considered stupid.

Image
User avatar
/dev/urandom
Level 4
Level 4
 
Posts: 353
Joined: Sun Jul 17, 2011 8:02 pm


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 3 guests