Installing lightDM on xfce

Questions about applications and software
Forum rules
Before you post please read this

Installing lightDM on xfce

Postby flaps on Wed Dec 07, 2011 8:30 am

Has anybody had any luck installing this in mint debian xfce? I can't get it working to save my life.
flaps
Level 1
Level 1
 
Posts: 1
Joined: Wed Dec 07, 2011 8:26 am

Linux Mint is funded by ads and donations.
 

Re: Installing lightDM on xfce

Postby Brian49 on Wed Dec 07, 2011 8:54 am

You are not alone - I had the same difficulty. After installing lightDM, there does't seem to be any way of making it appear on the list of available display managers. I just gave up after a while.
Brian49
Level 5
Level 5
 
Posts: 612
Joined: Thu Oct 29, 2009 2:27 pm

Re: Installing lightDM on xfce

Postby glenn4uk on Wed Dec 07, 2011 4:25 pm

I've been using lightdm on LMDE XFCE for several months. I don't recall any particular problems either with installation or in getting it to work. You can make it the default display manager by editing the file /etc/X11/default-display-manager. If I remember correctly, dpkg prompted me to choose a display manager when I installed lightdm or maybe when I removed gdm3.
glenn4uk
Level 1
Level 1
 
Posts: 8
Joined: Tue May 03, 2011 4:01 pm

Re: Installing lightDM on xfce

Postby xircon on Wed Dec 07, 2011 4:58 pm

Working here. What is the contents of /etc/X11/default-display-manager ? Should say /usr/sbin/lightdm.
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Installing lightDM on xfce

Postby diazepan11 on Thu Dec 29, 2011 4:10 pm

Hi. I installed lightdm but it doesn't show the users and i have to type them by myself. How can i show the users?
diazepan11
Level 1
Level 1
 
Posts: 34
Joined: Thu Dec 29, 2011 4:05 pm

Re: Installing lightDM on xfce

Postby xircon on Thu Dec 29, 2011 4:58 pm

Edit /etc/lightdm/lightdm.conf:
Code: Select all
greeter-hide-users=false


I think that should do it.
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Installing lightDM on xfce

Postby diazepan11 on Thu Dec 29, 2011 5:08 pm

no, it didn't show my user
diazepan11
Level 1
Level 1
 
Posts: 34
Joined: Thu Dec 29, 2011 4:05 pm

Re: Installing lightDM on xfce

Postby xircon on Thu Dec 29, 2011 5:09 pm

Will re-enable lightdm, been running gnome3. Back in a bit.

Works here, did you reboot or just log in/out? Did you remove the '#' from the beginning of the line? My conf file:
Code: Select all
#
# General configuration
#
# start-default-seat = True to always start one seat if none are defined in the configuration
# greeter-user = User to run greeter as
# minimum-display-number = Minimum display number to use for X servers
# minimum-vt = First VT to run displays on
# user-authority-in-system-dir = True if session authority should be in the system location
# guest-account-script = Script to be run to setup guest account
# log-directory = Directory to log information to
# run-directory = Directory to put running state in
# cache-directory = Directory to cache to
# xsessions-directory = Directory to find X sessions
# xgreeters-directory = Directory to find X greeters
#
[LightDM]
#start-default-seat=true
#greeter-user=lightdm
#minimum-display-number=0
#minimum-vt=7
#user-authority-in-system-dir=false
#guest-account-script=guest-account
#log-directory=/var/log/lightdm
#run-directory=/var/run/lightdm
#cache-directory=/var/cache/lightdm
#xsessions-directory=/usr/share/xsessions
#xgreeters-directory=/usr/share/xgreeters

#
# Seat defaults
#
# xserver-command = X server command to run
# xserver-layout = Layout to pass to X server
# xserver-config = Config file to pass to X server
# xserver-allow-tcp = True if TCP/IP connections are allowed to this X server
# xdmcp-manager = XDMCP manager to connect to (implies xserver-allow-tcp=true)
# xdmcp-port = XDMCP UDP/IP port to communicate on
# xdmcp-key = Authentication key to use for XDM-AUTHENTICATION-1 (stored in keys.conf)
# greeter-session = Session to load for greeter
# greeter-hide-users = True to hide the user list
# user-session = Session to load for users
# allow-guest = True if guest login is allowed
# guest-session = Session to load for guests (overrides user-session)
# session-wrapper = Wrapper script to run session with
# display-setup-script = Script to run when starting a greeter session (runs as root)
# greeter-setup-script = Script to run when starting a greeter (runs as root)
# session-setup-script = Script to run when starting a user session (runs as root)
# session-cleanup-script = Script to run when quitting a user session (runs as root)
# autologin-guest = True to log in as guest by default
# autologin-user = User to log in with by default (overrides autologin-guest)
# autologin-user-timeout = Number of seconds to wait before loading default user
# autologin-session = Session to load for automatic login (overrides user-session)
# exit-on-failure = True if the daemon should exit if this seat fails
#
[SeatDefaults]
#xserver-command=X
#xserver-layout=
#xserver-config=
xserver-allow-tcp=false
#xdmcp-manager=
#xdmcp-port=177
#xdmcp-key=
#greeter-session=example-gtk-gnome
greeter-hide-users=false
user-session=lightdm-xsession
#allow-guest=true
#guest-session=UNIMPLEMENTED
session-wrapper=/etc/X11/Xsession
#display-setup-script=
#greeter-setup-script=
#session-setup-script=
#session-cleanup-script=
#autologin-guest=false
#autologin-user=
#autologin-user-timeout=0
#autologin-session=UNIMPLEMENTED
#exit-on-failure=false

#
# Seat configuration
#
# Each seat must start with "Seat:".
# Uses settings from [SeatDefaults], any of these can be overriden by setting them in this section.
#
#[Seat:0]

#
# XDMCP Server configuration
#
# enabled = True if XDMCP connections should be allowed
# port = UDP/IP port to listen for connections on
# key = Authentication key to use for XDM-AUTHENTICATION-1 or blank to not use authentication (stored in keys.conf)
#
# The authentication key is a 56 bit DES key specified in hex as 0xnnnnnnnnnnnnnn.  Alternatively
# it can be a word and the first 7 characters are used as the key.
#
[XDMCPServer]
#enabled=false
#port=177
#key=

#
# VNC Server configuration
#
# enabled = True if VNC connections should be allowed
# port = TCP/IP port to listen for connections on
#
[VNCServer]
#enabled=false
#port=5900
#width=1024
#height=768
#depth=8
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Installing lightDM on xfce

Postby diazepan11 on Thu Dec 29, 2011 5:58 pm

I rebooted it. Here's my conf file

Code: Select all
#
# General configuration
#
# start-default-seat = True to always start one seat if none are defined in the configuration
# greeter-user = User to run greeter as
# minimum-display-number = Minimum display number to use for X servers
# minimum-vt = First VT to run displays on
# user-authority-in-system-dir = True if session authority should be in the system location
# guest-account-script = Script to be run to setup guest account
# log-directory = Directory to log information to
# run-directory = Directory to put running state in
# cache-directory = Directory to cache to
#
[LightDM]
#start-default-seat=true
#greeter-user=lightdm
#minimum-display-number=0
#minimum-vt=7
#user-authority-in-system-dir=false
#guest-account-script=guest-account
#log-directory=/var/log/lightdm
#run-directory=/var/run/lightdm
#cache-directory=/var/cache/lightdm

#
# Seat defaults
#
# xserver-command = X server command to run
# xserver-layout = Layout to pass to X server
# xserver-config = Config file to pass to X server
# xdmcp-manager = XDMCP manager to connect to
# xdmcp-port = XDMCP UDP/IP port to communicate on
# xdmcp-key = Authentication key to use for XDM-AUTHENTICATION-1 (stored in keys.conf)
# xsessions-directory = Directory to find X sessions
# xgreeters-directory = Directory to find X greeters
# greeter-session = Session to load for greeter
# greeter-hide-users = True to hide the user list
# user-session = Session to load for users
# allow-guest = True if guest login is allowed
# guest-session = Session to load for guests (overrides user-session)
# session-wrapper = Wrapper script to run session with
# autologin-guest = True to log in as guest by default
# autologin-user = User to log in with by default (overrides autologin-guest)
# autologin-user-timeout = Number of seconds to wait before loading default user
# autologin-session = Session to load for automatic login (overrides user-session)
#
[SeatDefaults]
#xserver-command=X
#xserver-layout=
#xserver-config=
#xdmcp-manager=
#xdmcp-port=177
#xdmcp-key=
#xsessions-directory=/usr/share/xsessions
#xgreeters-directory=/usr/share/xgreeters
#greeter-session=example-gtk-gnome
greeter-hide-users=false
user-session=lightdm-xsession
#allow-guest=true
#guest-session=UNIMPLEMENTED
session-wrapper=/etc/X11/Xsession
#autologin-guest=false
#autologin-user=
#autologin-user-timeout=0
#autologin-session=UNIMPLEMENTED

#
# Seat configuration
#
# Each seat must start with "Seat:".
# Uses settings from [SeatDefaults], any of these can be overriden by setting them in this section.
#
#[Seat:0]

#
# XDMCP Server configuration
#
# enabled = True if XDMCP connections should be allowed
# port = UDP/IP port to listen for connections on
# key = Authentication key to use for XDM-AUTHENTICATION-1 or blank to not use authentication (stored in keys.conf)
#
# The authentication key is a 56 bit DES key specified in hex as 0xnnnnnnnnnnnnnn.  Alternatively
# it can be a word and the first 7 characters are used as the key.
#
[XDMCPServer]
#enabled=false
#port=177
#key=


BTW: It didn't worked with your conf file
diazepan11
Level 1
Level 1
 
Posts: 34
Joined: Thu Dec 29, 2011 4:05 pm

Re: Installing lightDM on xfce

Postby xircon on Thu Dec 29, 2011 6:26 pm

Then I am at a loss :(

:Edit:

Image

Just to prove it is working here.
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Installing lightDM on xfce

Postby diazepan11 on Thu Dec 29, 2011 6:54 pm

Well, this is how it looks in my computer

Image

At the beginning looks like this (and i can't use the mouse, so i had to select other with the keyboard)

Image

After I chose other (now the mouse works)

If you can't solve it, don't worry. I'll get back to gdm3
diazepan11
Level 1
Level 1
 
Posts: 34
Joined: Thu Dec 29, 2011 4:05 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: Google Feedfetcher and 5 guests