recovery?

Questions about applications and software
Forum rules
Before you post please read this

recovery?

Postby billt79 on Tue Dec 13, 2011 4:27 pm

Hi,
Not sure of this is the correct place but i didnt see a better one. the other day I tried to install a piece of software using a script, and i ran it as root but forgot to set a prefix, so it installed straight to the root drive, this caused a problem as it overwrote the bin folder, nothing else. i had an old copy of it on a backup, so i copied it over, and i get to kdm, and the mouse and keyboard don't work. If i boot into recovery and run startx as root, then it loads an xserver but i get notifications saying the keyboard and touchpad configurations aren't supported and the plasma deskop crashes. Is there a way to fix this, as i have done a lot to that install and it would be a massive faff redoing it all.

cheers, Bill.
billt79
Level 1
Level 1
 
Posts: 20
Joined: Mon Jul 25, 2011 7:08 pm

Linux Mint is funded by ads and donations.
 

Re: recovery?

Postby Gerd50 on Tue Dec 13, 2011 8:05 pm

Try this, boot the recovery mode and use the command

Code: Select all
telinit 5

you should have a working system now. Open the terminal and put in

Code: Select all
ls -l /etc/rc*.d/*udev*

if you get something like this

Code: Select all
lrwxrwxrwx 1 root root 19  4. Jul 23:27 /etc/rc0.d/K01udev-mtab -> ../init.d/udev-mtab
    lrwxrwxrwx 1 root root 14 29. Jun 21:39 /etc/rc0.d/K02udev -> ../init.d/udev
    lrwxrwxrwx 1 root root 19  4. Jul 23:27 /etc/rc1.d/K01udev-mtab -> ../init.d/udev-mtab
    lrwxrwxrwx 1 root root 14 29. Jun 21:39 /etc/rc1.d/K02udev -> ../init.d/udev
    lrwxrwxrwx 1 root root 19 23. Aug 22:06 /etc/rc2.d/K01udev-mtab -> ../init.d/udev-mtab
    lrwxrwxrwx 1 root root 14 13. Sep 22:28 /etc/rc2.d/S02udev -> ../init.d/udev
    lrwxrwxrwx 1 root root 19  4. Jul 23:27 /etc/rc3.d/K01udev-mtab -> ../init.d/udev-mtab
    lrwxrwxrwx 1 root root 14 29. Jun 21:39 /etc/rc3.d/K02udev -> ../init.d/udev
    lrwxrwxrwx 1 root root 19  4. Jul 23:27 /etc/rc4.d/K01udev-mtab -> ../init.d/udev-mtab
    lrwxrwxrwx 1 root root 14 29. Jun 21:39 /etc/rc4.d/K02udev -> ../init.d/udev
    lrwxrwxrwx 1 root root 14 20. Sep 21:47 /etc/rc5.d/S02udev -> ../init.d/udev
    lrwxrwxrwx 1 root root 19 20. Sep 23:33 /etc/rc5.d/S13udev-mtab -> ../init.d/udev-mtab
    lrwxrwxrwx 1 root root 19  4. Jul 23:27 /etc/rc6.d/K01udev-mtab -> ../init.d/udev-mtab
    lrwxrwxrwx 1 root root 14 29. Jun 21:39 /etc/rc6.d/K02udev -> ../init.d/udev
    lrwxrwxrwx 1 root root 14 24. Feb 2010  /etc/rcS.d/S02udev -> ../init.d/udev
    lrwxrwxrwx 1 root root 19 25. Feb 2010  /etc/rcS.d/S13udev-mtab -> ../init.d/udev-mtab

delete all the udev links from rc0.d to rc6.d. Don't touch rcS.d, it's needed as it is.
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: recovery?

Postby billt79 on Wed Dec 14, 2011 9:08 am

hi,

Ran the commands below, the telinit 5 command, and the xserver started and went to kdm like normal but the keyboard and touchpad still didnt work, so i ran the 2nd command and it only listed symlinks in rcs.d, an as they are needed i didnt fiddle with them. I had to run that command in the recovery terminal because i still cant use the xserver, any other ideas?
Code: Select all
telinit 5
ls -l /etc/rc*.d/*udev*


Cheers, Bill.
billt79
Level 1
Level 1
 
Posts: 20
Joined: Mon Jul 25, 2011 7:08 pm

Re: recovery?

Postby Gerd50 on Wed Dec 14, 2011 10:40 am

Sorry, no. The only reason i know for tochpad/mouse & keyboard not working is the rc0 - rc6 udev stuff.
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: recovery?

Postby billt79 on Wed Dec 14, 2011 12:30 pm

Any packages i could reinstall?, im going to boot into it now and re install the xserver and xorg stuff see if that helps, providing i can connect it to the ethernet from the recovery terminal =p
billt79
Level 1
Level 1
 
Posts: 20
Joined: Mon Jul 25, 2011 7:08 pm

Re: recovery?

Postby billt79 on Wed Dec 14, 2011 2:35 pm

Well i reinstalled some stuff, and got to my desktop but still no mouse or keypad, although i got a segmentation error on something, not sure if that has anything to do with it?

EDIT: cant be udev i tried a usb mouse, and i have reinstalled just about everything to do with any inputs, guess i have got to reinstall :(
billt79
Level 1
Level 1
 
Posts: 20
Joined: Mon Jul 25, 2011 7:08 pm


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 5 guests