Sid-based LMDE with GNOME Shell

Questions about applications and software
Forum rules
Before you post please read this

Sid-based LMDE with GNOME Shell

Postby msx_ on Sat Dec 24, 2011 10:01 pm

Would it be possible to base LMDE in Sid instead of Testing - which have rather old kernel and packages? It would be *awesome* to have a much newer LMDE with GNOME Shell as main DE.
BTW, Lisa main edition rocks.
User avatar
msx_
Level 1
Level 1
 
Posts: 29
Joined: Fri Dec 23, 2011 4:57 pm

Linux Mint is funded by ads and donations.
 

Re: Sid-based LMDE with GNOME Shell

Postby michaelzap on Sat Dec 24, 2011 10:46 pm

msx_ wrote:Would it be possible to base LMDE in Sid instead of Testing - which have rather old kernel and packages? It would be *awesome* to have a much newer LMDE with GNOME Shell as main DE.
BTW, Lisa main edition rocks.
That's what I do, and what a lot of others seem to be doing as well. Just change your sources to unstable and be sure to check the "BREAKAGES!" thread before updating. Some minor caveats: You may lose some "Mintiness," especially if you remove the Mint repos from your sources list (which is what I did), and you should probably get comfortable updating from the command line or by using Synaptic instead of with the Mint Updater.

I haven't had any major glitches at all, and my LMDE system is about a year old now (and tracking unstable for much of that).
michaelzap
Level 3
Level 3
 
Posts: 160
Joined: Sat Sep 11, 2010 9:32 pm

Re: Sid-based LMDE with GNOME Shell

Postby cwwgateway on Sat Dec 24, 2011 10:47 pm

Yes, it is. You have to change your /etc/apt/sources.list to the following
Code: Select all
deb http://ftp.us.debian.org/debian/ sid main contrib non-free
deb http://security.debian.org/ sid/updates main contrib non-free
deb http://ftp.us.debian.org/debian/ sid-proposed-updates main contrib non-free
deb http://www.debian-multimedia.org sid main non-free

It's something like this, you can add/remove repos (I included the main repos and the multimedia one. This is what comes by default in lmde). Note that sid can be extremely unstable and can break your system. This is for the US only. For other countries, go to http://debgen.simplylinux.ch/index.php and change the release tp sid, the country to the country that you're in, and for default lmde repos (or at least the sid equivalents) select the debian main repo, the debian updates repo, the debian security updates repo, and the third party multimedia repo. Assuming you want the sid equivalents to the lmde repos, don't check any of the source repos. You can copy the sources.list file that comes up directly or remove the extraneous things that are surrounded in hashes.
Dell XPS 15 l502x - Debian Testing 64-bit NetInst Xfce, SolydX 64-bit Debian Testing, SolydK 64-bit SolydXK Testing
Old Gateway Pentium 4 Desktop - Arch Linux 64-bit Xfce and SolydX 32-bit Sid
cwwgateway
Level 5
Level 5
 
Posts: 839
Joined: Fri Nov 11, 2011 10:44 pm

Re: Sid-based LMDE with GNOME Shell

Postby msx_ on Sun Dec 25, 2011 1:12 am

Thanks guys!
Because Sid is somewhat unstable ;) I would like a aptosid/siduction approach for LMDE.
Nevermind, you confirmed my idea of manually changing LMDE repositories with which I will play tomorrow Sunday :D
User avatar
msx_
Level 1
Level 1
 
Posts: 29
Joined: Fri Dec 23, 2011 4:57 pm

Re: Sid-based LMDE with GNOME Shell

Postby wyrdoak on Sun Dec 25, 2011 1:22 am

just for another idea, here's my sources.list
Code: Select all
## SID
#
deb http://packages.linuxmint.com/ debian main upstream import
deb http://ftp.debian.org/debian unstable main contrib non-free
deb http://www.debian-multimedia.org sid main non-free
-Dell Mini Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(Maya-Xfce) LInux 3.2.0.57-generic(i686)
SolydX (32bit)
User avatar
wyrdoak
Level 6
Level 6
 
Posts: 1313
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: Sid-based LMDE with GNOME Shell

Postby hkbruvold on Mon Dec 26, 2011 8:55 pm

I can't seem to get any connection to the debian.org sources or the skype sources.
I used the sources.list created from http://debgen.simplylinux.ch/index.php

This is what I have in the sources.list
Code: Select all
deb http://ftp.no.debian.org/debian/ sid main contrib non-free
deb http://security.debian.org/ sid/updates main contrib non-free
deb http://ftp.no.debian.org/debian/ sid-proposed-updates main contrib non-free
deb http://www.debian-multimedia.org sid main non-free
deb http://download.skype.com/linux/repos/debian/ stable non-free
deb http://www.lamaresh.net/apt sid main


when running apt-get update I get "W: Failed to fetch [...] 404 Not Found"
And most other stuff is ignored, or that is what I guess the "Ign" means.
hkbruvold
Level 1
Level 1
 
Posts: 2
Joined: Mon Dec 26, 2011 8:42 pm

Re: Sid-based LMDE with GNOME Shell

Postby msx_ on Mon Jan 02, 2012 2:24 am

Hi folks, I've been über-busy these days and haven't got any time to play with this, I will be reporting back my experiences once I try it.
Thanks everyone who responded.
User avatar
msx_
Level 1
Level 1
 
Posts: 29
Joined: Fri Dec 23, 2011 4:57 pm

Re: Sid-based LMDE with GNOME Shell

Postby andrew5859 on Thu Jan 05, 2012 5:22 pm

Hello everyone,

I've been in the process of a "sudo aptitude safe-upgrade" which I started oh, about 2 hrs ago....when it started, it brings up like this:

resolving dependencies...
open: 446600; closed: 489100; defer: 93; conflict: 208

Does anyone know what this means or what's going on & why it's taking so long...any input is welcome...cheers


Andrew
Dell Latitude D810/2.26Ghz Intel/2GB Crucial/250GB WD/nVidia Quadro FX 1400 256MB/Intel Pro Wireless 2200BG
Win7 Bus 32 bit/LMDE-Sid-MATE 32/64 Tracking Sid


Image
User avatar
andrew5859
Level 4
Level 4
 
Posts: 418
Joined: Fri Mar 26, 2010 12:58 pm
Location: Boardman, Ohio USA

Re: Sid-based LMDE with GNOME Shell

Postby jlsmith722 on Thu Jan 05, 2012 7:19 pm

Andrew:
You may want to stop the "aptitude safe-upgrade" and substitute "sudo apt-get dist-upgrade". The apt-get approach is what was recommended in the "Tracking testing & Tracking sid" forums. I just tried both on my system, LMDE tracking sid , and they gave different results. The aptitude way wanted remove a bunch of packages, and apt-get didn't want to do anything. I had just recently done the apt-get dist-pgrade.

Jim
[size=85]Being intelligent is not a felony. But most societies evaluate it as at least a misdemeanor.
Robert Heinlein
User avatar
jlsmith722
Level 1
Level 1
 
Posts: 48
Joined: Fri Mar 05, 2010 9:38 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 5 guests