[SOLVED] digikam error, will not launch

Questions about applications and software
Forum rules
Before you post please read how to get help

[SOLVED] digikam error, will not launch

Postby adasilva on Thu Jan 05, 2012 10:52 am

Edit: Upon restarting, digikam now launches from both menu and command line. Sorry for taking up your time with this post... :oops:

Hi everyone. I am having an issue with digikam. When I installed it, there was no link in the menu, but the program worked fine from the command line. While trying to fix this minor issue, I seem to have gotten in over my head... I don't remember all of the steps, but I was editing the digikam.desktop files in /usr/share/applications/kde4/ and /usr/share/gnome/applications/. At some point, digikam stopped launching at all, giving me this error:
Code: Select all
$ digikam
KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work
QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is still in use, all queries will cease to work.

Then nothing. I replaced the files that I changed with the backups I had made, but still I get this error. I even tried to uninstall and install digikam, to no effect. I found another thread which suggests removing
Code: Select all
-caption %c %i
from the .desktop files, which did not help either. Any advice?

Edit: I am using LMDE, 64bit.
adasilva
Level 1
Level 1
 
Posts: 6
Joined: Thu Jan 05, 2012 10:36 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 5 guests

cron