Cannot install Blender

Questions about applications and software
Forum rules
Before you post please read this

Cannot install Blender

Postby crazypenguin2011 on Sun Jan 08, 2012 1:20 pm

hello! i was trying to install Blender but this is what i get:

sudo apt-get install blender
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
blender : Depends: libavdevice52 (>= 4:0.6-1~) but it is not going to be installed or
libavdevice-extra-52 (>= 4:0.6-1~) but it is not installable
E: Broken packages

what shell i do in a situation like this?
crazypenguin2011
Level 1
Level 1
 
Posts: 5
Joined: Fri Dec 23, 2011 5:50 pm

Linux Mint is funded by ads and donations.
 

Re: Cannot install Blender

Postby Aging Technogeek on Sun Jan 08, 2012 1:38 pm

Open a terminal and run

Code: Select all
sudo dpkg --configure -a


This should clear your broken package.

Hopefully that's all that's preventing the installation from proceeding.
Image

Registered Linux User 483387
User avatar
Aging Technogeek
Level 13
Level 13
 
Posts: 4605
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: Cannot install Blender

Postby crazypenguin2011 on Sun Jan 08, 2012 2:19 pm

still the same. i ran the command. it has no output. i still have the same error
crazypenguin2011
Level 1
Level 1
 
Posts: 5
Joined: Fri Dec 23, 2011 5:50 pm

Re: Cannot install Blender

Postby porternet on Wed Jan 11, 2012 5:13 pm

I've had exactly the same error.
There is a solution https://bugs.launchpad.net/linuxmint/+bug/868802.

But I've got these warnings in console:
dpkg: warning: downgrading gstreamer0.10-ffmpeg from 1:0.10.11-4.1 to 0.10.11-4.
dpkg: warning: downgrading libavformat52 from 5:0.6.3-0.0 to 4:0.6.2-5.
dpkg: warning: downgrading libavcodec52 from 5:0.6.3-0.0 to 4:0.6.2-5.
dpkg: warning: downgrading libavutil50 from 5:0.6.3-0.0 to 4:0.6.2-5.

Are these packages important?
Actually I've tried to push Refresh button in Update Manager and cannot see them in list of packages that should be updated.
porternet
Level 1
Level 1
 
Posts: 2
Joined: Wed Jan 11, 2012 5:02 pm

Re: Cannot install Blender

Postby porternet on Wed Jan 11, 2012 5:41 pm

Also I've got 2.58 blender version via terminal install instead of current 2.61.
So I've just downloaded standalone version from blender.org and it works fine.
porternet
Level 1
Level 1
 
Posts: 2
Joined: Wed Jan 11, 2012 5:02 pm

Re: Cannot install Blender

Postby telenux on Sun Jan 15, 2012 1:31 pm

I have 2.58 showing in the repositories, too. 2.61 is the up-to-date version. So, to use this version, I need to install from the Blender website (blender.org) then?

The Blender site shows ver. 2.61 needs Python 3.2 and glibc 2.7. But, Python is not at the newest version in the repo (not the latest in most distros, actually) and same with glibc, I think.

The Blender 2.61 install page shows 3.2 and 2.7 versions, respectively, will be included, however. I guess this question is dumb as I'm sure it will deal with the two versions and not conflict, right? This is standard in many applications.

I guess I'll do what porternet did unless someone follows up with a post suggesting another option. I suppose an older Blender version would work but I might as well install the latest unless there is some reason not to.

P.S. I'm using LMDE, too, but 2.6.39 (kernel) is installed so I guess some applications are a bit dated but not too much.
telenux
Level 3
Level 3
 
Posts: 164
Joined: Tue Nov 06, 2007 2:52 am


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 2 guests