[SOLVED] Some packages could not be updated

Questions about applications and software
Forum rules
Before you post please read this

[SOLVED] Some packages could not be updated

Postby thePhantom on Sat Jan 21, 2012 10:20 pm

Hello there,
I'm using LMDE from more than 1 year, all goes ok, but from many months i'm having a problem with my update. If I run apt-get update/upgrade/dist-upgrade , some packages could not be updated. These are the packages:

Code: Select all
  xorg xserver-xorg xserver-xorg-core xserver-xorg-dev
  xserver-xorg-input-evdev xserver-xorg-input-synaptics
  xserver-xorg-input-wacom xserver-xorg-video-apm xserver-xorg-video-ark
  xserver-xorg-video-ati xserver-xorg-video-chips xserver-xorg-video-cirrus
  xserver-xorg-video-fbdev xserver-xorg-video-i128 xserver-xorg-video-i740
  xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-neomagic xserver-xorg-video-openchrome
  xserver-xorg-video-r128 xserver-xorg-video-radeon
  xserver-xorg-video-rendition xserver-xorg-video-s3
  xserver-xorg-video-s3virge xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware
  xserver-xorg-video-voodoo


If I try to install for example "xserver-xorg" it returns this error:
Code: Select all
xserver-xorg: Depends: xserver-xorg-core (> = 2:1.11) but 2:1.10.4-1 is the version to be installed


Have you any idea? I never edited my apt source.list, and I always update my system with:
Code: Select all
apt-get update && apt-get -y upgrade && apt-get -y dist-upgrade


Thank you.
Last edited by thePhantom on Sun Jan 22, 2012 10:22 am, edited 1 time in total.
thePhantom
Level 1
Level 1
 
Posts: 7
Joined: Sat Jan 21, 2012 10:08 pm

Linux Mint is funded by ads and donations.
 

Re: Some packages could not be updated

Postby zerozero on Sat Jan 21, 2012 10:49 pm

hi,
and if you try to install xserver-xorg-core what kind of msg you get?
Code: Select all
sudo apt-get install xserver-xorg-core
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: Some packages could not be updated

Postby thePhantom on Sat Jan 21, 2012 10:55 pm

Hmm... Package not found ... :shock:
thePhantom
Level 1
Level 1
 
Posts: 7
Joined: Sat Jan 21, 2012 10:08 pm

Re: Some packages could not be updated

Postby zerozero on Sat Jan 21, 2012 11:16 pm

that's weird :shock: that pkg is available in all debian releases http://packages.debian.org/search?suite=all&section=all&arch=any&searchon=names&keywords=xserver-xorg-core
can you please show us your sources.list, the command
Code: Select all
inxi -r
will tell you that
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: Some packages could not be updated

Postby thePhantom on Sun Jan 22, 2012 9:09 am

I know... This is the list:
Code: Select all
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream import romeo
           deb http://ftp.debian.org/debian testing main contrib non-free
           deb http://security.debian.org/ testing/updates main contrib non-free
           deb http://www.debian-multimedia.org testing main non-free
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/google-talkplugin.list
           deb http://dl.google.com/linux/talkplugin/deb/ stable main
thePhantom
Level 1
Level 1
 
Posts: 7
Joined: Sat Jan 21, 2012 10:08 pm

Re: Some packages could not be updated

Postby zerozero on Sun Jan 22, 2012 9:19 am

just to be completely sure, you did copy&past the command above? there's no change for a spelling mistake? did you double-check your typing?
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: Some packages could not be updated

Postby thePhantom on Sun Jan 22, 2012 9:30 am

I confirm:
Code: Select all
# inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream import romeo
           deb http://ftp.debian.org/debian testing main contrib non-free
           deb http://security.debian.org/ testing/updates main contrib non-free
           deb http://www.debian-multimedia.org testing main non-free
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/google-talkplugin.list
           deb http://dl.google.com/linux/talkplugin/deb/ stable main
thePhantom
Level 1
Level 1
 
Posts: 7
Joined: Sat Jan 21, 2012 10:08 pm

Re: Some packages could not be updated

Postby zerozero on Sun Jan 22, 2012 9:32 am

no, sorry, my mistake, i meant
Code: Select all
sudo apt-get install xserver-xorg-core
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: Some packages could not be updated

Postby thePhantom on Sun Jan 22, 2012 9:38 am

:oops: sorry... Typos error... :oops:

Code: Select all
apt-get install xserver-xorg-core
[...]
The following packages have unmet dependencies:
  xserver-xorg-core: Depends: libpixman-1-0 (> = 0.21.6) but 0.20.2-0ubuntu1 is the version to be installed
E: Broken packages


if I try to install libpixman-1-0 (apt-get install libpixman-1-0) it says that it is already installed.
thePhantom
Level 1
Level 1
 
Posts: 7
Joined: Sat Jan 21, 2012 10:08 pm

Re: Some packages could not be updated

Postby zerozero on Sun Jan 22, 2012 9:49 am

no worries 8) happens :lol:
i was kinda expecting for that libpixman error but when you said that xserver-xorg-core couldn't be found i was lost;

that is a "well known" issue :shock:
look here viewtopic.php?f=198&t=70230&p=501655#p501223 and here viewtopic.php?f=198&t=67502&p=482881&hilit=libpixman#p482881 for some answers
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: Some packages could not be updated

Postby thePhantom on Sun Jan 22, 2012 10:21 am

Thank you! Solved by forcing unstable version! 8)
I hope that this will not create troubles for the future system updates... Does this could be possible?
thePhantom
Level 1
Level 1
 
Posts: 7
Joined: Sat Jan 21, 2012 10:08 pm

Re: [SOLVED] Some packages could not be updated

Postby zerozero on Sun Jan 22, 2012 10:25 am

don't think so, i did the same long time ago and everything is running smooth;
the only thing that you have to be aware (it's on the warnings on the pages i linked you to) is that the fonts might loose some of its config (i cant see the difference but some do)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: [SOLVED] Some packages could not be updated

Postby thePhantom on Sun Jan 22, 2012 10:29 am

good! Many thanks ;)
Bye!
thePhantom
Level 1
Level 1
 
Posts: 7
Joined: Sat Jan 21, 2012 10:08 pm

Re: Some packages could not be updated

Postby andrew5859 on Tue Jan 24, 2012 7:55 pm

thePhantom wrote::oops: sorry... Typos error... :oops:

Code: Select all
apt-get install xserver-xorg-core
[...]
The following packages have unmet dependencies:
  xserver-xorg-core: Depends: libpixman-1-0 (> = 0.21.6) but 0.20.2-0ubuntu1 is the version to be installed
E: Broken packages


if I try to install libpixman-1-0 (apt-get install libpixman-1-0) it says that it is already installed.



I have this same issue with my laptop....zz, I followed the links and looked at and tried to implement the solutions, but still come up with dependency problems....if you want to know my repo list, this is it:

Repos: Active apt sources in file: /etc/apt/sources.list
deb http://packages.linuxmint.com/ debian main upstream import backport romeo
deb http://www.debian-multimedia.org sid main non-free
deb http://ftp.us.debian.org/debian/ sid main contrib non-free
deb http://www.debian-multimedia.org wheezy main non-free
deb http://tridex.net/repo/debian/ wheezy main
can anyone help....please
Dell Latitude D810/2.26Ghz Intel/2GB Crucial/250GB WD/nVidia Quadro FX 1400 256MB/Intel Pro Wireless 2200BG
Win7 Bus 32 bit/LMDE-Sid-MATE 32/64 Tracking Sid


Image
User avatar
andrew5859
Level 4
Level 4
 
Posts: 418
Joined: Fri Mar 26, 2010 12:58 pm
Location: Boardman, Ohio USA

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 2 guests