gnome15 install help <SOLVED>

Questions about applications and software
Forum rules
Before you post please read how to get help

gnome15 install help <SOLVED>

Postby posetown on Sun Feb 12, 2012 9:15 pm

hello

im trying to install gnome15,its a driver for logitech g19 keyboard.
so i downloaded the source, Checked the pre-requisites, got all the things, un tar the file, ran ./configure
and i get a "configure: error: You must also provide the location of your distributions udev rules using --enable-udev=path-to-rules-directory"

I have no clue what that means, this is my first time ever trying to compile from source, i have googled all over for this specific error and cant find any thing that helps.
any help or direction will be greatly appreciated, thanks.

I was using this tutorial http://www.gnome15.org/index.php?option=com_content&view=article&id=5&Itemid=34
Last edited by posetown on Mon Feb 13, 2012 2:57 pm, edited 1 time in total.
posetown
Level 1
Level 1
 
Posts: 3
Joined: Sun Feb 12, 2012 8:39 pm

Linux Mint is funded by ads and donations.
 

Re: gnome15 install help

Postby dwasifar on Mon Feb 13, 2012 12:22 am

No need to build from source. Install from gnome15's ppa repository instead, using the instructions here: http://www.gnome15.org/index.php?option=com_content&view=article&id=22&Itemid=33
User avatar
dwasifar
Level 4
Level 4
 
Posts: 344
Joined: Mon May 09, 2011 10:03 pm

Re: gnome15 install help

Postby posetown on Mon Feb 13, 2012 1:15 am

whoops, ive posted this in the wrong section, im using linux mint dedian sorry about that.

but i have tried the other packages.

the debian package i get this error "The following packages have unmet dependencies:
gnome15-debian : Depends: gnome15-accessibility-icons but it is not installable
E: Broken packages"

the mint package i get this error" gnome15-mint : Depends: gnome15-mono-icons but it is not installable
E: Broken packages"

so im guessing the only way to get it to work is to compile it myself.
posetown
Level 1
Level 1
 
Posts: 3
Joined: Sun Feb 12, 2012 8:39 pm

Re: gnome15 install help

Postby dwasifar on Mon Feb 13, 2012 1:51 am

I went and had a look at the repositories, and those dependencies are not there. I suspect you will have a similar problem compiling from source, but if you want to try it, the path it's looking for is /etc/udev/rules.d so I imagine it wants you to run:

Code: Select all
./configure --enable-udev=/etc/udev/rules.d
User avatar
dwasifar
Level 4
Level 4
 
Posts: 344
Joined: Mon May 09, 2011 10:03 pm

Re: gnome15 install help

Postby posetown on Mon Feb 13, 2012 2:46 pm

YES! that seems to have done the trick :D

while not 100% working for the most part it works,i will play around with it more, install the other plugins and stuff
but for now im unstuck thankyou.
posetown
Level 1
Level 1
 
Posts: 3
Joined: Sun Feb 12, 2012 8:39 pm

Re: gnome15 install help

Postby dagon on Mon Feb 13, 2012 3:03 pm

posetown wrote:whoops, ive posted this in the wrong section, im using linux mint dedian.

Moved by moderator
Image
User avatar
dagon
Level 7
Level 7
 
Posts: 1690
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 5 guests