Install vlc 2.1

Questions about applications and software
Forum rules
Before you post please read this

Install vlc 2.1

Postby c-m on Mon Feb 27, 2012 12:04 pm

How do we install vlc 2.1 on our debian editions of linux mint?

The old vlc doesn't support the broadcom crystalhd.

I've tried adding the vlc repositories and also adding the sid reposities yet after a sudo apt-get update, vlc 1.x is still listed as the latest version avilable.
c-m
Level 3
Level 3
 
Posts: 114
Joined: Mon Aug 24, 2009 2:01 pm

Linux Mint is funded by ads and donations.
 

Re: Install vlc 2.1

Postby xenopeek on Mon Feb 27, 2012 12:09 pm

Moved here by moderator
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14996
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Install vlc 2.1

Postby zerozero on Mon Feb 27, 2012 12:35 pm

you have 2.0.0-3 http://packages.debian.org/sid/vlc in sid, but i would go very carefully trying that update (vlc usually pulls deps that tend to break things :lol: )
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: Install vlc 2.1

Postby zerozero on Mon Feb 27, 2012 12:54 pm

c-m,
with (adding the sid repos to the standard incoming repos)
Code: Select all
amadeu@zerozero:~$ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream import backport romeo
           deb-src http://packages.linuxmint.com/ debian main upstream import backport romeo #Added by software-properties
           deb http://debian.linuxmint.com/incoming testing main contrib non-free
           deb http://debian.linuxmint.com/incoming/security testing/updates main contrib non-free
           deb http://debian.linuxmint.com/incoming/multimedia testing main non-free
           deb http://ftp.debian.org/debian unstable main contrib non-free
           deb http://www.debian-multimedia.org sid main non-free

i get
Code: Select all
amadeu@zerozero:~$ apt-cache policy vlc
vlc:
  Installed: 1:1.1.13-0.0
  Candidate: 1:2.0.0-0.1
  Version table:
     1:2.0.0-0.1 0
        500 http://www.debian-multimedia.org/ sid/main amd64 Packages
 *** 1:1.1.13-0.0 0
        500 http://debian.linuxmint.com/incoming/multimedia/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
     2.0.0-3 0
        500 http://ftp.debian.org/debian/ unstable/main amd64 Packages
     1.1.13-1+b1 0
        500 http://debian.linuxmint.com/incoming/ testing/main amd64 Packages
so, i have 2.0.0-3 available from sid and 2.0.0-0.1 available from debian-multimedia (and th installed v. is 1.1.13 ofc)
if i do a a apt install vlc i get the debian-multimedia one
Code: Select all
amadeu@zerozero:~$ apt install -s vlc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libpostproc52 libresid-builder0c2a libsidplay2 libvlc5 libvlccore5
  libxcb-composite0 libxcb-xfixes0 libzvbi-common libzvbi0 vlc-data vlc-nox
  vlc-plugin-notify vlc-plugin-pulse
Suggested packages:
  videolan-doc
The following packages will be REMOVED:
  libvlccore4
The following NEW packages will be installed:
  libpostproc52 libresid-builder0c2a libsidplay2 libvlccore5 libxcb-composite0
  libxcb-xfixes0 libzvbi-common libzvbi0
The following packages will be upgraded:
  libvlc5 vlc vlc-data vlc-nox vlc-plugin-notify vlc-plugin-pulse
6 upgraded, 8 newly installed, 1 to remove and 357 not upgraded.
Inst vlc-plugin-pulse [1:1.1.13-0.0] (1:2.0.0-0.1 Unofficial Multimedia Packages:None/unstable [amd64]) []
Inst vlc-plugin-notify [1:1.1.13-0.0] (1:2.0.0-0.1 Unofficial Multimedia Packages:None/unstable [amd64]) []
Inst vlc [1:1.1.13-0.0] (1:2.0.0-0.1 Unofficial Multimedia Packages:None/unstable [amd64]) []
Inst vlc-nox [1:1.1.13-0.0] (1:2.0.0-0.1 Unofficial Multimedia Packages:None/unstable [amd64]) []
Inst libvlc5 [1:1.1.13-0.0] (1:2.0.0-0.1 Unofficial Multimedia Packages:None/unstable [amd64]) []
Remv libvlccore4 [1:1.1.13-0.0] []
Inst vlc-data [1:1.1.13-0.0] (1:2.0.0-0.1 Unofficial Multimedia Packages:None/unstable [all]) []
Inst libvlccore5 (1:2.0.0-0.1 Unofficial Multimedia Packages:None/unstable [amd64]) []
Inst libxcb-composite0 (1.8-2 Debian:testing [amd64]) []
Inst libxcb-xfixes0 (1.8-2 Debian:testing [amd64]) []
Inst libpostproc52 (5:0.10-0.1 Unofficial Multimedia Packages:None/unstable [amd64]) []
Inst libresid-builder0c2a (2.1.1-13 Debian:unstable [amd64]) []
Inst libsidplay2 (2.1.1-13 Debian:unstable [amd64]) []
Inst libzvbi-common (0.2.33-4 Debian:testing [all]) []
Inst libzvbi0 (0.2.33-4 Debian:testing [amd64])
Conf libpostproc52 (5:0.10-0.1 Unofficial Multimedia Packages:None/unstable [amd64])
Conf libresid-builder0c2a (2.1.1-13 Debian:unstable [amd64])
Conf libsidplay2 (2.1.1-13 Debian:unstable [amd64])
Conf vlc-data (1:2.0.0-0.1 Unofficial Multimedia Packages:None/unstable [all])
Conf libvlccore5 (1:2.0.0-0.1 Unofficial Multimedia Packages:None/unstable [amd64])
Conf libvlc5 (1:2.0.0-0.1 Unofficial Multimedia Packages:None/unstable [amd64])
Conf libzvbi-common (0.2.33-4 Debian:testing [all])
Conf libzvbi0 (0.2.33-4 Debian:testing [amd64])
Conf vlc-nox (1:2.0.0-0.1 Unofficial Multimedia Packages:None/unstable [amd64])
Conf vlc-plugin-pulse (1:2.0.0-0.1 Unofficial Multimedia Packages:None/unstable [amd64])
Conf vlc-plugin-notify (1:2.0.0-0.1 Unofficial Multimedia Packages:None/unstable [amd64])
Conf libxcb-composite0 (1.8-2 Debian:testing [amd64])
Conf libxcb-xfixes0 (1.8-2 Debian:testing [amd64])
Conf vlc (1:2.0.0-0.1 Unofficial Multimedia Packages:None/unstable [amd64])
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm


Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 6 guests