MATE + compiz - high cpu usage

Questions about applications and software
Forum rules
Before you post please read this

Re: MATE + compiz - high cpu usage

Postby 5oak on Fri Apr 27, 2012 12:06 pm

All I had to do was rename marco to compiz in mate-conf-editor and put compiz --replace in startup programs. The 'killing' part didn't help me much. =]
User avatar
5oak
Level 1
Level 1
 
Posts: 31
Joined: Fri Jan 25, 2008 4:39 pm

Linux Mint is funded by ads and donations.
 

Re: MATE + compiz - high cpu usage

Postby dezo on Fri May 04, 2012 6:18 am

For the window-decorator used under running Compiz:
Instead of a nice window decoration similar to marco (set by mate-appearance-properties) I'm getting a strange window border which comes from who knows where (and does not follow the font size set in appearance dialog). Anyone having the same issue?
Image
The first one is what I want, the second one is what I get.
dezo
Level 2
Level 2
 
Posts: 51
Joined: Sat Apr 07, 2012 3:16 pm

Re: MATE + compiz - high cpu usage

Postby dezo on Tue May 08, 2012 5:48 pm

The answer is gconf-editor, navigate to /apps/metacity/general and change theme and titlebar_font.
dezo
Level 2
Level 2
 
Posts: 51
Joined: Sat Apr 07, 2012 3:16 pm

Re: MATE + compiz - high cpu usage

Postby cb474 on Wed Jun 20, 2012 3:40 am

bdantas wrote:LMDE UP4 with MATE here
sh -c "killall -9 marco; compiz --replace" in Startup Applications got my cpu usage down, but 2 of 4 threads still at 40-50% (even though no marco processes were running! bizarre)
Then I replaced marco with compiz in mate-conf-editor and cpu usage went down to 0-2%. Beautiful :D Thanks for the tip, axl.

Yeah, I also strangely found that neither sh -c "killall -9 marco; compiz --replace" in Startup Applications alone, nore replacing marco with compiz in mateconf-editor alone solved the problem. I have to have both. Although strangely, if I logged into a session with maro running and executed killall -9 marco; compiz --replace from a terminal within the session, then that alone worked fine to solve the CPU issue.
cb474
Level 2
Level 2
 
Posts: 52
Joined: Thu Dec 11, 2008 9:01 am

Re: MATE + compiz - high cpu usage

Postby c-m on Wed Jul 11, 2012 12:33 pm

dezo wrote:The answer is gconf-editor, navigate to /apps/metacity/general and change theme and titlebar_font.


Did you mean "mateconf-editor" and "/apps/macro/general"?

Changing that doesn't then allow you to open the "windows" icon in the control centre or change the nasty compiz default font size.

How do we fix this issue?
c-m
Level 3
Level 3
 
Posts: 114
Joined: Mon Aug 24, 2009 2:01 pm

Re: MATE + compiz - high cpu usage

Postby mint_guy on Thu Jul 12, 2012 10:35 am

I was having this issue but now it's solved. Thanks guys.

Also you don't need to kill all every boot, you can just change the default window manager to compiz in configuration editor. Funny thing is even if you don't have the high cpu load. It still plays with the smoothness of compiz. Test if you can draw the selection rectangle on your desktop smoothly. If it's not smooth then you still need to refresh compiz.

I hope that it's fixed soon, so I don't have to refresh compiz every boot. :wink:

And flash is working great under mate with compiz, unbelievable normally I have issues with full screen flash, especially when I want to change the volume (it made the video go white, because I have to tweak flash to run with gpuvalidationoverride) now it just works.

Loving Mint, best distro I have used. :D

One problem though is using autohide on the panel. It stays visible even after you run a program from the mint menu. It should hide again if anything is ran to give me full screen space. Intellihide would be better though. Small problem :wink:
mint_guy
Level 1
Level 1
 
Posts: 4
Joined: Thu Jul 12, 2012 10:14 am

Re: MATE + compiz - high cpu usage

Postby Honest Mistake on Fri Jul 13, 2012 3:04 am

c-m wrote:
dezo wrote:The answer is gconf-editor, navigate to /apps/metacity/general and change theme and titlebar_font.


Did you mean "mateconf-editor" and "/apps/macro/general"?

Changing that doesn't then allow you to open the "windows" icon in the control centre or change the nasty compiz default font size.

How do we fix this issue?

No, he's right, you can change some settings with the gconf-editor. The problem is that Compiz doesn't recognise MATE and is looking for the settings in the wrong place.
Honest Mistake
Level 1
Level 1
 
Posts: 46
Joined: Mon Mar 05, 2012 4:40 am

Re: MATE + compiz - high cpu usage

Postby alirezaimi on Sat Aug 18, 2012 10:29 am

Hi
I can not change window borders in appearance when compiz is active.
with this solution (http://bit.ly/NQ5Hvs) can not change theme or window border too! Because in my system not exist any metacity in gconf-editor But:
Code: Select all
root@ali-deb:/home/alireza# apt-cache policy metacity
metacity:
  Installed: 1:2.34.3-2
  Candidate: 1:2.34.3-3
  Version table:
     1:2.34.3-3 0
        500 http://ftp.debian.org/debian/ sid/main amd64 Packages
 *** 1:2.34.3-2 0
        500 http://ftp.debian.org/debian/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
root@ali-deb:/home/alireza# apt-cache policy gnome-themes-standard
gnome-themes-standard:
  Installed: 3.4.2-1
  Candidate: 3.4.2-1
  Version table:
 *** 3.4.2-1 0
        500 http://ftp.debian.org/debian/ testing/main amd64 Packages
        500 http://ftp.debian.org/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status

Why ? Any ideas?
Thanks.
alirezaimi
Level 2
Level 2
 
Posts: 64
Joined: Tue Feb 08, 2011 5:18 am

Re: MATE + compiz - high cpu usage

Postby graphius on Wed Aug 22, 2012 12:22 am

I started having the dreaded compiz cpu killer, and found this thread.
I tried the killall -9 marco, but got
marco: no process found


Then using mateconf-editor, I don't have a "sessions" key under desktop/mate, or anywhere for that matter.

Does it make a difference that I am using cairo dock?

any suggestions?
graphius
Level 1
Level 1
 
Posts: 5
Joined: Thu May 10, 2012 9:42 am

Re: MATE + compiz - high cpu usage

Postby mint_guy on Wed Sep 19, 2012 10:37 pm

graphius wrote:I started having the dreaded compiz cpu killer, and found this thread.
I tried the killall -9 marco, but got
marco: no process found


Then using mateconf-editor, I don't have a "sessions" key under desktop/mate, or anywhere for that matter.

Does it make a difference that I am using cairo dock?

any suggestions?



You could try something that worked for me to fix the annoying compiz = high cpu usage problem.

Follow these steps:

1. Just disable marco in configuration editor. Leave the entry blank so it doesn't load any windows borders or anything. Quicker to boot than loading marco then replacing it with compiz straight after.
2. Add compiz to your startup applications. But for the command add this: bash -c "sleep 15; compiz". You can adjust the delay to whatever you want, if it's too long or too short.

Now compiz loads a bit later allowing the desktop to load first then it loads compiz. I don't have any stuttering problems anymore with my selection rectangle on the desktop. Try drawing one to test it out.

Hope it helps :)
mint_guy
Level 1
Level 1
 
Posts: 4
Joined: Thu Jul 12, 2012 10:14 am

Linux Mint is funded by ads and donations.
 
Previous

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 12 guests