Nvidia Graphics Drivers - Install Guide

Questions about hardware and drivers
Forum rules
Before you post please read this

Re: Nvidia Graphics Drivers - Install Guide

Postby arta on Wed Apr 17, 2013 9:47 am

I've been trying to install the nvidia driver on an old HP Pavalion ZV5000 laptop running Mint Debian 201303 without much luck. I tried the excellent guide in this forum but ended up with a black screen. I ran "nvidia-detect and got the following,

art@hp-laptop ~ $ sudo nvidia-detect
[sudo] password for art:
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation NV17 [GeForce4 440 Go 64M] [10de:0179] (rev a3)
Uh oh. Your card is only supported up to the 96.43 legacy drivers series, which is no longer usable due to lack of support for current Xorg Xserver 1.12

Is there any hope for using the Nvidia driver or should I just be satisfied with the built in driver?

Thanks

arta
I have fought reality for forty years. I have finally beaten it into submission, but it's fighting back with vigor.
arta
Level 1
Level 1
 
Posts: 29
Joined: Tue Feb 26, 2008 8:28 pm
Location: Louisville, KY

Linux Mint is funded by ads and donations.
 

Re: Nvidia Graphics Drivers - Install Guide

Postby Helmsdeeper on Sun May 05, 2013 1:50 am

I just switched from my old Pny Nvidia TI4600 128mb agp 4x to a Zotac Nvidia GT610 1GB pci and followed the guide Proxima_Centauri created, blacklisting the nouveau driver. Rebooted and working like a champ. Thanks!
Helmsdeeper
Level 1
Level 1
 
Posts: 32
Joined: Mon Aug 11, 2008 2:24 am

Re: Nvidia Graphics Drivers - Install Guide

Postby Aalexeey on Sun May 26, 2013 4:34 am

Can't install/run nvidia driver again, here is the X log:
Code: Select all
[    38.116]
X.Org X Server 1.12.4
Release Date: 2012-08-27
[    38.116] X Protocol Version 11, Revision 0
[    38.116] Build Operating System: Linux 2.6.32-5-686-bigmem i686 Debian
[    38.116] Current Operating System: Linux p4i45e 3.2.0-4-686-pae #1 SMP Debian 3.2.41-2 i686
[    38.116] Kernel command line: BOOT_IMAGE=/vmlinuz-3.2.0-4-686-pae root=UUID=7c518abd-b082-4b18-a96a-e2081248dcd1 ro quiet acpi_enforce_resources=lax
[    38.116] Build Date: 17 April 2013  11:13:16AM
[    38.116] xorg-server 2:1.12.4-6 (Julien Cristau <jcristau@debian.org>)
[    38.116] Current version of pixman: 0.26.0
[    38.116]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    38.116] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    38.117] (==) Log file: "/var/log/Xorg.0.log", Time: Sat May 25 22:45:32 2013
[    38.117] (==) Using config file: "/etc/X11/xorg.conf"
[    38.117] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    38.118] (==) ServerLayout "Default Layout"
[    38.118] (**) |-->Screen "Default Screen" (0)
[    38.118] (**) |   |-->Monitor "Monitor0"
[    38.118] (**) |   |-->Device "Device0"
[    38.118] (**) |-->Input Device "Keyboard0"
[    38.118] (**) |-->Input Device "Mouse0"
[    38.118] (==) Automatically adding devices
[    38.118] (==) Automatically enabling devices
[    38.118] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/cyrillic,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
   built-ins
[    38.118] (==) ModulePath set to "/usr/lib/xorg/modules"
[    38.118] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    38.119] (WW) Disabling Keyboard0
[    38.119] (WW) Disabling Mouse0
[    38.119] (II) Loader magic: 0xb77655a0
[    38.119] (II) Module ABI versions:
[    38.119]    X.Org ANSI C Emulation: 0.4
[    38.119]    X.Org Video Driver: 12.1
[    38.119]    X.Org XInput driver : 16.0
[    38.119]    X.Org Server Extension : 6.0
[    38.120] (--) PCI:*(0:1:0:0) 10de:0326:1acc:0192 rev 161, Mem @ 0xde000000/16777216, 0xc0000000/268435456, BIOS @ 0x????????/131072
[    38.120] (II) Open ACPI successful (/var/run/acpid.socket)
[    38.120] (II) LoadModule: "extmod"
[    38.121] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[    38.122] (II) Module extmod: vendor="X.Org Foundation"
[    38.122]    compiled for 1.12.4, module version = 1.0.0
[    38.122]    Module class: X.Org Server Extension
[    38.122]    ABI class: X.Org Server Extension, version 6.0
[    38.122] (II) Loading extension SELinux
[    38.122] (II) Loading extension MIT-SCREEN-SAVER
[    38.122] (II) Loading extension XFree86-VidModeExtension
[    38.122] (II) Loading extension XFree86-DGA
[    38.122] (II) Loading extension DPMS
[    38.122] (II) Loading extension XVideo
[    38.122] (II) Loading extension XVideo-MotionCompensation
[    38.122] (II) Loading extension X-Resource
[    38.122] (II) LoadModule: "dbe"
[    38.123] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[    38.123] (II) Module dbe: vendor="X.Org Foundation"
[    38.123]    compiled for 1.12.4, module version = 1.0.0
[    38.123]    Module class: X.Org Server Extension
[    38.123]    ABI class: X.Org Server Extension, version 6.0
[    38.123] (II) Loading extension DOUBLE-BUFFER
[    38.123] (II) LoadModule: "glx"
[    38.123] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[    38.159] (II) Module glx: vendor="NVIDIA Corporation"
[    38.159]    compiled for 4.0.2, module version = 1.0.0
[    38.159]    Module class: X.Org Server Extension
[    38.159] (II) NVIDIA GLX Module  173.14.35  Thu May 31 12:34:02 PDT 2012
[    38.159] (II) Loading extension GLX
[    38.159] (II) LoadModule: "record"
[    38.160] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[    38.160] (II) Module record: vendor="X.Org Foundation"
[    38.160]    compiled for 1.12.4, module version = 1.13.0
[    38.160]    Module class: X.Org Server Extension
[    38.160]    ABI class: X.Org Server Extension, version 6.0
[    38.160] (II) Loading extension RECORD
[    38.160] (II) LoadModule: "dri"
[    38.161] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[    38.161] (II) Module dri: vendor="X.Org Foundation"
[    38.161]    compiled for 1.12.4, module version = 1.0.0
[    38.161]    ABI class: X.Org Server Extension, version 6.0
[    38.161] (II) Loading extension XFree86-DRI
[    38.162] (II) LoadModule: "dri2"
[    38.162] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[    38.162] (II) Module dri2: vendor="X.Org Foundation"
[    38.162]    compiled for 1.12.4, module version = 1.2.0
[    38.162]    ABI class: X.Org Server Extension, version 6.0
[    38.162] (II) Loading extension DRI2
[    38.162] (II) LoadModule: "nvidia"
[    38.163] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    38.164] (II) Module nvidia: vendor="NVIDIA Corporation"
[    38.164]    compiled for 4.0.2, module version = 1.0.0
[    38.164]    Module class: X.Org Video Driver
[    38.164] (II) NVIDIA dlloader X Driver  173.14.35  Thu May 31 12:10:59 PDT 2012
[    38.164] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    38.164] (++) using VT number 7

[    38.167] (II) Loading sub module "fb"
[    38.167] (II) LoadModule: "fb"
[    38.167] (II) Loading /usr/lib/xorg/modules/libfb.so
[    38.168] (II) Module fb: vendor="X.Org Foundation"
[    38.168]    compiled for 1.12.4, module version = 1.0.0
[    38.168]    ABI class: X.Org ANSI C Emulation, version 0.4
[    38.168] (II) Loading sub module "wfb"
[    38.168] (II) LoadModule: "wfb"
[    38.169] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    38.169] (II) Module wfb: vendor="X.Org Foundation"
[    38.169]    compiled for 1.12.4, module version = 1.0.0
[    38.169]    ABI class: X.Org ANSI C Emulation, version 0.4
[    38.169] (II) Loading sub module "ramdac"
[    38.169] (II) LoadModule: "ramdac"
[    38.169] (II) Module "ramdac" already built-in
[    38.170] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[    38.170] (==) NVIDIA(0): RGB weight 888
[    38.170] (==) NVIDIA(0): Default visual is TrueColor
[    38.170] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    38.170] (**) NVIDIA(0): Enabling RENDER acceleration
[    38.170] (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
[    38.170] (II) NVIDIA(0):     enabled.
[    39.135] (EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
[    39.135] (EE) NVIDIA(0):  *** Aborting ***
[    39.135] (II) UnloadModule: "nvidia"
[    39.135] (II) UnloadSubModule: "wfb"
[    39.135] (II) UnloadSubModule: "fb"
[    39.135] (EE) Screen(s) found, but none have a usable configuration.
[    39.135]
Fatal server error:
[    39.135] no screens found
[    39.135]
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    39.135] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    39.135]
[    39.141] Server terminated with error (1). Closing log file.

I tried the following:
1. ddm, after reboot the nouveau driver active
2. dpkg-reconfigure nvidia-kernel-legacy-173xx-dkms
3. nvidia-xconfig
4. deleted nouveau
MB ASRock P4I45E P4 2,4GHz HT, RAM 1GB, AGP NV5500 (NV34), SATA RocketRaid 1740; MATE 1.6 Desktop
I have nice Clonezilla back-up images, so can do anything

For "Russian speakers", I've get help here: http://debianforum.ru/index.php?topic=5220.0
Aalexeey
Level 1
Level 1
 
Posts: 24
Joined: Sat Jun 30, 2012 4:51 am

Re: Nvidia Graphics Drivers - Install Guide

Postby vebuntu on Thu Oct 24, 2013 10:14 am

i have Geforce GT240 and just tried this method and it works :D only 1 problem when i try to blacklist the open source driver
sudo echo blacklist nouveau > /etc/modprobe.d/blacklist-nouveau.conf


it will give me with (sudo)

bash: /etc/modprobe.d/blacklist-nouveau.conf: Permission denied


but anyway fully working now on debian edition thanks!! :D
vebuntu
Level 1
Level 1
 
Posts: 1
Joined: Sat Dec 01, 2012 1:50 pm

Re: Nvidia Graphics Drivers - Install Guide

Postby BBX on Sun Feb 23, 2014 5:04 pm

I followed proxima_centauri's instructions and installed NVIDIA drivers on a fresh LMDE 201403 RC install. All is working fine. :wink:
BBX
Level 1
Level 1
 
Posts: 1
Joined: Sun Feb 23, 2014 4:54 pm

Re: Nvidia Graphics Drivers - Install Guide

Postby Jasz on Sat Mar 15, 2014 8:12 am

So I've been trying to install nvidia drivers for two days now, using various methods, and nothing works. So I wanted to ask, are Optimus cards working for anyone on LMDE right now? According to this thread over at nvidia.com there are some problems with 3.10+ kernel (and I believe LMDE is on 13.11?) Simply installing the nvidia driver (from the repos, from testing, from nvidia site) breaks the X Server and using bumblebee gives a range of different errors including "falling of the bus."
Jasz
Level 1
Level 1
 
Posts: 1
Joined: Mon Nov 05, 2012 4:54 pm

Re: Nvidia Graphics Drivers - Install Guide

Postby primski on Thu Apr 10, 2014 3:21 am

I got a new laptop too that has Optimus and two graphics cards.

Nvidia 740M

I tried running nvidia-detect and it says no supported hardware found or something like that.

This is a driver issue? I don't really need this laptop for gaming, bought it for work, but if it has nvidia, that'd be cool to use.
primski
Level 1
Level 1
 
Posts: 19
Joined: Fri Nov 13, 2009 1:22 pm

Re: Nvidia Graphics Drivers - Install Guide

Postby cyb3rc0de on Tue Apr 15, 2014 5:29 am

I want to get best out of my GTS 450, every single atom of strength out of it. So, what is the best solution for me and whats IS CORRECT order to do it?

Will this method work: http://livelinux.altervista.org/Guida_L ... river.html ????

Thanks!
Proud LMDE user.
cyb3rc0de
Level 1
Level 1
 
Posts: 30
Joined: Sun Apr 13, 2014 8:56 am

Re: Nvidia Graphics Drivers - Install Guide

Postby primski on Fri Apr 18, 2014 3:07 am

sigh

back to ubuntu i guess.

does this at least work on Mint 16 ?
primski
Level 1
Level 1
 
Posts: 19
Joined: Fri Nov 13, 2009 1:22 pm

Re: Nvidia Graphics Drivers - Install Guide

Postby powerhouse on Fri Apr 18, 2014 11:44 am

primski wrote:I got a new laptop too that has Optimus and two graphics cards.

Nvidia 740M

I tried running nvidia-detect and it says no supported hardware found or something like that.

This is a driver issue? I don't really need this laptop for gaming, bought it for work, but if it has nvidia, that'd be cool to use.

Have you tried Bumblebee? I tried it with a Dell 5110 laptop and it worked fine with the IGD and the Nvidia card. It's been a while since I did that and can't remember the steps. But perhaps it's worth checking.

P.S.: I'm not familiar with how Bumblebee or the Nvidia "Optimus" technology works. It could be that by default the Nvidia card is hidden from the kernel or user programs, and only activated via some "trigger", but that is pure speculation.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 575
Joined: Thu May 03, 2012 3:54 am

Linux Mint is funded by ads and donations.
 
Previous

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 4 guests