Correct driver for HP LaserJet 2200

Questions about hardware and drivers
Forum rules
Before you post please read this

Correct driver for HP LaserJet 2200

Postby dclement on Thu May 03, 2012 9:22 am

Hello,

My LaserJet 2200d is surprisingly tricky to install under LMDE (XFCE). The recommended driver won't print (even the test page). I do have found a working driver (hpijs), but the output is far from perfect (way too much contrast in gray areas, and weird spacing when printing html pages).

Has any user found the best driver for this type of printer? Or could I just transfer the .ppd file from my previous setup under Ubuntu?

TIA - regards, Daniel
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Linux Mint is funded by ads and donations.
 

Re: Correct driver for HP LaserJet 2200

Postby mank_in on Thu May 03, 2012 9:30 am

I don't know in LMDE, but in ubuntu version i must install hplib-gui from synaptic to make HP laserjet 1006 printing. Maybe you can search in synaptic about that.
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Correct driver for HP LaserJet 2200

Postby dclement on Thu May 03, 2012 12:33 pm

Thanks, but in my case hplip-gui isn't doing a very good job:
* either I plug my HP2200 to the print server on my router (its normal condition), and hplip doesn't see it,
* either I plug it directly to an USB port. Then it gets detected and hplip suggests a driver. But it fails, and hplip then complains about communication errors.

So I have nothing better than to revert to the built-in printer management and search the best driver by trial and error.

It's all the more tedious as, every time I try to change the settings, I get this error (which can be bypassed):

Option 'printer-resolution' has value '(unknown IPP tag)' and cannot be edited.

I'm still looking for the best driver. I'm surprised to see how difficult it is, given that the HP2200 is a Postscript printer!
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Re: Correct driver for HP LaserJet 2200

Postby HogNation on Sun May 13, 2012 5:30 pm

I've had numerous problems with HP printers for some reason. The driver never works, etc, etc. Until I tried this: http://hplipopensource.com/hplip-web/install/manual/distros/ubuntu.html Follow that step by step and it should work, at least mine does anyways. Best of luck.

Here's a link strictly for Linux Mint manual installs: http://hplipopensource.com/hplip-web/install/manual/distros/linuxmint.html

Important: Make sure you remove HPLIP from the Package Manager or your install may get all screwed up. This worked for me so hopefully it will work for you as well. Either way, that website should point you in the correct direction to get your drivers working correctly.
Last edited by HogNation on Mon May 14, 2012 9:58 am, edited 2 times in total.
"Keep Calm & Call On"
Linux Number: 551803
User avatar
HogNation
Level 1
Level 1
 
Posts: 26
Joined: Mon Apr 30, 2012 11:02 am
Location: United States

Re: Correct driver for HP LaserJet 2200

Postby Oscar799 on Mon May 14, 2012 3:45 am

Moved here by moderator
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8838
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Correct driver for HP LaserJet 2200

Postby dclement on Tue May 15, 2012 2:10 am

Unfortunately, the compiled HPLIP did not do a better job than the version from the repo. in my case.
With the driver it chose, the test page took ages to print and came out with only garbage :-(

Maybe these instructions are not for LMDE.

The best result I had is with the hpijs driver, but I guess I don't get the full benefit of my postscript printer.
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Re: Correct driver for HP LaserJet 2200

Postby HogNation on Tue May 15, 2012 10:55 am

dclement wrote:Unfortunately, the compiled HPLIP did not do a better job than the version from the repo. in my case.
With the driver it chose, the test page took ages to print and came out with only garbage :-(

Maybe these instructions are not for LMDE.

The best result I had is with the hpijs driver, but I guess I don't get the full benefit of my postscript printer.


That's so odd. I have it running on LMDE on my Desktop and it prints fine, hmmm. Did you use the Debian based technique? http://hplipopensource.com/hplip-web/install/manual/distros/debian.html
"Keep Calm & Call On"
Linux Number: 551803
User avatar
HogNation
Level 1
Level 1
 
Posts: 26
Joined: Mon Apr 30, 2012 11:02 am
Location: United States

Re: Correct driver for HP LaserJet 2200

Postby dclement on Tue May 15, 2012 12:06 pm

Oops, I blindly applied the Linux Mint instructions. I again note that the hplip version suggested for Debian is but slightly newer that the one in the repos. (3.12.4 instead of 3.12.2).

My hope is in the decimals... I'll make another test and report.
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Re: Correct driver for HP LaserJet 2200

Postby HogNation on Tue May 15, 2012 1:05 pm

dclement wrote:Oops, I blindly applied the Linux Mint instructions. I again note that the hplip version suggested for Debian is but slightly newer that the one in the repos. (3.12.4 instead of 3.12.2).

My hope is in the decimals... I'll make another test and report.


Yeah the Linux Mint instructions was my error. I posted the wrong link. Hope you can get it working.
"Keep Calm & Call On"
Linux Number: 551803
User avatar
HogNation
Level 1
Level 1
 
Posts: 26
Joined: Mon Apr 30, 2012 11:02 am
Location: United States

Re: Correct driver for HP LaserJet 2200

Postby dclement on Wed May 16, 2012 11:05 am

It's weird. I was testing on a bootable USB to preserve my main HD install.

When I'm told to install a load of packages, I get errors from apt-get, first:
Code: Select all
E: Unable to locate package gs-esp

Then I try to proceed without this one (hoping it's not critical) and it gives:
Code: Select all
The following packages have unmet dependencies:
 libcupsimage2-dev : Depends: libtiff4-dev but it is not going to be installed
                     Depends: libjpeg8-dev but it is not going to be installed or
                              libjpeg-dev
 libsane-dev : Depends: libjpeg-dev
               Depends: libtiff4-dev but it is not going to be installed

These ones are surely critical so I have to give up at this point.

Now I have to inspect the repositories: I see no reason why these packages wouldn't be available when running from a liveUSB key. More testing to do...
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Re: Correct driver for HP LaserJet 2200

Postby HogNation on Wed May 16, 2012 12:21 pm

https://bugs.launchpad.net/hplip/+bug/748094

That may help get you in the right direction for your first error.
"Keep Calm & Call On"
Linux Number: 551803
User avatar
HogNation
Level 1
Level 1
 
Posts: 26
Joined: Mon Apr 30, 2012 11:02 am
Location: United States

Re: Correct driver for HP LaserJet 2200

Postby dclement on Thu May 17, 2012 10:01 am

Well this was all very frustrating. After patching (manually, because the patch is too old for the current hplip), I finally managed to compile it and run it (ver. 3.12.4).

It did not detect my HP2200 when plugged to the router, but it did when I plugged it directly to an USB port (as ver. 3.12.2 did).

Unfortunately, when I tried to print the test page, I got:
Code: Select all
lpr: HP_LaserJet_2200_hplip: unknown printer
error: Print command failed with exit code 256!

So I feel this is becoming unreasonably complicated. I've decided to stick with my current driver until perhaps some newer version of hplip hits the LMDE repos.
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 1 guest