LMDE 64-bit XFCE sound problems <SOLVED>

Questions about hardware and drivers
Forum rules
Before you post please read this

LMDE 64-bit XFCE sound problems <SOLVED>

Postby Ken_g6 on Fri May 11, 2012 1:36 pm

So, I just installed LMDE XFCE 64-bit on this old Core 2 Quad 9400 yesterday. I didn't notice until today that I had no sound. I've unmuted and turned up everything I can find from the speaker icon, with no luck. I've also gone through a couple Ubuntu sound guides, trying to sort out what's relevant for Debian. Here's the first part of what I got from alsa-info.sh:
Code: Select all
upload=true&script=true&cardinfo=
!!################################
!!ALSA Information Script v 0.4.60
!!################################

!!Script ran on: Fri May 11 16:52:20 UTC 2012


!!Linux Distribution
!!------------------

Linux Mint Xfce Edition \n \l DISTRIB_ID=LinuxMint DISTRIB_CODENAME=debian DISTRIB_DESCRIPTION="Linux Mint Xfce Edition"


!!DMI Information
!!---------------

Manufacturer:      Gigabyte Technology Co., Ltd.
Product Name:      G41M-ES2L
Product Version:   


!!Kernel Information
!!------------------

Kernel release:    3.2.0-2-amd64
Operating System:  GNU/Linux
Architecture:      x86_64
Processor:         unknown
SMP Enabled:       Yes


!!ALSA Version
!!------------

Driver version:     1.0.24
Library version:   
Utilities version:  1.0.25


!!Loaded ALSA modules
!!-------------------

snd_hda_intel


!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

ESound Daemon:
      Installed - Yes (/usr/bin/esd)
      Running - No


!!Soundcards recognised by ALSA
!!-----------------------------

 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfdff8000 irq 44


!!PCI Soundcards installed in the system
!!--------------------------------------

00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)


!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!--------------------------------------------------------

00:1b.0 0403: 8086:27d8 (rev 01)
   Subsystem: 1458:a002


!!Modprobe options (Sound related)
!!--------------------------------

snd-atiixp-modem: index=-2
snd-intel8x0m: index=-2
snd-via82xx-modem: index=-2
snd-pcsp: index=-2
snd-usb-audio: index=-2


A few things look wrong: the multiple alsa versions, the missing alsa libraries, and the non-running esound daemon. But I don't know what to do to fix any of that.

SOLVED: The second answer at this URL solved it for me. I had added the line "options snd-hda-intel model=generic" to /etc/modprobe.d/alsa-base.conf before. But I had only restarted the alsa service. Fully rebooting after doing that fixed the issue. :)
Ken_g6
Level 1
Level 1
 
Posts: 18
Joined: Fri May 11, 2012 12:43 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 3 guests